Stefano Di Paola and Giorgio Fedon have discovered some vulnerabilities in Adobe Reader, which can be exploited by malicious people to conduct cross-site scripting attacks, as a vector for conducting cross-site request forgery attacks, or potentially compromise a user's system.
1) Input passed to a hosted PDF file is not properly handled by the browser plug-in, which can be exploited to cause memory corruption and potential execution of arbitrary code.
2) Input passed to a hosted PDF file is not properly sanitised by the browser plug-in before being returned to users. This can be exploited to execute arbitrary script code in a user's browser session in context of an affected site.
It is also possible to cause the browser to stop responding by passing a lot of "#" characters.
The vulnerabilities are confirmed in Adobe Reader version 6.0.1 for Windows via Internet Explorer 6 and version 7.0.8 for Windows via Firefox 184.108.40.206. The following products are reportedly affected as well:
* Adobe Acrobat 3D
* Adobe Acrobat Standard, Professional, and Elements version 7.0.8 and prior
* other Adobe Reader versions prior to 7.0.8
Do you have additional information related to this advisory?
Please provide information about patches, mitigating factors, new versions, exploits, faulty patches, links, and other relevant data by posting comments to this Advisory. You can also send this
information to email@example.com