A vulnerability has been reported in Drupal, which can be exploited by malicious people to compromise a vulnerable system.
The vulnerability is caused due to an input sanitation error when processing comment previews (passed in the "comment" parameter in Drupal 5.x or the "edit[comment]" parameter in Drupal 4.x), which can be exploited to execute arbitrary code.
Successful exploitation requires "post comments" privileges and access to multiple input filters (not the default).
The vulnerability is reported in Drupal 4.7.x branch prior to version 4.7.6 and Drupal 5.x branch prior to version 5.1.
Solution: Apply patches or update to version 4.7.6 and 5.1.
Do you have additional information related to this advisory?
Please provide information about patches, mitigating factors, new versions, exploits, faulty patches, links, and other relevant data by posting comments to this Advisory. You can also send this
information to firstname.lastname@example.org