Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
Database
Search
Advisories by Product
Advisories by Vendor
Terminology
Report Vulnerability
Insecure Library Loading
Moderately critical

BEA Products Multiple Vulnerabilities

-

Release Date:  2007-05-15    Last Update:  2007-05-18    Views:  14,080

Secunia Advisory SA25284

Where:

From remote

Impact:

Security Bypass, Cross Site Scripting, Brute force, Exposure of sensitive information, DoS

Solution Status:

Vendor Patch

CVE Reference(s):

Description


Some vulnerabilities and two security issues have been reported in BEA WebLogic, which can be exploited by malicious users to disclose sensitive information, bypass certain security restrictions, and conduct script insertion attacks, and by malicious people to bypass certain security restrictions, brute force an administrator's password, conduct cross-site scripting attacks, and cause a DoS (Denial of Service).

1) Input passed to unspecified parameters in WebLogic Server and WebLogic Express is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

The following versions are affected:
* WebLogic Server 9.1 GA release, on all platforms
* WebLogic Server 9.0 GA release, on all platforms
* WebLogic Server 8.1 released through Service Pack 5, on all platforms.
* WebLogic Server 7.0 released through Service Pack 7, on all platforms.
* WebLogic Server 6.1 released through Service Pack 7, on all platforms.

2) An error in the processing of requests within the "HttpClusterServlet" and "HttpProxyServlet" proxy servlets, when configured with the "SecureProxy" parameter, can potentially be exploited to gain access to certain administrative resources that are only accessible to an administrator.

The following versions are affected:
* WebLogic Server 9.1 on all platforms
* WebLogic Server 9.0 on all platforms
* WebLogic Server 8.1 released through Service Pack 5, on all platforms
* WebLogic Server 7.0 released through Service Pack 7, on all platforms
* WebLogic Server 6.1 released through Service Pack 7, on all platforms

3) An error in WebLogic JMS can be exploited to bypass the front-end validation and read and write messages from a protected queue.

The following versions are affected:
* WebLogic Server 8.1 released through Service Pack 4, on all platforms
* WebLogic Server 7.0 released through Service Pack 6, on all platforms
* WebLogic Server 6.1 released through Service Pack 7, on all platforms

4) An error in the WebLogic Server embedded LDAP can be exploited to brute force an administrator's password or to cause a DoS via repeated attempts to login.

The following versions are affected:
* WebLogic Server 9.1 on all platforms
* WebLogic Server 9.0 on all platforms
* WebLogic Server 8.1 released through Service Pack 5, on all platforms
* WebLogic Server 7.0 released through Service Pack 6, on all platforms

5) An error in the "configToScript" causes sensitive attributes like the node manager password to be stored in clear text in the executable WLST script.

The following versions are affected:
* WebLogic Server 9.1 on all platforms
* WebLogic Server 9.0 on all platforms

6) An error in the Administration Console can be exploited by an Admin or Deployer to upload files for deployment, against the configured security policy.

The security issue affects the following versions:
* WebLogic Server 9.1 on all platforms
* WebLogic Server 9.0 on all platforms

7) An error in the WebLogic JMS Message Bridge can be exploited to send unauthorized messages to a queue protected by a security policy.

The following versions are affected:
* WebLogic Server 8.1 released through Service Pack 6, on all platforms
* WebLogic Server 7.0 released through Service Pack 7, on all platforms

8) An error in the WebLogic Server within the handling of SSL connections can be exploited to cause a DoS by accessing an SSL port when it is half-closed.

The following versions are affected:
* WebLogic Server 9.2 on all platforms
* WebLogic Server 9.1 on all platforms
* WebLogic Server 9.0 on all platforms

9) An error exists within the verification of certain signatures. If an RSA key with exponent 3 is used, it may be possible to forge a signature signed by that key.

The following versions are affected:
* WebLogic Server 9.2 on all platforms
* WebLogic Server 9.1 on all platforms
* WebLogic Server 9.0 on all platforms
* WebLogic Server 8.1 released through Service Pack 6, on all platforms
* WebLogic Server 7.0 released through Service Pack 7, on all platforms

10) Input passed to unspecified parameters in WebLogic Portal Groupspace is not properly sanitised before being used. This can be exploited to insert arbitrary HTML and script code, which is executed in a user's browser session in context of an affected site when the malicious data is viewed.

The following versions are affected:
* WebLogic Portal 9.2 installations using the GroupSpace application; this applies to all platform versions of WebLogic Portal 9.2 GA.

11) An error in the edit functionality for role descriptions can cause all resources that were protected to no longer be protected when entering more than 255 characters.

The security issue affects the following versions:
* WebLogic Portal 9.2 GA on all platforms.


Solution:
Apply patches (see vendor advisories for details).

Provided and/or discovered by:
1) The vendor credits ACROS Security, DV Bern AG, Application Security Inc, and GomoR.
2-11) Reported by the vendor.

Original Advisory:
1) http://dev2dev.bea.com/pub/advisory/232
2) http://dev2dev.bea.com/pub/advisory/227
3) http://dev2dev.bea.com/pub/advisory/228
4) http://dev2dev.bea.com/pub/advisory/229
5) http://dev2dev.bea.com/pub/advisory/233
6) http://dev2dev.bea.com/pub/advisory/231
7) http://dev2dev.bea.com/pub/advisory/234
8) http://dev2dev.bea.com/pub/advisory/237
9) http://dev2dev.bea.com/pub/advisory/238
10) http://dev2dev.bea.com/pub/advisory/235
11) http://dev2dev.bea.com/pub/advisory/236

Deep Links:
Links available to Secunia VIM customers

Do you have additional information related to this advisory?

Please provide information about patches, mitigating factors, new versions, exploits, faulty patches, links, and other relevant data by posting comments to this Advisory. You can also send this information to vuln@secunia.com

Subject: BEA Products Multiple Vulnerabilities

No posts yet

-

You must be logged in to post a comment.



 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Factsheets
Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability