Some vulnerabilities have been reported in Kerberos, which can be exploited by malicious users and malicious people to compromise a vulnerable system.
1) A boundary error within the implementation of the RPCSEC_GSS authentication type exists in the "svcauth_gss_validate()" function in src/lib/rpc/svc_auth_gss.c. This can be exploited to cause a stack-based buffer overflow by sending a specially crafted RPC message to a vulnerable server.
Successful exploitation potentially allows the execution of arbitrary code. Products linking to the RPC library may also be affected.
2) The "kadm5_modify_policy_internal()" function in src/lib/kadm5/srv/svr_policy.c does not correctly check return values of the "krb5_db_get_policy()" function. This can be exploited to cause a memory corruption and may potentially allow the execution of arbitrary code.
Successful exploitation requires valid user credentials and privileges to modify policies.
Vulnerability #1 is reported in krb5-1.4 through krb5-1.6.2, vulnerability #2 is reported in krb5-1.5 through krb5-1.6.2.
Solution: Update to Kerberos 1.5.5 or 1.6.3 as soon as available or apply patches.
Do you have additional information related to this advisory?
Please provide information about patches, mitigating factors, new versions, exploits, faulty patches, links, and other relevant data by posting comments to this Advisory. You can also send this
information to firstname.lastname@example.org
Subject: Kerberos Multiple Vulnerabilities
No posts yet
You must be logged in to post a comment.
Secunia Customer Login
Not a customer already?
Learn more about how our market leading Vulnerability Management solutions can help you manage risk and ensure compliance.