A vulnerability has been reported in MediaWiki, which can be exploited by malicious people to conduct cross-site scripting attacks.
Input passed via unspecified parameters to api.php is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site. The vulnerability affects users of Microsoft Internet Explorer only.
Successful exploitation requires that the API interface is enabled.
The vulnerability is reported in the following versions:
* 1.11 <= 1.11.0rc1
* 1.10 <= 1.10.2
* 1.9 <= 1.9.4
* 1.8 any version (if $wgEnableAPI has been switched on)
NOTE: MediaWiki 1.7 is reportedly not affected, but the BotQuery extension is similarly vulnerable unless updated to the latest SVN version.
Solution: Update to version 1.11.1, 1.10.3, or 1.9.5.
Do you have additional information related to this advisory?
Please provide information about patches, mitigating factors, new versions, exploits, faulty patches, links, and other relevant data by posting comments to this Advisory. You can also send this
information to firstname.lastname@example.org