A vulnerability has been reported in MediaWiki, which can be exploited by malicious people to conduct cross-site scripting attacks.
Input passed to the "useskin" parameter is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.
Successful exploitation requires that $wgUseSiteCss is enabled, which is the default.
The vulnerability is reported in version 1.12.0 and all 1.13.x versions prior to 1.13.2.
Solution: Update to version 1.12.1 or 1.13.2.
Provided and/or discovered by: Reported by the vendor.
Original Advisory: http://lists.wikimedia.org/pipermail/mediawiki-announce/2008-October/000078.html
Do you have additional information related to this advisory?
Please provide information about patches, mitigating factors, new versions, exploits, faulty patches, links, and other relevant data by posting comments to this Advisory. You can also send this
information to firstname.lastname@example.org