Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
Database
Search
Advisories by Product
Advisories by Vendor
Terminology
Report Vulnerability
Insecure Library Loading
Moderately critical

MediaWiki Multiple Vulnerabilities

-

Release Date:  2008-12-15    Last Update:  2008-12-18    Views:  8,709

Secunia Advisory SA33133

Where:

From remote

Impact:

Cross Site Scripting

Solution Status:

Vendor Patch

Software:

CVE Reference(s):

Description


Some vulnerabilities have been reported in MediaWiki, which can be exploited by malicious users to conduct script insertion attacks and by malicious people to conduct cross-site scripting and request forgery attacks.

1) Certain unspecified input is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.

The vulnerability is reported in versions 1.13.0 through 1.13.2.

2) Certain unspecified input related to uploads is not properly sanitised before being used. This can be exploited to inject arbitrary HTML and script code, which will be executed in a user's browser session in context of an affected site when a malicious data is opened.

Successful exploitation may require that uploads are enabled and the victim uses an Internet Explorer based browser.

3) Certain SVG scripts are not properly sanitised before being used. This can be exploited to inject arbitrary HTML and script code, which will be executed in a user's browser session in context of an affected site when a malicious data is opened.

Successful exploitation may require that SVG uploads are enabled and the victim uses a browser supporting SVG scripting.

4) The application allows users to perform certain actions via HTTP requests without performing any validity checks to verify the requests. This can be exploited to perform certain operations when a logged in user visits a malicious site.

The vulnerability is reported in versions since 1.3.0.


Solution:
Update to MediaWiki 1.13.3, 1.12.3 and 1.6.11 or apply patches. See vendor advisory for more details.

Further details available to Secunia VIM customers

Provided and/or discovered by:
The vendor partially credits David Remahl, Apple's Product Security.
Further information provided by the vendor.

Original Advisory:
http://lists.wikimedia.org/pipermail/mediawiki-announce/2008-December/000080.html
http://lists.wikimedia.org/pipermail/mediawiki-announce/2008-December/000081.html
http://lists.wikimedia.org/pipermail/mediawiki-announce/2008-December/000082.html

Deep Links:
Links available to Secunia VIM customers

Do you have additional information related to this advisory?

Please provide information about patches, mitigating factors, new versions, exploits, faulty patches, links, and other relevant data by posting comments to this Advisory. You can also send this information to vuln@secunia.com

Subject: MediaWiki Multiple Vulnerabilities

No posts yet

-

You must be logged in to post a comment.



 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Factsheets
Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability