Some vulnerabilities have been reported in phpMyAdmin, which can be exploited by malicious people to conduct cross-site scripting attacks or compromise a vulnerable system.
1) Input passed via export page cookies is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in the context of an affected site.
2) The vulnerability is caused due to the application not properly sanitising configuration parameters during the setup procedure. This can be exploited to inject arbitrary PHP code into the phpMyAdmin configuration file.
NOTE: Successful exploitation of this vulnerability requires that installation best-practices have not been followed and the setup scripts have not been deleted after a successful installation.
The vulnerability is reported in versions prior to 184.108.40.206 and 220.127.116.11.
Solution: Update to versions 18.104.22.168 or 22.214.171.124 or apply patches.
Do you have additional information related to this advisory?
Please provide information about patches, mitigating factors, new versions, exploits, faulty patches, links, and other relevant data by posting comments to this Advisory. You can also send this
information to email@example.com
Subject: phpMyAdmin Multiple Vulnerabilities
No posts yet
You must be logged in to post a comment.
Secunia Customer Login
Not a customer already?
Learn more about how our market leading Vulnerability Management solutions can help you manage risk and ensure compliance.