Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
Database
Search
Advisories by Product
Advisories by Vendor
Terminology
Report Vulnerability
Insecure Library Loading
Moderately critical

Gimp Multiple Vulnerabilities

-

Release Date:  2009-11-17    Last Update:  2011-05-24    Views:  4,383

Secunia Advisory SA37348

Where:

From remote

Impact:

DoS, System access

Solution Status:

Vendor Patch

Software:

CVE Reference(s):

Description


Some vulnerabilities have been reported in Gimp, which can be exploited by malicious people to cause a DoS (Denial of Service) and potentially compromise a user's system.

1) An integer overflow exists within the "read_channel_data()" function in plug-ins/file-psd/psd-load.c. This can be exploited to cause a heap-based buffer overflow by e.g. tricking a user into opening a specially crafted PSD file.

2) Boundary errors exist within the "read_rle8()" and "read_rle16()" function in plug-ins/file-sgi/sgi-lib.c, which can be exploited to cause a heap-based buffer overflow by e.g. tricking a user into opening a specially crafted SGI file.

3) Integer overflows in plug-ins/file-sgi/sgi.c may be exploited to cause heap-based buffer overflows by e.g. tricking a user into opening a specially crafted SGI file.

4) Integer overflows in plug-ins/common/file-pat.c may be exploited to cause heap-based buffer overflows by e.g. tricking a user into opening a specially crafted pattern file.

5) Integer overflows in plug-ins/common/file-gbr.c may be exploited to cause heap-based buffer overflows by e.g. tricking a user into opening a specially crafted GBR file.

6) Integer overflows in plug-ins/common/file-pcx.c may be exploited to cause heap-based buffer overflows by e.g. tricking a user into opening a specially crafted PCX file.

The vulnerabilities are reported in version 2.6.7. Prior versions may also be affected.


Solution:
Update to version 2.6.8.

Further details available to Secunia VIM customers

Provided and/or discovered by:
1) Stefan Cornelius, Secunia Research.
2-6) Disclosed in GIT commits.

Original Advisory:
Secunia Research:
http://secunia.com/secunia_research/2009-43/

2) http://git.gnome.org/browse/gimp/commit/?h=gimp-2-6&id=b428adfa9f24eceba2066f656f495b68480f6101
3) http://git.gnome.org/browse/gimp/commit/?h=gimp-2-6&id=88dfad9dc8bd9a20b46b1c3824634c969ef43986
http://git.gnome.org/browse/gimp/commit/?h=gimp-2-6&id=c54b53da5589a0eadf5fd2c8d95bf9d01ad77d34
4) http://git.gnome.org/browse/gimp/commit/?h=gimp-2-6&id=aee2bc35febf336d6b9ddba0c0a9d2883be8fd21
5) http://git.gnome.org/browse/gimp/commit/?h=gimp-2-6&id=aecccbc62cdb0e0a287502fbf34b98e2371b69b4
http://git.gnome.org/browse/gimp/commit/?h=gimp-2-6&id=343651e87f8a4227b02a34fbff4188b519417de5
6) http://git.gnome.org/browse/gimp/commit/?h=gimp-2-6&id=aaf0dfe5306f8a6bf66c927fa6c5148d9ce53c36
http://git.gnome.org/browse/gimp/commit/?h=gimp-2-6&id=5bc9aaf753eae6999fb1497e6dd19e586016e193

Deep Links:
Links available to Secunia VIM customers

Do you have additional information related to this advisory?

Please provide information about patches, mitigating factors, new versions, exploits, faulty patches, links, and other relevant data by posting comments to this Advisory. You can also send this information to vuln@secunia.com

Subject: Gimp Multiple Vulnerabilities

No posts yet

-

You must be logged in to post a comment.



 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Factsheets
Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability