Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
Database
Search
Advisories by Product
Advisories by Vendor
Terminology
Report Vulnerability
Insecure Library Loading
Highly critical

Adobe Reader/Acrobat Multiple Vulnerabilities

-

Release Date:  2010-08-04    Last Update:  2010-08-19    Views:  27,980

Secunia Advisory SA40766

Where:

From remote

Impact:

System access

Solution Status:

Vendor Patch

CVE Reference(s):

Description


Multiple vulnerabilities have been reported in in Adobe Reader / Acrobat, which can be exploited by malicious people to compromise a user's system.

1) The application bundles a vulnerable version of Flash Player (authplay.dll).

For more information:
SA40907

2) An integer overflow error in CoolType.dll when parsing the "maxCompositePoints" field value in the "maxp" (Maximum Profile) table of a TrueType font can be exploited to corrupt memory via a PDF file containing a specially crafted TrueType font.

Successful exploitation may allow execution of arbitrary code.

The vulnerability is confirmed in Adobe Reader versions 8.2.3 and 9.3.3 and Adobe Acrobat version 9.3.3. Prior versions may also be affected.


Solution:
Update to version 9.3.4 or 8.2.4.

Further details available to Secunia VIM customers

Provided and/or discovered by:
2) Charlie Miller, Independent Security Evaluators. The vendor also credits Tavis Ormandy, Google Security Team.

Original Advisory:
Crash analysis with BitBlaze (page 51 - 58):
http://securityevaluators.com/files/papers/CrashAnalysis.pdf

Adobe:
http://www.adobe.com/support/security/bulletins/apsb10-17.html

Deep Links:
Links available to Secunia VIM customers

Do you have additional information related to this advisory?

Please provide information about patches, mitigating factors, new versions, exploits, faulty patches, links, and other relevant data by posting comments to this Advisory. You can also send this information to vuln@secunia.com

Subject: Adobe Reader/Acrobat Multiple Vulnerabilities

User Message
HamitOzen RE: Adobe Reader/Acrobat Multiple Vulnerabilities
Member 14th Aug, 2010 07:39
Score: 2
Posts: 4
User Since: 27th Jun 2010
System Score: N/A
Location: TR
Last edited on 14th Aug, 2010 07:39
A PoC code for this 0-day vulnerability has been published along with detailed write-up, check this out:
https://www.rafzar.com/node/21
Was this reply relevant?
+1
-0
pc77 RE: Adobe Reader/Acrobat Multiple Vulnerabilities
Member 24th Aug, 2010 10:50
Score: 2
Posts: 5
User Since: 15th Jul 2010
System Score: N/A
Location: NL
Last edited on 24th Aug, 2010 10:50

https://www.rafzar.com/node/21

Er is een probleem met het beveiligingscertificaat van deze website.


Het certificaat van deze organisatie is ingetrokken.

Best not.

Was this reply relevant?
+0
-0

-

You must be logged in to post a comment.



 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Factsheets
Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability