Some vulnerabilities have been reported in phpMyAdmin, which can be exploited by malicious people to conduct cross-site scripting attacks.
1) Input passed via the "field_str" parameter to db_search.php , the "delimiter" parameter to db_sql.php, the "sort" parameter to db_structure.php, the "db" parameter to js/messages.php, the "sort_by" parameter to server_databases.php, the "checkprivs", "dbname", "pred_tablename", "selected_usr", "tablename", and "username" parameters to server_privileges.php, the "DefaultLang" parameter to setup/config.php, the "cpurge", "goto", "purge", "purgekey", "table", and "zero_rows" parameters to sql.php, and the "fields[multi_edit]" parameter to tbl_replace.php is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.
2) Certain unspecified input is not properly sanitised before being returned to the user. This can be exploited to execute arbitrary HTML and script code in a user's browser session in context of an affected site.
The vulnerabilities are reported in versions prior to 18.104.22.168 and 22.214.171.124.
Solution: Update to version 126.96.36.199 or 188.8.131.52.
Provided and/or discovered by: 1) Aung Khant, YGN Ethical Hacker Group
2) Reported by the vendor
Original Advisory: phpMyAdmin:
Do you have additional information related to this advisory?
Please provide information about patches, mitigating factors, new versions, exploits, faulty patches, links, and other relevant data by posting comments to this Advisory. You can also send this
information to email@example.com