Highly critical

GTK+ Insecure Library Loading Vulnerability

-

Release Date:  2011-09-05    Last Update:  2011-09-22    Views:  8,184

Secunia Advisory SA45815

Where:

Log in with your Secunia community profile. If you are an IT security professional, request a trial of the Secunia VIM.

Impact:

Log in with your Secunia community profile. If you are an IT security professional, request a trial of the Secunia VIM.

Solution Status:

Log in with your Secunia community profile. If you are an IT security professional, request a trial of the Secunia VIM.

Software:

Log in with your Secunia community profile. If you are an IT security professional, request a trial of the Secunia VIM.

CVE Reference(s):

Log in with your Secunia community profile. If you are an IT security professional, request a trial of the Secunia VIM.

Description


Naoto Katsumi has reported a vulnerability in GTK+, which can be exploited by malicious people to compromise an application using the library


Log in with your Secunia community profile to view the full description of this Advisory. If you are an IT security professional, request a trial of the Secunia VIM.

If you are not a member of the Secunia community, you can sign up here for free.

Do you have additional information related to this advisory?

Please provide information about patches, mitigating factors, new versions, exploits, faulty patches, links, and other relevant data by posting comments to this Advisory. You can also send this information to vuln@secunia.com

Subject: GTK+ Insecure Library Loading Vulnerability

User Message
earthsound RE: GTK+ Insecure Library Loading Vulnerability
Member 16th Sep, 2011 18:19
Score: -9
Posts: 14
User Since: 10th Dec 2008
System Score: N/A
Location: Hoover, AL, US
Last edited on 16th Sep, 2011 18:19
According to the advisory, versions prior to 2.21.8 are affected. I had 2.22 installed, but secunia reported it as being vulnerable.
Was this reply relevant?
+0
-0
ddmarshall RE: GTK+ Insecure Library Loading Vulnerability
Dedicated Contributor 16th Sep, 2011 19:01
Score: 1232
Posts: 979
User Since: 8th Nov 2008
System Score: 98%
Location: UK
According to this, versions prior to 2.24.0 are vulnerable.
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CV...

The Secunia recommendation to upgrade to 2.24 appears to be correct.

--
This answer is provided “as-is.” You bear the risk of using it.
Was this reply relevant?
+0
-0

-

You must be logged in to post a comment.