Multiple vulnerabilities have been reported in PostgreSQL, which can be exploited by malicious users to bypass certain security restrictions and by malicious people to conduct spoofing attacks and manipulate certain data.
1) An error due to CREATE TRIGGER not performing permission checks on a trigger function can be exploited by marking a trigger function as SECURITY DEFINER, which would grant EXECUTE permissions.
2) An error when verifying the common name within SSL certificates incorrectly truncates the name to 32 characters, which may result in successful verification of spoofed certificates.
3) An input sanitisation error in pg_dump when inserting object names into comments can be exploited to escape the comment via linefeed characters and insert a SQL command into a dump script.
The vulnerabilities are reported in versions prior to 9.1.3, 9.0.7, 8.4.11 and 8.3.18.
Solution: Update to version 9.1.3, 9.0.7, 8.4.11 or 8.3.18.
Provided and/or discovered by: Reported by the vendor.
Original Advisory: http://www.postgresql.org/about/news/1377/
Do you have additional information related to this advisory?
Please provide information about patches, mitigating factors, new versions, exploits, faulty patches, links, and other relevant data by posting comments to this Advisory. You can also send this
information to email@example.com
Subject: PostgreSQL Multiple Vulnerabilities
No posts yet
You must be logged in to post a comment.
Secunia Customer Login
Not a customer already?
Learn more about how our market leading Vulnerability Management solutions can help you manage risk and ensure compliance.