CVE Reference: CVE-2007-2692

NOTE: The text on this page is written by CVE MITRE and reflects neither the opinions of Secunia or the results of our research. All data on this page is written and maintained by CVE MITRE.

Original Page at CVE MITRE:
CVE-2007-2692

Description:
The mysql_change_db function in MySQL 5.0.x before 5.0.40 and 5.1.x before 5.1.18 does not restore THD::db_access privileges when returning from SQL SECURITY INVOKER stored routines, which allows remote authenticated users to gain privileges.

CVE Status:
Candidate

References:

XF
  http://xforce.iss.net/xforce/xfdb/34348

UBUNTU
  http://www.ubuntu.com/usn/usn-588-1

SUSE
  http://lists.opensuse.org/opensuse-security-announce/2008-02/msg00003.html

ST
  1018070

SAID
  Secunia Advisory: SA25301
  Secunia Advisory: SA30351
  Secunia Advisory: SA26073
  Secunia Advisory: SA26430
  Secunia Advisory: SA27823
  Secunia Advisory: SA28637
  Secunia Advisory: SA28838
  Secunia Advisory: SA29443

REDHAT
  http://www.redhat.com/support/errata/RHSA-2008-0364.html
  http://www.redhat.com/support/errata/RHSA-2007-0894.html

OVAL
  http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:9166

OSVDB
  34765

MLIST
  http://lists.mysql.com/announce/470

MISC
  http://bugs.mysql.com/bug.php?id=27337

MANDRIVA
  http://www.mandriva.com/security/advisories?name=MDVSA-2008:028

DEBIAN
  http://www.debian.org/security/2007/dsa-1413

CONFIRM
  http://dev.mysql.com/doc/refman/5.1/en/news-5-1-18.html

BUGTRAQ
  http://www.securityfocus.com/archive/1/archive/1/473874/100/0/threaded

BID
  24011


Return to the previous page.