CVE Reference: CVE-2007-3946

NOTE: The text on this page is written by CVE MITRE and reflects neither the opinions of Secunia or the results of our research. All data on this page is written and maintained by CVE MITRE.

Original Page at CVE MITRE:
CVE-2007-3946

Description:
mod_auth (http_auth.c) in lighttpd before 1.4.16 allows remote attackers to cause a denial of service (daemon crash) via unspecified vectors involving (1) a memory leak, (2) use of md5-sess without a cnonce, (3) base64 encoded strings, and (4) trailing whitespace in the Auth-Digest header.

CVE Status:
Candidate

References:

SUSE
  http://www.novell.com/linux/security/advisories/2007_15_sr.html

SAID
  Secunia Advisory: SA26130
  Secunia Advisory: SA26158
  Secunia Advisory: SA26505
  Secunia Advisory: SA26593

OSVDB
  38314
  38315
  38316
  38317

MISC
  http://trac.lighttpd.net/trac/changeset/1875

GENTOO
  http://security.gentoo.org/glsa/glsa-200708-11.xml

DEBIAN
  http://www.debian.org/security/2007/dsa-1362

CONFIRM
  http://trac.lighttpd.net/trac/browser/branches/lighttpd-1.4.x/NEWS?rev=1875

BUGTRAQ
  http://www.securityfocus.com/archive/1/archive/1/474131/100/0/threaded

BID
  24967


Return to the previous page.