CVE Reference: CVE-2009-1570

NOTE: The text on this page is written by CVE MITRE and reflects neither the opinions of Secunia or the results of our research. All data on this page is written and maintained by CVE MITRE.

Original Page at CVE MITRE:
CVE-2009-1570

Description:
Integer overflow in the ReadImage function in plug-ins/file-bmp/bmp-read.c in GIMP 2.6.7 might allow remote attackers to execute arbitrary code via a BMP file with crafted width and height values that trigger a heap-based buffer overflow.

CVE Status:
Candidate

References:

XF
  http://xforce.iss.net/xforce/xfdb/54254

SUSE
  http://lists.opensuse.org/opensuse-security-announce/2010-04/msg00002.html

SAID
  Secunia Advisory: SA37232
  Secunia Advisory: SA50737

REDHAT
  http://www.redhat.com/support/errata/RHSA-2011-0838.html
  http://www.redhat.com/support/errata/RHSA-2011-0837.html

OVAL
  http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:8290

OSVDB
  59930

MISC
  http://secunia.com/secunia_research/2009-42/

GENTOO
  http://security.gentoo.org/glsa/glsa-201209-23.xml

CONFIRM
  http://git.gnome.org/cgit/gimp/commit/?h=gimp-2-6&id=df2b0aca2e7cdb95ebfd3454c65aaba0a83e9bbe

BUGTRAQ
  http://www.securityfocus.com/archive/1/archive/1/507813/100/0/threaded

BID
  37006


Return to the previous page.