CVE Reference: CVE-2009-2948

NOTE: The text on this page is written by CVE MITRE and reflects neither the opinions of Secunia or the results of our research. All data on this page is written and maintained by CVE MITRE.

Original Page at CVE MITRE:
CVE-2009-2948

Description:
mount.cifs in Samba 3.0 before 3.0.37, 3.2 before 3.2.15, 3.3 before 3.3.8 and 3.4 before 3.4.2, when mount.cifs is installed suid root, does not properly enforce permissions, which allows local users to read part of the credentials file and obtain the password by specifying the path to the credentials file and using the --verbose or -v option.

CVE Status:
Candidate

References:

XF
  http://xforce.iss.net/xforce/xfdb/53574

UBUNTU
  http://www.ubuntu.com/usn/USN-839-1

SUSE
  http://lists.opensuse.org/opensuse-security-announce/2009-10/msg00004.html

ST
  1022975

SLACKWARE
  http://slackware.com/security/viewer.php?l=slackware-security&y=2009&m=slackware-security.561439

SAID
  Secunia Advisory: SA36893
  Secunia Advisory: SA36918
  Secunia Advisory: SA36937
  Secunia Advisory: SA36953

OVAL
  http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:10434
  http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:7087

OSVDB
  58520

FEDORA

CONFIRM
  http://news.samba.org/releases/3.3.8/
  http://news.samba.org/releases/3.4.2/
  http://news.samba.org/releases/3.2.15/
  http://news.samba.org/releases/3.0.37/
  http://www.samba.org/samba/security/CVE-2009-2948.html

BID
  36572


Return to the previous page.