CVE Reference: CVE-2009-4143

NOTE: The text on this page is written by CVE MITRE and reflects neither the opinions of Secunia or the results of our research. All data on this page is written and maintained by CVE MITRE.

Original Page at CVE MITRE:
CVE-2009-4143

Description:
PHP before 5.2.12 does not properly handle session data, which has unspecified impact and attack vectors related to (1) interrupt corruption of the SESSION superglobal array and (2) the session.save_path directive.

CVE Status:
Candidate

References:

SAID
  Secunia Advisory: SA37821
  Secunia Advisory: SA38648
  Secunia Advisory: SA40262
  Secunia Advisory: SA41480
  Secunia Advisory: SA41490

OVAL
  http://oval.mitre.org/repository/data/getDef?id=oval:org.mitre.oval:def:7439

MANDRIVA
  http://www.mandriva.com/security/advisories?name=MDVSA-2010:045

HP
  http://www.itrc.hp.com/service/cki/docDisplay.do?docId=emr_na-c02512995
  http://marc.info/?l=bugtraq&m=127680701405735&w=2

DEBIAN
  http://www.debian.org/security/2010/dsa-2001

CONFIRM
  http://support.apple.com/kb/HT4077
  http://www.php.net/releases/5_2_12.php
  http://www.php.net/ChangeLog-5.php

BID
  37390

APPLE
  http://lists.apple.com/archives/security-announce/2010//Mar/msg00001.html


Return to the previous page.