CVE Reference: CVE-2010-2941

NOTE: The text on this page is written by CVE MITRE and reflects neither the opinions of Secunia or the results of our research. All data on this page is written and maintained by CVE MITRE.

Original Page at CVE MITRE:
CVE-2010-2941

Description:
ipp.c in cupsd in CUPS 1.4.4 and earlier does not properly allocate memory for attribute values with invalid string data types, which allows remote attackers to cause a denial of service (use-after-free and application crash) or possibly execute arbitrary code via a crafted IPP request.

CVE Status:
Candidate

References:

XF
  http://xforce.iss.net/xforce/xfdb/62882

UBUNTU
  http://www.ubuntu.com/usn/USN-1012-1

SUSE
  http://lists.opensuse.org/opensuse-security-announce/2010-12/msg00000.html

ST
  1024662

SLACKWARE
  http://slackware.com/security/viewer.php?l=slackware-security&y=2010&m=slackware-security.468323

SAID
  Secunia Advisory: SA42287
  Secunia Advisory: SA42867
  Secunia Advisory: SA43521

REDHAT
  http://www.redhat.com/support/errata/RHSA-2010-0866.html
  http://rhn.redhat.com/errata/RHSA-2010-0811.html

OSVDB
  68951

MANDRIVA
  http://www.mandriva.com/security/advisories?name=MDVSA-2010:234
  http://www.mandriva.com/security/advisories?name=MDVSA-2010:233
  http://www.mandriva.com/security/advisories?name=MDVSA-2010:232

GENTOO
  http://security.gentoo.org/glsa/glsa-201207-10.xml

FEDORA
  http://lists.fedoraproject.org/pipermail/package-announce/2010-November/050977.html
  http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051277.html
  http://lists.fedoraproject.org/pipermail/package-announce/2010-November/051301.html

DEBIAN
  http://www.debian.org/security/2011/dsa-2176

CONFIRM
  http://blogs.sun.com/security/entry/multiple_vulnerabilities_in_mozilla_firefox
  http://support.apple.com/kb/HT4435

BID
  44530

APPLE
  http://lists.apple.com/archives/security-announce/2010//Nov/msg00000.html


Return to the previous page.