CVE Reference: CVE-2010-4824

NOTE: The text on this page is written by CVE MITRE and reflects neither the opinions of Secunia or the results of our research. All data on this page is written and maintained by CVE MITRE.

Original Page at CVE MITRE:
CVE-2010-4824

Description:
SQL injection vulnerability in the augmentSQL method in core/model/Translatable.php in SilverStripe 2.3.x before 2.3.10 and 2.4.x before 2.4.4, when the Translatable extension is enabled, allows remote attackers to execute arbitrary SQL commands via the locale parameter.

CVE Status:
Candidate

References:

XF
  http://xforce.iss.net/xforce/xfdb/63989

SAID
  Secunia Advisory: SA42346

OSVDB
  69884

MLIST
  http://www.openwall.com/lists/oss-security/2011/01/03/12
  http://www.openwall.com/lists/oss-security/2012/04/30/1
  http://www.openwall.com/lists/oss-security/2012/04/30/3
  http://www.openwall.com/lists/oss-security/2012/05/01/3

CONFIRM
  http://doc.silverstripe.org/framework/en/trunk/changelogs//2.3.10
  http://doc.silverstripe.org/framework/en/trunk/changelogs//2.4.4
  http://open.silverstripe.org/changeset/114515
  http://open.silverstripe.org/changeset/114517

BID
  45367


Return to the previous page.