CVE Reference: CVE-2011-2939

NOTE: The text on this page is written by CVE MITRE and reflects neither the opinions of Secunia or the results of our research. All data on this page is written and maintained by CVE MITRE.

Original Page at CVE MITRE:
CVE-2011-2939

Description:
Off-by-one error in the decode_xs function in Unicode/Unicode.xs in the Encode module before 2.44, as used in Perl before 5.15.6, might allow context-dependent attackers to cause a denial of service (memory corruption) via a crafted Unicode string, which triggers a heap-based buffer overflow.

CVE Status:
Candidate

References:

UBUNTU
  http://www.ubuntu.com/usn/USN-1643-1

SAID
  Secunia Advisory: SA46989
  Secunia Advisory: SA51457
  Secunia Advisory: SA46172
  Secunia Advisory: SA55314

REDHAT
  http://www.redhat.com/support/errata/RHSA-2011-1424.html

MLIST
  http://www.openwall.com/lists/oss-security/2011/08/19/17
  http://www.openwall.com/lists/oss-security/2011/08/18/8

MANDRIVA
  http://www.mandriva.com/security/advisories?name=MDVSA-2012:008

CONFIRM
  http://cpansearch.perl.org/src/FLORA/perl-5.14.2/pod/perldelta.pod
  http://search.cpan.org/~flora/perl-5.14.2/pod/perldelta.pod#Encode_decode_xs_n-byte_heap-overflow_(CVE-2011-2939)
  http://perl5.git.perl.org/perl.git/commitdiff/e46d973584785af1f445c4dedbee4243419cb860#patch5

BID
  49858


Return to the previous page.