Products
Solutions
Customers
Partner
Resources
Company
Careers
Community

CVE Reference: CVE-2012-1986

NOTE: The text on this page is written by CVE MITRE and reflects neither the opinions of Secunia or the results of our research. All data on this page is written and maintained by CVE MITRE.

Original Page at CVE MITRE:
CVE-2012-1986

Description:
Puppet 2.6.x before 2.6.15 and 2.7.x before 2.7.13, and Puppet Enterprise (PE) Users 1.0, 1.1, 1.2.x, 2.0.x, and 2.5.x before 2.5.1 allows remote authenticated users with an authorized SSL key and certain permissions on the puppet master to read arbitrary files via a symlink attack in conjunction with a crafted REST request for a file in a filebucket.

CVE Status:
Candidate

References:

XF
  http://xforce.iss.net/xforce/xfdb/74794

UBUNTU
  http://ubuntu.com/usn/usn-1419-1

SUSE

SAID
  Secunia Advisory: SA48743
  Secunia Advisory: SA48748
  Secunia Advisory: SA48789
  Secunia Advisory: SA49136

MISC
  http://projects.puppetlabs.com/issues/13511

FEDORA
  http://lists.fedoraproject.org/pipermail/package-announce/2012-May/080003.html
  http://lists.fedoraproject.org/pipermail/package-announce/2012-April/079289.html
  http://lists.fedoraproject.org/pipermail/package-announce/2012-April/079227.html

DEBIAN
  http://www.debian.org/security/2012/dsa-2451

CONFIRM
  http://puppetlabs.com/security/cve/cve-2012-1986/
  http://projects.puppetlabs.com/projects/1/wiki/Release_Notes#2.6.15

BID
  52975


Return to the previous page.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability