CVE Reference: CVE-2013-0277

NOTE: The text on this page is written by CVE MITRE and reflects neither the opinions of Secunia or the results of our research. All data on this page is written and maintained by CVE MITRE.

Original Page at CVE MITRE:
CVE-2013-0277

Description:
ActiveRecord in Ruby on Rails before 2.3.17 and 3.x before 3.1.0 allows remote attackers to cause a denial of service or execute arbitrary code via crafted serialized attributes that cause the +serialize+ helper to deserialize arbitrary YAML.

CVE Status:
Candidate

References:

SUSE
  http://lists.opensuse.org/opensuse-updates/2013-03/msg00048.html

ST
  1028109

SAID
  Secunia Advisory: SA52112

OSVDB
  90073

MLIST
  http://www.openwall.com/lists/oss-security/2013/02/11/6

DEBIAN
  http://www.debian.org/security/2013/dsa-2620

CONFIRM
  http://weblog.rubyonrails.org/2013/2/11/SEC-ANN-Rails-3-2-12-3-1-11-and-2-3-17-have-been-released/
  http://support.apple.com/kb/HT5784

APPLE
  http://lists.apple.com/archives/security-announce/2013/Jun/msg00000.html


Return to the previous page.