CVE Reference: CVE-2013-4113

NOTE: The text on this page is written by CVE MITRE and reflects neither the opinions of Secunia or the results of our research. All data on this page is written and maintained by CVE MITRE.

Original Page at CVE MITRE:
CVE-2013-4113

Description:
ext/xml/xml.c in PHP before 5.3.27 does not properly consider parsing depth, which allows remote attackers to cause a denial of service (heap memory corruption) or possibly have unspecified other impact via a crafted document that is processed by the xml_parse_into_struct function.

CVE Status:
Candidate

References:

UBUNTU
  http://www.ubuntu.com/usn/USN-1905-1

SUSE
  http://lists.opensuse.org/opensuse-security-announce/2013-07/msg00034.html
  http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00007.html
  http://lists.opensuse.org/opensuse-security-announce/2013-08/msg00006.html

SAID
  Secunia Advisory: SA54071
  Secunia Advisory: SA54104
  Secunia Advisory: SA54163
  Secunia Advisory: SA54165

REDHAT
  http://rhn.redhat.com/errata/RHSA-2013-1062.html
  http://rhn.redhat.com/errata/RHSA-2013-1063.html
  http://rhn.redhat.com/errata/RHSA-2013-1061.html
  http://rhn.redhat.com/errata/RHSA-2013-1050.html
  http://rhn.redhat.com/errata/RHSA-2013-1049.html

DEBIAN
  http://www.debian.org/security/2013/dsa-2723

CONFIRM
  http://support.apple.com/kb/HT6150
  http://php.net/archive/2013.php#id2013-07-11-1
  http://php.net/ChangeLog-5.php
  http://git.php.net/?p=php-src.git;a=commit;h=7d163e8a0880ae8af2dd869071393e5dc07ef271


Return to the previous page.