Advisories
Research
Forums
Create Profile
Our Commitment
Database
Search
Advisories by Product
Advisories by Vendor
Terminology
Report Vulnerability
Insecure Library Loading

Vulnerability Report: WordPress 2.x

This vulnerability report for WordPress 2.x contains a complete overview of all Secunia advisories affecting it. You can use this vulnerability report to ensure that you are aware of all vulnerabilities, both patched and unpatched, affecting this product allowing you to take the necessary precautions.

If you have information about a new or an existing vulnerability in WordPress 2.x then you are more than welcome to contact us.


Table of Contents

1. Product Summary Only

2. Secunia Advisory Statistics (All time)
2.1. Statistics for 2014
2.2. Statistics for 2013
2.3. Statistics for 2012
2.4. Statistics for 2011
2.5. Statistics for 2010
2.6. Statistics for 2009
2.7. Statistics for 2008
2.8. Statistics for 2007
2.9. Statistics for 2006
2.10. Statistics for 2005
2.11. Statistics for 2004
2.12. Statistics for 2003

3. List of Secunia Advisories (All time)
3.1. List for 2014
3.2. List for 2013
3.3. List for 2012
3.4. List for 2011
3.5. List for 2010
3.6. List for 2009
3.7. List for 2008
3.8. List for 2007
3.9. List for 2006
3.10. List for 2005
3.11. List for 2004
3.12. List for 2003

4. Send Feedback
 
Vendor, Links, and Unpatched Vulnerabilities

Vendor WordPress

Product Link View Here (Link to external site)

Affected By 39 Secunia advisories
57 Vulnerabilities

Monitor Product Receive alerts for this product

Unpatched 21% (8 of 39 Secunia advisories)

Most Critical Unpatched
The most severe unpatched Secunia advisory affecting WordPress 2.x, with all vendor patches applied, is rated Less critical .




22 Secunia Advisories in 2007

Secunia has issued a total of 22 Secunia advisories in 2007 for WordPress 2.x. Currently, 32% (7 out of 22) are marked as unpatched with the most severe being rated Less critical

More information about the specific Secunia advisories affecting WordPress 2.x can be found below. Each Secunia advisory is enclosed by a box highlighted with a color representing its current patch status. You can read the complete Secunia advisories for thorough descriptions of the issues covered and for solution suggestions by clicking either the Secunia advisory title or the "Read More" links available for each Secunia advisory.



WordPress Multiple Information Disclosure Vulnerabilities
Vendor Patch. Secunia Advisory 1 of 22 in 2007. 11,692 views.
Release Date:
2007-12-19
Secunia Advisory ID:
SA28130
Solution Status:
Vendor Patch
Criticality:
Impact:
Security Bypass
Exposure of system information
Exposure of sensitive information
Where:
From remote
Short Description:
Some vulnerabilities and a security issue have been reported in WordPress, which can be exploited by malicious users to disclose potentially sensitive information and by malicious people to bypass certain security restrictions and to disclose sensitive or system information. [Read More]


WordPress GBK/Big5 Character Set "s" SQL Injection
Unpatched. Secunia Advisory 2 of 22 in 2007. 13,401 views.
Release Date:
2007-12-11
Secunia Advisory ID:
SA28005
Solution Status:
Unpatched
Criticality:
Impact:
Manipulation of data
Exposure of sensitive information
Where:
From remote
Short Description:
Abel Cheung has discovered a vulnerability in WordPress, which can be exploited by malicious people to conduct SQL injection attacks. [Read More]


WordPress Cookies Security Bypass Weakness
Unpatched. Secunia Advisory 3 of 22 in 2007. 13,204 views.
Release Date:
2007-11-21
Secunia Advisory ID:
SA27714
Solution Status:
Unpatched
Criticality:
Impact:
Security Bypass
Where:
From remote
Short Description:
Steven J. Murdoch has discovered a weakness in WordPress, which can be exploited by malicious people to bypass certain security restrictions. [Read More]


WordPress "posts_columns" Cross-Site Scripting
Vendor Patch. Secunia Advisory 4 of 22 in 2007. 14,654 views.
Release Date:
2007-10-29
Secunia Advisory ID:
SA27407
Solution Status:
Vendor Patch
Criticality:
Impact:
Cross Site Scripting
Where:
From remote
Short Description:
Janek Vind has discovered a vulnerability in WordPress, which can be exploited by malicious people to conduct cross-site scripting attacks. [Read More]


WordPress Multiple Vulnerabilities
Vendor Patch. Secunia Advisory 5 of 22 in 2007. 16,800 views.
Release Date:
2007-09-12
Secunia Advisory ID:
SA26771
Solution Status:
Vendor Patch
Criticality:
Impact:
Security Bypass
Cross Site Scripting
Manipulation of data
Where:
From remote
Short Description:
Some vulnerabilities have been reported in WordPress, which can be exploited by malicious users to conduct script insertion attacks and bypass certain security restrictions, and by malicious people to conduct SQL injection attacks. [Read More]


WordPress "style" Cross-Site Scripting
Vendor Patch. Secunia Advisory 6 of 22 in 2007. 14,040 views.
Release Date:
2007-08-01
Secunia Advisory ID:
SA26296
Solution Status:
Vendor Patch
Criticality:
Impact:
Cross Site Scripting
Where:
From remote
Short Description:
Benjamin Flesch has discovered a vulnerability in WordPress, which can be exploited by malicious people to conduct cross-site scripting attacks. [Read More]


WordPress Custom Field PHP Script Upload
Vendor Patch. Secunia Advisory 7 of 22 in 2007. 18,845 views.
Release Date:
2007-06-26
Secunia Advisory ID:
SA25794
Solution Status:
Vendor Patch
Criticality:
Impact:
Security Bypass
System access
Where:
From remote
Short Description:
Alexander Concha has discovered a vulnerability in WordPress and WordPress MU, which can be exploited by malicious users to bypass certain security restrictions and to compromise a vulnerable system. [Read More]


WordPress XML-RPC "wp.suggestCategories" SQL Injection
Vendor Patch. Secunia Advisory 8 of 22 in 2007. 16,705 views.
Release Date:
2007-06-07
Secunia Advisory ID:
SA25552
Solution Status:
Vendor Patch
Criticality:
Impact:
Manipulation of data
Exposure of sensitive information
Where:
From remote
Short Description:
A vulnerability has been discovered in WordPress, which can be exploited by malicious users to conduct SQL injection attacks. [Read More]


WordPress Unmoderated Comments Disclosure and Default Theme Cross-Site Scripting
Unpatched. Secunia Advisory 9 of 22 in 2007. 12,528 views.
Release Date:
2007-06-04
Secunia Advisory ID:
SA25541
Solution Status:
Unpatched
Criticality:
Impact:
Cross Site Scripting
Exposure of sensitive information
Where:
From remote
Short Description:
A vulnerability and a security issue have been discovered in WordPress, which can be exploited by malicious people to disclose potentially sensitive information and conduct cross-site scripting attacks. [Read More]


WordPress "admin-ajax.php" SQL Injection
Vendor Patch. Secunia Advisory 10 of 22 in 2007. 23,390 views.
Release Date:
2007-05-21
Secunia Advisory ID:
SA25345
Solution Status:
Vendor Patch
Criticality:
Impact:
Manipulation of data
Exposure of sensitive information
Where:
From remote
Short Description:
Janek Vind has discovered a vulnerability in WordPress, which can be exploited by malicious people to conduct SQL injection attacks. [Read More]


WordPress Pingback Denial of Service Security Issue
Unpatched. Secunia Advisory 11 of 22 in 2007. 16,505 views.
Release Date:
2007-04-19
Secunia Advisory ID:
SA24951
Solution Status:
Unpatched
Criticality:
Impact:
DoS
Where:
From remote
Short Description:
foobarwp12 has reported a security issue in WordPress, which potentially can be exploited by malicious people to cause a DoS (Denial of Service). [Read More]


WordPress XML-RPC SQL Injection and Security Bypass
Vendor Patch. Secunia Advisory 12 of 22 in 2007. 15,975 views.
Release Date:
2007-04-04
Secunia Advisory ID:
SA24751
Solution Status:
Vendor Patch
Criticality:
Impact:
Security Bypass
Manipulation of data
Exposure of sensitive information
Where:
From remote
Short Description:
Sumit Siddharth has discovered two vulnerabilities in WordPress, which can be exploited by malicious users to conduct SQL injection attacks or to bypass certain security restrictions. [Read More]


WordPress "PHP_SELF" Cross-Site Scripting Vulnerability
Vendor Patch. Secunia Advisory 13 of 22 in 2007. 18,751 views.
Release Date:
2007-03-19
Secunia Advisory ID:
SA24567
Solution Status:
Vendor Patch
Criticality:
Impact:
Cross Site Scripting
Where:
From remote
Short Description:
A vulnerability has been discovered in WordPress, which can be exploited by malicious people to conduct cross-site scripting attacks. [Read More]


WordPress "year" Cross-Site Scripting Vulnerability
Vendor Patch. Secunia Advisory 14 of 22 in 2007. 15,996 views.
Release Date:
2007-03-12
Secunia Advisory ID:
SA24485
Solution Status:
Vendor Patch
Criticality:
Impact:
Cross Site Scripting
Where:
From remote
Short Description:
g30rg3_x has discovered a vulnerability in WordPress, which can be exploited by malicious people to conduct cross-site scripting attacks. [Read More]


WordPress "demo" Cross-Site Scripting Vulnerability
Unpatched. Secunia Advisory 15 of 22 in 2007. 18,200 views.
Release Date:
2007-03-07
Secunia Advisory ID:
SA24430
Solution Status:
Unpatched
Criticality:
Impact:
Cross Site Scripting
Where:
From remote
Short Description:
Alexander Concha has discovered a vulnerability in WordPress, which can be exploited by malicious people to conduct cross-site scripting attacks. [Read More]


WordPress Command Execution and PHP "eval()" Injection
Vendor Patch. Secunia Advisory 16 of 22 in 2007. 21,018 views.
Release Date:
2007-03-05
Secunia Advisory ID:
SA24374
Solution Status:
Vendor Patch
Criticality:
Impact:
System access
Where:
From remote
Short Description:
Ivan Fratric has reported two vulnerabilities in WordPress, which can be exploited by malicious people to compromise vulnerable systems. [Read More]


WordPress Multiple Cross-Site Scripting Vulnerabilities
Unpatched. Secunia Advisory 17 of 22 in 2007. 15,864 views.
Release Date:
2007-02-27
Secunia Advisory ID:
SA24316
Solution Status:
Unpatched
Criticality:
Impact:
Cross Site Scripting
Where:
From remote
Short Description:
Some vulnerabilities have been discovered in WordPress, which can be exploited by malicious people to conduct cross-site scripting attacks. [Read More]


WordPress templates.php Cross-Site Scripting Vulnerability
Vendor Patch. Secunia Advisory 18 of 22 in 2007. 12,387 views.
Release Date:
2007-02-26
Secunia Advisory ID:
SA24306
Solution Status:
Vendor Patch
Criticality:
Impact:
Cross Site Scripting
Where:
From remote
Short Description:
PsychoGun has discovered a vulnerability in WordPress, which can be exploited by malicious people to conduct cross-site scripting attacks. [Read More]


Wordpress Pingback Information Disclosure Vulnerability
Vendor Patch. Secunia Advisory 19 of 22 in 2007. 10,706 views.
Release Date:
2007-01-29
Secunia Advisory ID:
SA23912
Solution Status:
Vendor Patch
Criticality:
Impact:
Exposure of system information
Exposure of sensitive information
Where:
From remote
Short Description:
Blake Matheny has reported a vulnerability in Wordpress, which can potentially be exploited by malicious people to disclose sensitive information. [Read More]


Wordpress SQL Injection and Cross-Site Scripting Vulnerabilities
Vendor Patch. Secunia Advisory 20 of 22 in 2007. 20,388 views.
Release Date:
2007-01-05
Secunia Advisory ID:
SA23595
Solution Status:
Vendor Patch
Criticality:
Impact:
Cross Site Scripting
Manipulation of data
Where:
From remote
Short Description:
Stefan Esser has reported some vulnerabilities in WordPress, which can be exploited by malicious people to conduct cross-site scripting and SQL injection attacks. [Read More]


WordPress User Account Enumeration Weakness
Unpatched. Secunia Advisory 21 of 22 in 2007. 20,588 views.
Release Date:
2007-01-05
Secunia Advisory ID:
SA23621
Solution Status:
Unpatched
Criticality:
Impact:
Exposure of system information
Where:
From remote
Short Description:
A weakness has been discovered in WordPress, which can be exploited by malicious people to identify valid user accounts. [Read More]


WordPress "file" Script Insertion Vulnerability
Vendor Workaround. Secunia Advisory 22 of 22 in 2007. 24,330 views.
Release Date:
2007-01-02
Secunia Advisory ID:
SA23587
Solution Status:
Vendor Workaround
Criticality:
Impact:
Cross Site Scripting
Where:
From remote
Short Description:
David Kierznowski has discovered a vulnerability in WordPress, which can be exploited by malicious people to conduct script insertion attacks. [Read More]





Discuss this Product
A new thread in our forum is automatically created for each Product. Activate the thread by commenting/discussing below.
Subject: WordPress 2.x 
No posts yet

-

You must be logged in to post a comment.



 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability - Disclaimer