Forum Thread: swapping out newer version of Mozilla's firefox with latest versi...

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
Programs

Relating to this vendor:
Mozilla Foundation
And, this specific program:
Mozilla Firefox 7.x

This thread has been marked as locked.
bilysinger swapping out newer version of Mozilla's firefox with latest version. problem
Member 1st Oct, 2011 15:35
Ranking: 0
Posts: 1
User Since: 13th Nov, 2009
System Score: N/A
Location: N/A
It appears that Secunia complains that version 6 has reached end of life, while I have download the required remedy . Secunia still complains. I have seen another program is needed to accomplish this. What is it's source? why is it needed? and maybe it's time Secunia take a hike, as this occurs far too often to be of assistance, it ls more a pain in my a**.

Maurice Joyce RE: swapping out newer version of Mozilla's firefox with latest version. problem
Handling Contributor 1st Oct, 2011 15:52
Score: 11932
Posts: 9,159
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Last edited on 2nd Oct, 2011 11:04
Why do U want to shoot the messenger? All PSI does is reads the meta data on your PC & reports it's findings to U.

Many have complained about the frequency of the version changes made by Mozilla. Protest to them & then remove the offending browser.

Not sure I fully understand what else you are talking about. If U have End of Life programme installed it is best practise to remove/replace it with a secure version.

If U have a vulnerability we need to see the Troubleshooting report to really help.

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+6
-0
Anthony Wells RE: swapping out newer version of Mozilla's firefox with latest version. problem
Expert Contributor 2nd Oct, 2011 19:29
Score: 2472
Posts: 3,362
User Since: 19th Dec 2007
System Score: N/A
Location: N/A

HI ,

To add a little more , Firefox version 7.0 is a security update and so Ff version 6.0.x is "insecure" as well as "EOL" and would best be deleted ;-

http://www.mozilla.org/security/known-vulnerabilit...

If you want to be safe and secure when surfing , better to try and at least keep your browser(s) up to date .

That is the advice that the PSI is trying to give you ; take it or leave it , it is entirely up to you .

Take care

Anthony

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+3
-0

This thread has been marked as locked.