Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: Major problem with Google chrome in Beta 2

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
Anthony Wells Major problem with Google chrome in Beta 2
Expert Contributor 11th Apr, 2012 23:05
Ranking: 2437
Posts: 3,327
User Since: 19th Dec, 2007
System Score: N/A
Location: N/A
Last edited on 11th Apr, 2012 23:10

Hi ,

This problem may be idiosyncratic to me and I'm dead busy , so I'll be cryptic .

I have Chrome Frame IE BHO Stable version in it's default (XP) location of Programme Files and the Canary and Dev Channel versions of the browser in their default Documents and Settings - ALL versions seemingly up to date . The PSI has always detected/displayed the Frame as the Browser .

I have just run M$ updates without running a PSI scan . On reboot , a PSI tray icon popup said it had successfully scanned and was preparing programme updates - definitely NOT my choice/requirement/need ; "autoupdatoing" is deselected .

The PSI opened at the listed programmes display and showed 99% , "Chrome(Frame)" needing to be updated and ALL the rest of the progs with a red ! and contact support in the tiles . ONLY way to resolve this incorrect display was to reboot . Then I decided to try out the PSI Chrome silent installer - manual selection (BAD MOVE) .

Initially my Comodo firewall blocked this (as it was configured to so do) so I let it in and it has since continued to churn .

I get regular popups of a successful scan and preparing updates and the installer running (all other icons now are green , but there is a regular reinstall of the display) ; whichever browser is open/closed none of my Chrome installations update .

Rebooting has absolutely no effect , the installer just runs . Closing the GUI and tray stops the process whilst reinstalling from the tray sets it all back in motion and RESELECTS "start on boot" when I have deselected it ; definitely bad .

In it's current state as installed with the sua updater/installer allowed through the firewall , 3Beta2 is unusable on my system .

Will either have to reload it or reinstall 2.0.0.3003 ; will decide later when I have time .

At this stage , after the Mozilla 10.0.3 and 11.0 problem , then allowing the PSI to update your browser (manually or auto) carries problems .

AFAIK , the Chrome version I have installed 18.0.1025.151 is/was a security fix and .152 is an SSL "bug" fix with it's own bug . ?? why is PSI so keen to update ??

I will wait for Google's own silent installer to run in due course (usually slow/delayed in Frame) and see what happens . In the meantime , support might like to comment .

Gotta go .

Anthony

--


It always seems impossible until its done.
Nelson Mandela

Anthony Wells RE: Major problem with Google chrome in Beta 2
Expert Contributor 13th Apr, 2012 16:49
Score: 2437
Posts: 3,327
User Since: 19th Dec 2007
System Score: N/A
Location: N/A
Last edited on 13th Apr, 2012 16:51
Ok , it's still broke and does need fixing . The problem started after a reboot , immediately following M$ patch Tuesday updates caused the PSI to scan without my input .

1)PSI detects Chrome Frame as Chrome Browser ; it detects version 18.0.1025.151 as insecure/needing to be updated . This is not supportded by the current SA :-

http://secunia.com/advisories/48732/

even if a later "bug fix" version .152 is technically available .

2)Manual start to silent updater does not say why , how or which version is to be installed . Once started , it cannot be stopped and runs whenever the PSI is loaded ; I can stop it after closing the GUI (psi.exe) , exiting tray icon (psi_tray.exe) and then closing (via task manager) psia.exe and lastly sua.exe (in that exact order) . It restarts at the next loading of the PSI (at Boot or manual from All Programmes(XP)).

3)There is nothing to show what is going on nor any suggestion what to do .

4)A mistaken programme identification and a silent installer locks up the Beta and renders it useless/no help advised/available .

I will uninstall the Beta and see what the 2.0.0.3003 detects re Chrome and then recheck the Beta , as and when I have time .

Getting late for support , but I think they need to look at this problem ASAP .

Take care

Anthony


--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+0
-0
Anthony Wells RE: Major problem with Google chrome in Beta 2
Expert Contributor 13th Apr, 2012 17:14
Score: 2437
Posts: 3,327
User Since: 19th Dec 2007
System Score: N/A
Location: N/A

OK having just typed all that Chrome Stable versions - and this time including Frame - have just been up dated to version 18...... 162 :-

http://googlechromereleases.blogspot.fr/

The PSI has suddenly stopped whatever it was doing and turned to green and identifies my Google Chrome (whatever) as version 18.... 162 .

If I was a betting man I would put my money on this being a result for the Google Silent installer doing it's job and not the Secunia SPS untwisting it's knickers .

Still needs a big think by Support and the designers , especially regarding comments here :-

http://secunia.com/community/forum/thread/show/125...

Done for now .

Anthony

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+0
-0
mogs RE: Major problem with Google chrome in Beta 2
Expert Contributor 13th Apr, 2012 19:17
Score: 2265
Posts: 6,266
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
Last edited on 13th Apr, 2012 19:19
Hello Anthony.......just thought to mention that there is a later update to Chrome Stable and Frame.....to 18.0.1025.162 http://googlechromereleases.blogspot.co.uk/ detected all okay (Stable ) with 2.0.0.4003


Edit.....couldn't have scrolled down far enough.....missed your last post !!! Silly me !!



--
Was this reply relevant?
+0
-0
Anthony Wells RE: Major problem with Google chrome in Beta 2
Expert Contributor 13th Apr, 2012 23:12
Score: 2437
Posts: 3,327
User Since: 19th Dec 2007
System Score: N/A
Location: N/A

Hello silly you :))

A missing link , did you happen to notice if your PSI 2.x showed either of the Stable 18....151 or .152 versions as anything other than "patched/up to date" before the Google silent updater ran ??

Another anomaly is that my Beta shows the last scan as Thur 12 April (no hours precision) yet the problem was only resolved in the PSI late today (as per my 3rd post) ; the actual .162 files are stamped earlier as created on my PC at 10.52 on 13th April .

Take care

Anthony



--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+0
-0
mogs RE: Major problem with Google chrome in Beta 2
Expert Contributor 14th Apr, 2012 06:59
Score: 2265
Posts: 6,266
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
I've been updating Chrome Stable manually from here :- https://www.google.com/chrome?platform=win
Reason being that the "Update server not available ( error :3 ) when clicking Wrench/About. ( last few weeks ).
psi 2.0.0.4003 has been picking up the new version and removal of the previous sometimes ( as indicated by the balloon )....but always after a full scan, Chrome has been shown as fully patched/up to date . Also shown as Safe for Browsing in SB feature.
As I write, I do remember tho' that the silent installer did do it's job on one occasion having left it a little longer.

--
Was this reply relevant?
+0
-0
Anthony Wells RE: Major problem with Google chrome in Beta 2
Expert Contributor 15th Apr, 2012 18:11
Score: 2437
Posts: 3,327
User Since: 19th Dec 2007
System Score: N/A
Location: N/A
Last edited on 15th Apr, 2012 18:21
Hi Mogs ,

Not much further forward :(( and as I decided to drop back to 2.0.0.3003 (to check my profile) , I'm going to stay with it until Secunia can tell us what happens when the Beta is running and facing this kind of problem .

Busy for a few days , so you're in charge :))

Anthony

EDIT:PS:You clicking the wrench/about before the silent installer has run might be because it (the installer) is delayed and/or not yet available locally - hence the eror message - the silent one can be 24 hours behind the blog announce and Google website , but always before the vulnerablilties are publicly disclosed .

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+0
-0
mogs RE: Major problem with Google chrome in Beta 2
Expert Contributor 15th Apr, 2012 19:12
Score: 2265
Posts: 6,266
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
Thanks Anthony.

Thinking about it, prompted by your comments....I think it's been the case since I went back to the Stable version. I got used perhaps to a much more prompt update mechanism with the Dev and Canary....tho' did occasionally have " update server unavailable". I'll probably try one or the other again at some time.
I wished I'd held on to that 2.0.0.3003 file....the best version in recent times.....4003 not too many shortcomings tho'.

--
Was this reply relevant?
+0
-0
Maurice Joyce RE: Major problem with Google chrome in Beta 2
Handling Contributor 18th Apr, 2012 12:33
Score: 11723
Posts: 8,968
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Sadly, genuine submissions created on this Forum are getting "lost" amongst the sustained spammer attack posts being created.

I have grouped this post & others where Forum members have open questions & comments which should make it easier for Forum readers & helpers to navigate.

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability