Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: Python 3.2 marked as insecure

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
Programs

Relating to this vendor:
And, this specific program:

This thread has been marked as locked.
Jack42 Python 3.2 marked as insecure
Member 17th Jun, 2012 12:27
Ranking: 0
Posts: 4
User Since: 13th Jun, 2012
System Score: N/A
Location: UK
Last edited on 17th Jun, 2012 12:28

Hello

When I scanned my system today it showed that Python 3.3x(64-bit) was marked as insecure. I updated it but it is still marked as insecure and therefore not fixing the problem.

Here's the details from PSI:
---START---

Program Name:
Python 3.2.x(64-bit)

Security State:
Insecure

Download Link
http://www.python.org/getit/

Instances Found:
C:\Programme Files (x86)/Blender/python32.dll
C:\Programme Files/Blender Foundation/Blender/python32.dll

Last System Scan (localtime):
17. Jun 2012, 11:07

Operating System:
Microsoft Windows 7, Microsoft Windows 7

---END---

- Jack

--
Jack42

ddmarshall RE: Python 3.2 marked as insecure
Dedicated Contributor 17th Jun, 2012 13:42
Score: 1198
Posts: 954
User Since: 8th Nov 2008
System Score: 98%
Location: UK
Blender obviously has its own copy of the Python runtime in its files. Installing Pyhon will not affect that. A new version of Blender with an updated runtime would fix it.

If Secunia see this, they may modifiy their rules so that you no longer get this alert.

--
This answer is provided “as-is.” You bear the risk of using it.
Was this reply relevant?
+0
-0
Agapanthus RE: Python 3.2 marked as insecure
Member 17th Jun, 2012 19:32
Score: 0
Posts: 11
User Since: 11th Jun 2009
System Score: N/A
Location: N/A
Same problem here. Has been around for some days now.

With me too, the Blender DLL remained in place and is therefore still being flagged by PSI. I installed the latest version of Blender but this did not solve the problem. Did not find any information on the blender.org website as to how to update the Python DLL either. So I guess we'll have to wait for Secunia (or the Blender developers) to realise that there is a problem here.
Was this reply relevant?
+0
-0
Maurice Joyce RE: Python 3.2 marked as insecure
Handling Contributor 17th Jun, 2012 21:51
Score: 11569
Posts: 8,889
User Since: 4th Jan 2009
System Score: N/A
Location: UK
As stated above it is a false positive.

If U have installed Python & do not require that programme it can be safely uninstalled as it will not fix this issue.

In case they miss this thread I will ask Secunia Support to adjust their database for U.



--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+1
-1
E.Jeppesen RE: Python 3.2 marked as insecure
Secunia Official 18th Jun, 2012 09:12
Score: 220
Posts: 618
User Since: 24th Nov 2008
System Score: N/A
Location: Copenhagen, DK
A full system rescan with the PSI should now fix the issue. Thank you for reporting it.

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability