Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: Icon Does Not Change Color

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
troothteller Icon Does Not Change Color
Member 22nd Jan, 2013 17:35
Ranking: 0
Posts: 75
User Since: 10th Dec, 2010
System Score: N/A
Location: N/A
I am running version 3.0.0.3001 on both Windows 7 64-bit and XP-Pro, both notebook computers. Knowing that the matter of the icon not turning from red to green when a scan shows a perfect 100% score is an ongoing issue. I thought I would contribute my two cents. My XP-Pro has the same problem, but not the Windows 7 64-Bit. I am disappointed in the appearance of the program box, which looks more like a social network page than an application program. If there is any further testing to do, I will await a response to this posting.

Maurice Joyce RE: Icon Does Not Change Color
Handling Contributor 22nd Jan, 2013 21:13
Score: 11630
Posts: 8,917
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Last edited on 22nd Jan, 2013 21:15
PSI 3 has moved on slightly since your version. The change log & download link are here if required:

https://secunia.com/products/consumer/PSI/sys_req/


--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+0
-0
trocker RE: Icon Does Not Change Color
Member 23rd Jan, 2013 00:17
Score: 5
Posts: 11
User Since: 29th Nov 2011
System Score: N/A
Location: US

I'm having the same issue: tray icon stays red. I have the latest version (3.0.0.6001).

More disturbingly, when I look at the detailed app details, the line for PSI says it is 2.0.0.4003, but when I look on disk (via property-details on psi.exe) it says 3.0.0.6001. So it appears that scans are not actually happening, even when the "scan again" button is pressed, or there is a data issue somewhere...

Thanks.
Was this reply relevant?
+0
-0

layohei

RE: Icon Does Not Change Color
[+]
This reply has been deleted
ManFromOz RE: Icon Does Not Change Color
Member 23rd Jan, 2013 13:05
Score: 15
Posts: 101
User Since: 6th Jun 2012
System Score: 100%
Location: AU
PSi2

I am having the same problem on one of my Windows 7 SP1 x64 PCs. Red icon in the System tray, yet PSI shows 100% score.

I have tried to run a Full System Scan a few times but before it finishes I get a "Scan Aborted" message.

So far this does not affect my other PC.

ManFromOz
Was this reply relevant?
+0
-0
M.Haggqvist RE: Icon Does Not Change Color
Secunia Official 23rd Jan, 2013 14:31
Score: 10
Posts: 34
User Since: 13th Jan 2012
System Score: N/A
Location: Copenhagen, DK
Hi
It sounds like you are experiencing an issue we are currently working on, and if you would like to help us solve it, then please go to your PSI folder. You should see a file called "psialog". It is a .txt document. Can I ask you to attach that file to in an email to support@secunia.com?
We can then add the log file to our bug report which might help our developers solve the issue.

@trocker
Can I ask you to send a screenshot of your version problems with the PSI? We would like to see if its a bug.



--
Kind regards,
Martin Hggqvist
Secunia PSI Support
GeorgeYves RE: Icon Does Not Change Color
Member 23rd Jan, 2013 19:46
Score: 3
Posts: 14
User Since: 9th Feb 2012
System Score: N/A
Location: BY
Last edited on 23rd Jan, 2013 19:50
on 23rd Jan, 2013 13:05, ManFromOz wrote:
PSi2

I am having the same problem on one of my Windows 7 SP1 x64 PCs. Red icon in the System tray, yet PSI shows 100% score.

I have tried to run a Full System Scan a few times but before it finishes I get a "Scan Aborted" message.

I have the same problem too. But my system is Windows Vista Home Basic SP2 (32-bit) and the full scan isn't aborted - it never finishes and stops at the stage of retrieving the results. And it takes the program now several minutes to load its main window.

I don't understand why it happened. Yesterday the icon was green, today it is red.
Was this reply relevant?
+1
-0
trocker RE: Icon Does Not Change Color
Member 23rd Jan, 2013 23:47
Score: 5
Posts: 11
User Since: 29th Nov 2011
System Score: N/A
Location: US
Last edited on 23rd Jan, 2013 23:49
on 23rd Jan, 2013 14:31, M.Haggqvist wrote:
@trocker
Can I ask you to send a screenshot of your version problems with the PSI? We would like to see if its a bug.


Martin, I would love to, but today PSI will not open.

It takes over 30 min to get to the "you haven't run a scan lately", and when I started the scan it doesn't complete: Its been on the "scanning for outdated programs... Updating scanning results" screen for over 5 hours, while the program is idle (according to process explorer).

The timestamp on psialog.txt is from yesterday, so that wasn't updated either. I've sent you the one from yesterday in an email. My current symptoms sound just like George's.

(And just because its always the first question asked when supporting windows: yes, I had the problem after a reboot too...)

Was this reply relevant?
+1
-0
ManFromOz RE: Icon Does Not Change Color
Member 23rd Jan, 2013 23:51
Score: 15
Posts: 101
User Since: 6th Jun 2012
System Score: 100%
Location: AU
Last edited on 24th Jan, 2013 00:01
on 23rd Jan, 2013 14:31, M.Haggqvist wrote:
Hi
It sounds like you are experiencing an issue we are currently working on, and if you would like to help us solve it, then please go to your PSI folder. You should see a file called "psialog". It is a .txt document. Can I ask you to attach that file to in an email to support@secunia.com?
We can then add the log file to our bug report which might help our developers solve the issue.


The problem seems to of been corrected. System tray icon is green and shows a score of 100%. Full System scan completes now too. (although I see Adobe Flash Player Active X version has disappeared again). http://secunia.com/community/forum/thread/show/137...

Do you still require the psialog to be sent to support@secunia.com?

Thanks,
ManFromOz
Was this reply relevant?
+0
-0
YidArmy RE: Icon Does Not Change Color
Member 24th Jan, 2013 01:43
Score: 0
Posts: 1
User Since: 23rd Jan 2013
System Score: N/A
Location: UK
on 23rd Jan, 2013 23:47, trocker wrote:
Martin, I would love to, but today PSI will not open.

It takes over 30 min to get to the "you haven't run a scan lately", and when I started the scan it doesn't complete: Its been on the "scanning for outdated programs... Updating scanning results" screen for over 5 hours, while the program is idle (according to process explorer).

The timestamp on psialog.txt is from yesterday, so that wasn't updated either. I've sent you the one from yesterday in an email. My current symptoms sound just like George's.

(And just because its always the first question asked when supporting windows: yes, I had the problem after a reboot too...)


Used PSI for a while now with no problems, but today I am experiencing these same problems.

Takes a long time to load, finally get to "the havn't run a scan lately" which is wrong, starts scan gets to the end and then freezes on updating scanning results
Was this reply relevant?
+0
-0
puget1 RE: Icon Does Not Change Color
Member 24th Jan, 2013 07:24
Score: 0
Posts: 551
User Since: 21st Dec 2007
System Score: N/A
Location: US
I have had no problem with PSI 3.0.0.6001 until recently. I have now come to the conclusion ,and maybe secunia support might look at this. I think the recent problems now occuring in the U.S may be related to the tweaking of servers for the new xsi . The way to test this: if one tries to log onto the forum and it takes a increditable long time. I think this may be the proof that the servers are down or being tweaked. and why the icon and other functions appear to be amiss. All appears to straighten out during the evening hours.

--
Windows Home Basic-Service Pack 2
Dell AMD Athlon 64x2 Processor 4000+ 2.10Ghz 2Memory 32 Bit

Firefox 27+ - MS Security Essentials+Spybot-Spyware Blaster-Malwarebytes-Emsisoft Malware- Sandboxie

IE 9-seldom












Was this reply relevant?
+0
-0
M.Haggqvist RE: Icon Does Not Change Color
Secunia Official 24th Jan, 2013 13:56
Score: 10
Posts: 34
User Since: 13th Jan 2012
System Score: N/A
Location: Copenhagen, DK
Hi
We had a temporary server issue which has now been fixed.
The PSI might have to be closed completely down, that meaning the PSI window and tray icon, then it should work.

@trocker
You should now be able to open the PSI and take a screenshot.

@ManFromOz
We can only use the psialog from when the issue occurs, but feel free to send the log to support@secunia.com if you encounter the issue again


--
Kind regards,
Martin Hggqvist
Secunia PSI Support
rexjim RE: Icon Does Not Change Color
Member 29th Jan, 2013 07:03
Score: 0
Posts: 13
User Since: 4th Dec 2008
System Score: 98%
Location: UK
I have the same problem here is my psi.inf file:
;;;
;;; PSI
;;;

[Version]
Signature = "$Windows NT$"
Class = "ActivityMonitor" ;This is determined by the work this filter driver does
ClassGuid = {b86dff51-a31e-4bac-b3cf-e8cfe75c9fc2} ;This value is determined by the Class
Provider = %Company%
DriverVer = 06/03/2009,1.0.0.1

[DestinationDirs]
DefaultDestDir = 12
PSI.DriverFiles = 12 ;%windir%\system32\drivers

;;
;; Default install sections
;;

[DefaultInstall]
OptionDesc = %ServiceDescription%
CopyFiles = PSI.DriverFiles

[DefaultInstall.Services]
AddService = %ServiceName%,,PSI.Service

;;
;; Default uninstall sections
;;

[DefaultUninstall]
DelFiles = PSI.DriverFiles

[DefaultUninstall.Services]
DelService = %ServiceName%,0x200 ;Ensure service is stopped before deleting

;;
;; Services Section
;;

[PSI.Service]
DisplayName = %ServiceName%
Description = %ServiceDescription%
ServiceBinary = %12%\%DriverName%.sys ;%system32%\drivers\
Dependencies = FltMgr
ServiceType = 2 ;SERVICE_FILE_SYSTEM_DRIVER
StartType = 3 ;SERVICE_DEMAND_START
ErrorControl = 1 ;SERVICE_ERROR_NORMAL
LoadOrderGroup = "FSFilter Activity Monitor"
AddReg = PSI.AddRegistry

;;
;; Registry Modifications
;;

[PSI.AddRegistry]
HKR,"Instances","DefaultInstance",0x00000000,%Defa ultInstance%
HKR,"Instances\"%Instance1.Name%,"Altitude",0x0000 0000,%Instance1.Altitude%
HKR,"Instances\"%Instance1.Name%,"Flags",0x0001000 1,%Instance1.Flags%
HKR,"Instances\"%Instance2.Name%,"Altitude",0x0000 0000,%Instance2.Altitude%
HKR,"Instances\"%Instance2.Name%,"Flags",0x0001000 1,%Instance2.Flags%
HKR,"Instances\"%Instance3.Name%,"Altitude",0x0000 0000,%Instance3.Altitude%
HKR,"Instances\"%Instance3.Name%,"Flags",0x0001000 1,%Instance3.Flags%

;;
;; Copy Files
;;

[PSI.DriverFiles]
%DriverName%.sys

;;
;; String Section
;;

[Strings]
Company = "Secunia"
ServiceDescription = "PSI mini-filter driver"
ServiceName = "PSI"
DriverName = "psi_mf"

;Instances specific information.
DefaultInstance = "PSI - Top Instance"
Instance1.Name = "PSI - Middle Instance"
Instance1.Altitude = "370000"
Instance1.Flags = 0x1 ; Suppress automatic attachments
Instance2.Name = "PSI - Bottom Instance"
Instance2.Altitude = "361000"
Instance2.Flags = 0x1 ; Suppress automatic attachments
Instance3.Name = "PSI - Top Instance"
Instance3.Altitude = "385000"
Instance3.Flags = 0x1 ; Suppress automatic attachments

Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability