navigation bar left navigation bar right

Secunia CSI7
navigation left tab Advisories navigation right tab
navigation left tab Research navigation right tab
navigation left tab Forums navigation right tab
navigation left tab Create Profile navigation right tab
navigation left tab Our Commitment navigation right tab
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: GIMP Script-Fu Server Buffer Overflow Vulnerability

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
Vulnerabilities

See the original Secunia advisory:
GIMP Script-Fu Server Buffer Overflow Vulnerability

Secunia GIMP Script-Fu Server Buffer Overflow Vulnerability
Secunia Official 25th Mar, 2013 10:30
Ranking: 0
Posts: 0
User Since: -
System Score: -
Location: Copenhagen, DK
Reaction Information Security has discovered a vulnerability in GIMP, which can be exploited by malicious people to compromise a vulnerable system.

The vulnerability is caused due to an error within the script-fu server process when handling command input. This can be exploited to cause a buffer overflow via a specially crafted packet sent to TCP port 10008.

Successful exploitation allows execution of arbitrary code, but requires the server to be manually started.

The vulnerability is reported in versions prior to 2.8.0 (confirmed in version 2.6.11).

secunia_psi_user RE: GIMP Script-Fu Server Buffer Overflow Vulnerability
Member 25th Mar, 2013 10:30
Score: 1
Posts: 2
User Since: 25th Mar 2013
System Score: N/A
Location: RU
Last edited on 25th Mar, 2013 10:30
PSI reports GIMP 2.8.4 for Windows is vulnerable:

Technical details about this installation of GIMP 2.x (64-bit), you can use this information to determine why the Secunia PSI detected the program and the security state of it.

Version Detected:
2.8.4.0

Installation Path:
C:\Program Files\GIMP 2\bin\gimp-2.8.exe

Last Inspection of Program:
25th Mar. 2013, 10:27 CET

Is this false positive or not?
Was this reply relevant?
+0
-0
E.Jeppesen RE: GIMP Script-Fu Server Buffer Overflow Vulnerability
Secunia Official 25th Mar, 2013 13:52
Score: 220
Posts: 618
User Since: 24th Nov 2008
System Score: N/A
Location: Copenhagen, DK
Having just installed the latest version of GIMP 2.x I can at least say that this version is correctly detected as patched/up-to-date. Your installation of GIMP 2.x should also be detected as up-to-date since you have version 2.8.4 installed.

If you would like us to examine this detection issue further then you are welcome to send an email to support@secunia.com. Please include a link to this thread and a few screenshots showing the details of what the PSI has detected.
colebantam RE: GIMP Script-Fu Server Buffer Overflow Vulnerability
Member 26th Mar, 2013 13:14
Score: 7
Posts: 8
User Since: 23rd Apr 2010
System Score: N/A
Location: AT
Last edited on 26th Mar, 2013 13:35
on 25th Mar, 2013 13:52, E.Jeppesen wrote:
Having just installed the latest version of GIMP 2.x I can at least say that this version is correctly detected as patched/up-to-date. Your installation of GIMP 2.x should also be detected as up-to-date since you have version 2.8.4 installed.


It is not detected as safe. It is detected as 2.8.4.0, but it still says its unsafe, hinting I should "upgrade" to 2.8.0! Do you have installed the "official" windows 2.8.4 build by Sergej or the one from Partha? 32or 64bit Windows? I have the original Windows Build (linked on the gimp.org homepage) on 64Bit Windows 8, and it's detected as unsafe. I'm using PSI2, I guess that doesn't make any difference from 3.x versions?

Update:
Here's what PSI reports on my Gimp:
"The version detected of GIMP 2.x (64-bit) was 2.8.4.0 while the latest version including one or more security fixes is 2.8.0."
Was this reply relevant?
+0
-0
E.Jeppesen RE: GIMP Script-Fu Server Buffer Overflow Vulnerability
Secunia Official 26th Mar, 2013 14:00
Score: 220
Posts: 618
User Since: 24th Nov 2008
System Score: N/A
Location: Copenhagen, DK
@colebantam
When testing I simply used the download link that the PSI provides, which is www.gimp.org/downloads
I just tried again with the same result.

Have you tried to use this exact download link?
uniauxcsi RE: GIMP Script-Fu Server Buffer Overflow Vulnerability
Member 26th Mar, 2013 15:15
Score: 0
Posts: 1
User Since: 26th Mar 2013
System Score: N/A
Location: DE
Last edited on 26th Mar, 2013 15:23
Same problem here with CSI:

Name: GIMP 2.x
Version: 2.8.4.0
State: Insecure
SAID: SA49314

Its a fresh install of GIMP 2.8.4 and it is detected on all PCs installed with this version. It shows the gimp-2.8.exe as Insecure while the two libgtk-win32-2.0-0.dll files are shown as patched.

The GIMP Installer decides if the 32/64 bit version will be installed by the system's architecture. We have the 64bit version installed on our 64bit machines.
Was this reply relevant?
+0
-0
secunia_psi_user RE: GIMP Script-Fu Server Buffer Overflow Vulnerability
Member 27th Mar, 2013 07:43
Score: 1
Posts: 2
User Since: 25th Mar 2013
System Score: N/A
Location: RU
Last edited on 27th Mar, 2013 07:43
Problem is fixed now. After rescan GIMP is not shown as vulnerable.
Was this reply relevant?
+1
-0
colebantam RE: GIMP Script-Fu Server Buffer Overflow Vulnerability
Member 28th Mar, 2013 00:53
Score: 7
Posts: 8
User Since: 23rd Apr 2010
System Score: N/A
Location: AT
on 27th Mar, 2013 07:43, secunia_psi_user wrote:
Problem is fixed now. After rescan GIMP is not shown as vulnerable.


Well, it's true that Gimp 2.8.4 isn't erroneously detected as unsafe anymore. But I wouldn't say the issue is fixed, because on my pc, gimp isn't detected anymore at all now?! I haven't touched Gimp since my last post, and let PSI scan my system now. Happy at first look, that score is back to 100%, but then i couldn't find Gimp in the list of patched apps anymore.
Was this reply relevant?
+0
-0
mtodorov RE: GIMP Script-Fu Server Buffer Overflow Vulnerability
Member 28th Mar, 2013 15:19
Score: 12
Posts: 171
User Since: 20th Mar 2009
System Score: N/A
Location: HR
Last edited on 28th Mar, 2013 15:19
I can confirm that I have GIMP 2.8.2 installed and it isn't detected as vulnerable.

Expanding + sign next to GIMP 2.x entry we can see what lies beneath. Secunia PSI 2.0.0.4003 had reverted to detecting libgtk-win32-2.0-0.dll library.

(unknown source)

C:\Program Files\GIMP 2\bin\libgtk-win32-2.0-0.dll, version 2.24.10.0


Does this mean that GIMP may be erroneously detected? Probably, yes. libGTK is very common in GNOME apps.

Hope this helps.

Regards,
mt


--
"If a task is worth doing, it is worth doing right. If it is not worth doing well, it is not worth doing." -- Dr. Jack Hyles
<><
Was this reply relevant?
+0
-0


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


Secunia is a member of FIRST Secunia is a member of EDUcause Secunia is a member of The Open Group Secunia is a member of FS-ISAC
 
Secunia © 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability - Disclaimer
follow Secunia on Facebook follow Secunia on Twitter follow Secunia on LinkedIn follow Secunia on YouTube follow Secunia Xing follow Secunias RSS feed follow Secunia on Google+