Forum Thread: Auto-updating very slowly

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as resolved.
spartanhooah Auto-updating very slowly
Member 16th Jan, 2014 01:13
Ranking: 0
Posts: 3
User Since: 16th Jan, 2014
System Score: N/A
Location: US
Much like this (locked) thread (http://secunia.com/community/forum/thread/show/146...), PSI is taking an extraordinarily long time to update programs. I currently have 8 programs that it's updating, and it's been doing so for at least a couple of hours. How long should I expect it to take? I have a reasonably modern computer (built it about two years ago) running Windows 8.1 Pro.

Post "RE: Auto-updating very slowly" has been selected as an answer.
lampoilman RE: Auto-updating very slowly
Member 16th Jan, 2014 13:08
Score: 0
Posts: 3
User Since: 9th Feb 2013
System Score: N/A
Location: US
Last edited on 16th Jan, 2014 13:10
From my own experience and after reading reports here It is clear to me that it is neither a computer nor an installation problem. There is, in my opinion, a glitch in the coding of the app.
There appears to be a race condition possibly related to unsafe threading (though I don't actually know if this is a threaded application) or inappropriate logic loops. In any event the source code needs to be reworked by the development team. As not everyone is affected my first question would be is if the problem were specific to x64 OS
Was this reply relevant?
+0
-0
spartanhooah RE: Auto-updating very slowly
Member 16th Jan, 2014 14:11
Score: 0
Posts: 3
User Since: 16th Jan 2014
System Score: N/A
Location: US
You might be on to something with the x64. My desktop is 64-bit, but my laptop is not. My laptop had maybe 4 or 5 programs that needed to be updated (3 were Java), and although it did take quite some time, it eventually succeeded.
Was this reply relevant?
+0
-0
taffy078 RE: Auto-updating very slowly
Contributor 23rd Jan, 2014 07:51
Score: 408
Posts: 1,352
User Since: 26th Feb 2009
System Score: 100%
Location: UK
Hi. Manually updating seems to be best for Adobe in particular. Any help for you here?

http://secunia.com/community/forum/thread/show/147...

--
taffy078, West Yorkshire, UK

Desktop: Compaq Presario (OEM) 32 bit / AMD Athlon / 2 GB RAM
XP Home - SP3/ IE8/ Norton IS - Secunia PSI v2.0.0.3003

Laptop: Win 7 / IE11 / PSI v2.0.0.3003
Was this reply relevant?
+1
-0
M.Hansen RE: Auto-updating very slowly
Secunia Official 23rd Jan, 2014 08:36
Score: 188
Posts: 414
User Since: 26th Jan 2009
System Score: N/A
Location: Copenhagen, DK
Hi,

I've filed a bug-report for our developers so they can have a look at the issue.

Thank you for your feedback.
spartanhooah RE: Auto-updating very slowly
Member 23rd Jan, 2014 14:38
Score: 0
Posts: 3
User Since: 16th Jan 2014
System Score: N/A
Location: US
Last edited on 24th Jan, 2014 15:00
on 23rd Jan, 2014 07:51, taffy078 wrote:
Hi. Manually updating seems to be best for Adobe in particular. Any help for you here?

http://secunia.com/community/forum/thread/show/147...



No, none of the programs that are hanging are Adobe programs. I've got Apple QuickTime, Media Player Classic Home Cinema, and Skype trying to update.
Was this reply relevant?
+0
-0
MartinSmith RE: Auto-updating very slowly
Member 29th Jan, 2014 16:27
Score: 6
Posts: 1
User Since: 29th Jan 2014
System Score: N/A
Location: UK
I just had this issue on a couple of Flash updates that have been stuck on "updating" indefinitely (for at least a week with intervening reboots)

I killed the various psi processes, Deleted the folder C:\Program Files (x86)\Secunia\PSI\SUA and then restarted psia.exe.

This seemed to do the trick.
Was this reply relevant?
+1
-0

This thread has been marked as locked.