navigation bar left navigation bar right

Secunia CSI7
navigation left tab Advisories navigation right tab
navigation left tab Research navigation right tab
navigation left tab Forums navigation right tab
navigation left tab Create Profile navigation right tab
navigation left tab Our Commitment navigation right tab
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: PSI fails to connect to secunia server

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
noel47 PSI fails to connect to secunia server
Member 1st Jul, 2014 23:10
Ranking: 0
Posts: 3
User Since: 30th Jun, 2014
System Score: N/A
Location: DE
Last edited on 2nd Jul, 2014 15:42

Another victim of the not working PSI is petitioning for help.
Secunia PSI 2.x under Win 7 was working perfectly on my laptop for a long time. Suddenly, it started to abort scanning while trying to download the search rules again and again. First thought was to update the program to the 3.x version, which I did to no avail. The problem still was there. It did (and does) not connect to the secunia server to download the search rules, it simply get stuck, the tray icon stays grey and nothing happens any more.
So I searched the internet for solutions of that problem. After having installed all the suggestions and remedies (also out of this forum) still there is no progress. The changing of internet settings, DNS server addresses, resetting my router, switching off all firewalls and av-programs etc. didn't show any positive effects.
Are there any new ideas or remedies for that problem? Any suggestion or tip will be gratefully aknowledged.

edit:
I just found out that the necessary service "secunia update agent" is not running and so missing from the services list. Tried to start the service via sua.exe, but it didn't work, whereas the other service (secunia psi agent) is listed.
Probably this is the reason why PSI isn't working properly.
Is there a way to start the service or what is wrong with that .exe?
Btw. the (grey) tray icon on the task bar constantly is displaying the message "check your internet connection". But, my internet is fine and working properly in all other cases.

This user no longer exists RE: PSI fails to connect to secunia server
Secunia Official 3rd Jul, 2014 13:57
Hi,

Please note that this forum is only dedicated to corporate support and for issues relating to our corporate tool - the Corporate Software Inspector. For future references, please report PSI issues to our dedicated PSI forum posted below.

http://secunia.com/community/forum/psi/

Anyway though, let me provide you with feedback on your inquiry since you've already posted your comments to avoid more work for you and more delays.

Secunia actually applied new fixes on the PSI platform 2 days ago and it had resolved issues which were internal to the PSI engines. This eliminates the possibility that you are looking at an internal PSI problem as all fixes were tested properly internally and confirmed as successful.

The case characteristics you provided sound like an issue with the main PSI service. This service requires full Local Administrator privileges to run correctly. Please undertake the following test to troubleshoot:

1. Uninstall Secunia PSI completely
2. Clean the installation folders and directories
3. Open your IE and add https://*.secunia.com to the list of Trusted Sites in IE
4. Set the IE security levels to default
5. Download the PSI installer
6. Right-click on the Installer and use ''Run As Administrator'' to launch the installation.
7. After installing PSI, right-click on the PSI icon and also select ''Run as Administrator''

Further on, please do start PSI with Run As Administrator setting each time you are working with the User Interface to perform tasks in it. Otherwise, any of the PSI services may fail to perform since each of those requires the full Admin permissions.

Let us know if the above fixed the issues.
Feel free to comment under this post since we already took the question here.

Kind regards / Stay Secure
Rosen Danailov / Security+
Secunia Customer Support
klausus02 RE: PSI fails to connect to secunia server
Member 3rd Jul, 2014 16:14
Score: 4
Posts: 74
User Since: 4th Feb 2011
System Score: N/A
Location: DE
Last edited on 3rd Jul, 2014 16:23
@r.danailov

.. I know that this isn't the proper thread for my special concern. But I don't see any other topic or link to chose...


Since yesterday I'm trying to create a new thread after some time of absence. But it was not possible. I only get a page with the caption "Create a new thread" together with the hint to login to the forum. But: I'm logged in already! So, what goes wrong? What can I do? Who can I ask for help.

regards
Klaus Junke

====
solved....
Was this reply relevant?
+0
-0
noel47 RE: PSI fails to connect to secunia server
Member 3rd Jul, 2014 16:25
Score: 0
Posts: 3
User Since: 30th Jun 2014
System Score: N/A
Location: DE
Last edited on 3rd Jul, 2014 16:30
Thank you for your reply, Rosen!
I was quite sure to have posted to the right (PSI) forum. No idea how it got to the wrong place. Sorry for the inconveniance.
Anyway, I have done as you recommended, unfortunately without a positive effect. In contrast unfortunately it has got worse. Uninstallation, cleaning PSI files and folders,cleaning registry, updating internet options of the IE and subsequent new installation of the latest version of PSI didn't change the situation.
Btw. I always have run PSI (and installations) under full administrator rights in my Win 7 Home Premium.
With the old installation the GUI was loaded, only the following download of search rules was blocked. Now loading of GUI is interrupted und a notification window opens telling me that the PSI-User-ID cannot be called and that PSI is not working if a proxy is used for internet access (which I do not!). Furthermore I am asked to try to connect to hxxps://psi3.secunia.com und then run the program again. If I try to connect to that address I am redirected to hxxp://secunia.com.

One further observation might be interesting to you: Secunia PSI is not listed in the „all programs“ bar when the start button is clicked, but apears in the program list of the control panel.
To me that all is very strange because Mozilla browser and IE are workinf fine without any problems.

Thank you and regards
Klaus
Was this reply relevant?
+0
-0
Maurice Joyce RE: PSI fails to connect to secunia server
Handling Contributor 3rd Jul, 2014 19:10
Score: 11865
Posts: 9,101
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Klaus,

You have indeed posted to the correct Forum. Your original thread was to PSI - I have been asset tracking and looking for a post Secunia Support posted a long time ago to try & help you - I have now found it but have never used or tested it but here goes:

MISSING SECUNIA UPDATE AGENT

This is an exact copy of the solution to this problem provided by a Secunia Official on 8th May 2012.

"Are you comfortable with working with the command line? You need to execute the file "sua.exe" in the PSI directory with "-i -L" parameters.

First, open "cmd" as an administrative user. In Vista and Windows 7, you can type "cmd" in the Start menu and then right-click the icon to launch with elevated privileges.

Then enter this command for a 32-bit system:
cd "C:\Program Files\Secunia\PSI"

And this command for a 64-bit system:
cd "C:\Program Files (x86)\Secunia\PSI"

sua.exe -i -L

After restarting the PSI, it should now work."


For Secunia Support.

1. You are mistaken - this THREAD has always been for PSI.

2. PSI has been updated in the last two days? There is no record of that here & the download links offered remain unchanged with regards to version numbers.

https://secunia.com/products/consumer/PSI/sys_req/

Which of the many bugs were fixed & requested enhancements made in this update?

3. Maybe now we have got some attention from Secunia Support perhaps PSI & xSI support can become active - we have not heard from them for over a month despite numerous threads requiring their personal attention. Here are but a few that willing helpers cannot action.

https://secunia.com/community/forum/thread/show/15...

https://secunia.com/community/forum/thread/show/15...

https://secunia.com/community/forum/thread/show/15...












--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+0
-0
klausus02 RE: PSI fails to connect to secunia server
Member 3rd Jul, 2014 19:23
Score: 4
Posts: 74
User Since: 4th Feb 2011
System Score: N/A
Location: DE
Maurice,

thanks a lot. I discovered it was my own stupidity :-). I simply overlooked the button on the right...

regard
Klaus
Was this reply relevant?
+0
-0
noel47 RE: PSI fails to connect to secunia server
Member 3rd Jul, 2014 22:19
Score: 0
Posts: 3
User Since: 30th Jun 2014
System Score: N/A
Location: DE
Last edited on 3rd Jul, 2014 22:20
@Maurice
thank you for your suggestions. I tried as you have recommended and got the message that there is no access to the file at all.
This indicating that there is a major integrity problem on my system not related to PSI. So, I decided to install a clean image which I took a few months ago. PSI 2.x is now working fine for me again. I am going to upgrade to version 3.x now, and should there be any problems occurring I at least have learnt how to cope with them.
Thanks to all contributors giving me help and advise. I have learnt a lot, and hopefully shall be able to remedy future problems with the program.

Best regards
Klaus
Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


Secunia is a member of FIRST Secunia is a member of EDUcause Secunia is a member of The Open Group Secunia is a member of FS-ISAC
 
Secunia © 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability - Disclaimer
follow Secunia on Facebook follow Secunia on Twitter follow Secunia on LinkedIn follow Secunia on YouTube follow Secunia Xing follow Secunias RSS feed follow Secunia on Google+