navigation bar left navigation bar right

Secunia CSI7
navigation left tab Advisories navigation right tab
navigation left tab Research navigation right tab
navigation left tab Forums navigation right tab
navigation left tab Create Profile navigation right tab
navigation left tab Our Commitment navigation right tab
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: Web Browser path obtained from Registry is potentially unsafe.

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as resolved.
richardfrey11001 Web Browser path obtained from Registry is potentially unsafe.
Member 2nd Aug, 2014 16:21
Ranking: 0
Posts: 7
User Since: 3rd Jan, 2008
System Score: N/A
Location: US
Last edited on 2nd Aug, 2014 17:48

Hi All,

I have recently developed a problem with my PSI 2 (.4003). When trying to download the fix for the MSMXL 4, I get the path error. I also get the error when I try to connect to the Forum, when I click on the link in PSI 2.

I found that the community had addressed this before, but the thread was locked.

http://secunia.com/community/forum/thread/show/117...

I tried to execute the fix contained in that thread, but the registry did not contain "http" in the HKEY_CLASSES_ROOT.

The error does not contain "-nohome" after iexplore.exe.

*I can not log into the Forum when I use IE 11. I can connect to the Forum using IE 11 and scan the questions, but imputing the log in info does nothing.

*When I make Chrome the default browser, clicking the Forum link connects immediately. And now even though I have restored IE 11 as default Browser, clicking the forum link in PSI 2 will cause Chrome to call up the connection to the Forum.

I have Windows 7 SP1 X 64 with IE 11.

Richard

*=edits have been made to paragraph.

Post "RE: Web Browser path obtained from Registry is potentially unsafe." has been selected as an answer.
Maurice Joyce RE: Web Browser path obtained from Registry is potentially unsafe.
Handling Contributor 3rd Aug, 2014 12:57
Score: 11830
Posts: 9,072
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Richard,
If you want to reinstate IE 11 to your default browser the Registry string has changed from the thread you refer to.

It is now this:

https://1ncuig.bn1.livefilestore.com/y2p9vmztxkDZM...

If necessary you can use this to copy & paste the new string in the registry.

"C:\Program Files\Internet Explorer\IEXPLORE.EXE" %1

You may also wish to check your other settings using the FAQ - please note that some detail is out of date like any reference to Windows XP or OSI (both are obsolete & discontinued) & some of the registry strings for various browsers.

https://secunia.com/vulnerability_scanning/persona...

Hope this helps.

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+1
-0
richardfrey11001 RE: Web Browser path obtained from Registry is potentially unsafe.
Member 3rd Aug, 2014 18:10
Score: 0
Posts: 7
User Since: 3rd Jan 2008
System Score: N/A
Location: US
Hi Maurice,

Thanks for the quick reply.

I understand the problem. I have some computer skills, but I need a little direction. I think that IE 11 has been corrupted. When I open up HKEY_CLASSES_ROOT in regedit, there is no HTTP. It goes to HTT but has no HTTP. Another sign of a problem with IE 11 is that I can't log in to the Forum with IE 11, I have to use Chrome to log in, to post to this thread. Will uninstalling and then re-installing IE 11 fix the corruption problem?

Richard
Was this reply relevant?
+0
-0
richardfrey11001 RE: Web Browser path obtained from Registry is potentially unsafe.
Member 3rd Aug, 2014 18:26
Score: 0
Posts: 7
User Since: 3rd Jan 2008
System Score: N/A
Location: US
I just checked out Internet options>Security tab and noticed "Enable Protected Mode" was enabled. Taking the check mark out of the box-disabling Protected Mode, allows me to log in to the Forum. Weird as there is no warning that Protected mode is blocking me from logging in and doesn't give me an option to allow it. Disabling Protected Mode did not put the "HTTP" back in the registry.
Was this reply relevant?
+0
-0
richardfrey11001 RE: Web Browser path obtained from Registry is potentially unsafe.
Member 3rd Aug, 2014 19:07
Score: 0
Posts: 7
User Since: 3rd Jan 2008
System Score: N/A
Location: US
I made a mistake. I checked for http further down in the registry column and it was there. I backed up the registry and cut and pasted the info you provided and IE 11 is restored as default browser. Thank you Maurice.


Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


Secunia is a member of FIRST Secunia is a member of EDUcause Secunia is a member of The Open Group Secunia is a member of FS-ISAC
 
Secunia © 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability - Disclaimer
follow Secunia on Facebook follow Secunia on Twitter follow Secunia on LinkedIn follow Secunia on YouTube follow Secunia Xing follow Secunias RSS feed follow Secunia on Google+