Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: Links open in Firefox even though Chrome is my default browser

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
jhertel Links open in Firefox even though Chrome is my default browser
Member 30th Jun, 2009 03:08
Ranking: 1
Posts: 15
User Since: 11th Mar, 2009
System Score: 99%
Location: DK
All links from the just installed Secunia PSI 1.5.0.0 (and also the previous installation, I don't remember the version) opens in Firefox, even though Google Chrome is my default browser.

This means that I have to wait 15 to 30 seconds for Firefox to start, just when I want to follow a link from PSI.

Links from all other programs open correctly (and instantly) in Chrome.

How did Secunia PSI get the idea that it should use Firefox to open links?

I am using Windows Vista Home Premium, fully updated, and Google Chrome 2.0.172.33 (the latest and greatest).

philip42h RE: Links open in Firefox even though Chrome is my default browser
Member 4th Jul, 2009 08:41
Score: 0
Posts: 3
User Since: 4th Jul 2009
System Score: 97%
Location: UK
Last edited on 4th Jul, 2009 08:42
Forgive my piggy-backing on your thread, but I believe I'm looking for an answer to the same question ... PSI always invokes Firefox even though Internet Explorer is my default browser. (IE8 on Vista HP)

Can anyone suggest why this is so? And how to correct this behaviour?

As the OP suggested, this isn't new to PSI 1.5 but has existed for several versions ...
Was this reply relevant?
+0
-0
jhertel RE: Links open in Firefox even though Chrome is my default browser
Member 4th Jul, 2009 21:23
Score: 1
Posts: 15
User Since: 11th Mar 2009
System Score: 99%
Location: DK
Well, it looks like the exact same problem. :o)

Now I tried uninstalling Firefox, and then links from Secunia opened in Internet Explorer instead! Which is still not what I want personally... I still want it to open in my default browser, which is Chrome.

I don't want to try to uninstall Internet Explorer, as I fear that this would make my Windows system unusable.

Secunia, have you noticed this bug? How do Secunia PSI determine which browser is the default browser? Which key in the registry do you use? If you told us this, we could investigate the problem on our computers.
Was this reply relevant?
+0
-0
Old Phil RE: Links open in Firefox even though Chrome is my default browser
Member 5th Jul, 2009 00:57
Score: -1
Posts: 45
User Since: 19th Apr 2009
System Score: N/A
Location: Jamesport, US
With a start up history like Chrome has I would delete it not any of the others, check a few of the links in the Google list below. I never can understand why people try unproven things without any research, when they announced Chrome I did a weekly search to see what turned up. The Google search below is today and has grown like warts, why not dump it until they get it fixed it may be doing other harmful things!

Google results
http://www.google.com/search?q=Google+chrome+probl...

Internet Explorers (Bing results)
http://www.bing.com/search?q=Google+chrome+problem...

One should always do homework be fore leaping into things!

--
Home built fairly loaded box ASRock ConRoe1333-D667, 3.4 Intel Dual core, 2G ram, XP Home SP3 Linksys WRT160Nv2 router

733 Dell 512MB ram XP Pro SP3
Acer Aspire One baby lap top

100% Securnia score
Was this reply relevant?
+0
-1
jhertel RE: Links open in Firefox even though Chrome is my default browser
Member 5th Jul, 2009 00:59
Score: 1
Posts: 15
User Since: 11th Mar 2009
System Score: 99%
Location: DK
I should note that after installing Firefox 3.5 again, Secunia PSI still open links in Internet Explorer (IE8). Which, as I said earlier, is still not my default browser, which is Chrome.

So the problem has not been solved.
Was this reply relevant?
+0
-0
jhertel RE: Links open in Firefox even though Chrome is my default browser
Member 5th Jul, 2009 01:38
Score: 1
Posts: 15
User Since: 11th Mar 2009
System Score: 99%
Location: DK
on 5th Jul, 2009 00:57, Old Phil wrote:
With a start up history like Chrome has I would delete it not any of the others, check a few of the links in the Google list below.

What you personally think about Chrome, what your personal rules are concerning what "one" should do or should not do in life, or what you do not understand about other people seems completely off topic to this thread, and it is not helpful in any way.

Please only post about something that has to do with the actual subject.
Was this reply relevant?
+1
-0
Anthony Wells RE: Links open in Firefox even though Chrome is my default browser
Expert Contributor 6th Jul, 2009 21:24
Score: 2445
Posts: 3,332
User Since: 19th Dec 2007
System Score: N/A
Location: N/A
Last edited on 6th Jul, 2009 21:33
As it seems to be a technical problem (for you & others) why not ask "support" direct for their advice & then post their reply here (if they agree)to help the others ; otherwise you might have to wait for Secunia to pick it up .

FYI I usually leave Ff running when I go to Chrome (no special reason) ; if you can do the same , that would save a few seconds. I guess same might apply to IE (I never use it ).

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+0
-0
E.Jeppesen RE: Links open in Firefox even though Chrome is my default browser
Secunia Official 7th Jul, 2009 15:30
Score: 220
Posts: 618
User Since: 24th Nov 2008
System Score: N/A
Location: Copenhagen, DK
This is the registry key determining which default browser the PSI uses:

HKEY_CLASSES_ROOT\HTTP\shell\open\command

The browser stated in this registry key should be the one used by the PSI.

To examine the issue further we would appreciate if those experiencing the issue would provide us with the following information.

- The browser shown in the above mentioned registry key.
- Operating system and Service Packs.
- Whether you normally run as limited user or administrator (please note that to set a default browser for the PSI you need to do so as administrator).

To check the registry key:
* Click Start (and then "Run" if you are using Windows XP).
* Type regedit and press enter.
* Navigate to HKEY_CLASSES_ROOT\HTTP\shell\open\command
philip42h RE: Links open in Firefox even though Chrome is my default browser
Member 7th Jul, 2009 17:45
Score: 0
Posts: 3
User Since: 4th Jul 2009
System Score: 97%
Location: UK
As requested:
HKEY_CLASSES_ROOT\HTTP\shell\open\command contains the default string "C:\Program Files\Mozilla Firefox\firefox.exe" -requestPending -osint -url "%1" ... which rather explains why FireFox is invoked in my case.

I am running Vista SP2 from an administrator account with IE8 set as the default browser ... i.e. IE has all its defaults; Firefox has 3 of its 9 defaults and is default for the file types that IE doesn't support - .shtml, .xht, and .xhtml

How would one actually set a default browser for the PSI?
Was this reply relevant?
+0
-0
eSKzHvZreJxktYLUd4jN1oy... RE: Links open in Firefox even though Chrome is my default browser
Member 8th Jul, 2009 14:21
Score: -1
Posts: 82
User Since: 7th Dec 2009
System Score: N/A
Location: N/A
The way I understand it, the PSI looks at the registry key, so you need to change that registry key.
Have you tried to open Internet Explorer, go to Internet Explorer, then the Programs-tab and check if Internet Explorer is set to default browser? If it isn't you can press the button to make it default.

Well that's how it works in IE 8. I'm sure earlier versions have similar functionality.

Could be interesting if that changes the registry key and solves the issue.
Was this reply relevant?
+0
-0
elations RE: Links open in Firefox even though Chrome is my default browser
Member 8th Jul, 2009 18:17
Score: 1
Posts: 8
User Since: 7th Jul 2009
System Score: N/A
Location: N/A
Though I find that my default browser is being used to open Security advisories, it is always IE, apparently, that's being used to download suggested updates. Is there any way to change this behavior to make use of either default browser or a download manager? I'd prefer to download the way I'm used to, which gives me better insight in what's happening (what is the download source, which folder the download goes into, things like that) and control of the download process (resume broken download, select a download folder of choice, download from a different, preferred source, etc).
Was this reply relevant?
+0
-0
Anthony Wells RE: Links open in Firefox even though Chrome is my default browser
Expert Contributor 8th Jul, 2009 18:29
Score: 2445
Posts: 3,332
User Since: 19th Dec 2007
System Score: N/A
Location: N/A
If you open this page in your chosen browser ,in the top bar click on "Vulnerability Scanning" tab -> Personal PSI tab and you will have Download options on the right of the page .
If you are referring to .dll updates you'll maybe need to clarify with Secunia directly.

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+0
-0
elations RE: Links open in Firefox even though Chrome is my default browser
Member 8th Jul, 2009 19:11
Score: 1
Posts: 8
User Since: 7th Jul 2009
System Score: N/A
Location: N/A
Last edited on 8th Jul, 2009 19:16
on 8th Jul, 2009 18:29, Anthony Wells wrote:
If you open this page in your chosen browser ,in the top bar click on "Vulnerability Scanning" tab -> Personal PSI tab and you will have Download options on the right of the page .


From what I see, this gives me the option to download PSI. What I was referring to was after having installed PSI and done the system scan, then, as part of the options given with each insecure program is a download option to directly download/install the patched version of the insecure application (provided one has been released, of course). Let's say this is, as so often, Adobe Flash Player plugin. Clicking the download link from within PSI will start a direct download that automatically proceeds to installation. I'd prefer PSI gave me the option to use my default browser or a download manager and specify the download folder too. One advantage of being given this option would be that once the download is done, I could re-use the upgrade should it become necessary (if the update fails, if I have a second or third computer or a dual boot system, or if I run into problems and need to restore the system from a backup image). The way it is now, clicking that link is only good for a single install at best, sometimes not even that (e.g. if the download fails/gets corrupted/interrupted or the installation doesn't complete successfully).


on 8th Jul, 2009 18:29, Anthony Wells wrote:
If you are referring to .dll updates you'll maybe need to clarify with Secunia directly.


Not quite sure what you mean by that, perhaps that's what I meant in short words ;)
Was this reply relevant?
+0
-0
Anthony Wells RE: Links open in Firefox even though Chrome is my default browser
Expert Contributor 8th Jul, 2009 19:52
Score: 2445
Posts: 3,332
User Since: 19th Dec 2007
System Score: N/A
Location: N/A
Last edited on 8th Jul, 2009 19:57
Elations ,

In my experience & no criticism to Secunia , I seem to get better results - I also feel I have more control - after a Secunia warning if I go , in my chosen browser ,to the relevant website or use CleanSofts.org "update notifier" or FileHippo or whatever to download - normally to Program Files , sometimes to Desktop - the latest version installer/updater ; I certainly do this for Flash , Shockwave and Chrome. I use the Java website directly. I update Adobe Reader from within it's own Help menu .

Sometimes I do a delete/clean install ,sometimes just an overinstall - depends on the suppliers advice .

This may not answer your question directly , but is my "workaround" of Secunia "solution" links not suiting me. I have experienced very few problems this way.

The .dll reference relates to your thread on Psires.dll - please excuse my shortcut - one finger typist:((

Take care Anthony

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+0
-0
elations RE: Links open in Firefox even though Chrome is my default browser
Member 8th Jul, 2009 20:17
Score: 1
Posts: 8
User Since: 7th Jul 2009
System Score: N/A
Location: N/A
Yes, now we understand each other. I use exactly the same "workarounds" you use, and the apps you quote are exactly the ones I've experienced as troublesome (except Adobe Reader - I switched to Foxit for speed - and Chrome - I stick with Opera which I've been very satisfied with for more than a decade).

But as you confirmed, working around is more satisfactory when it comes to downloading solutions, so my suggestion was really just asking, why not improve the download options directly available from within PSI? One will probably still sometimes prefer to go to certain sites for updates, but allowing to use one's default download program would, at least, reduce the necessity to do that... at least sometimes ;)

BTW, I was a bit too harsh perhaps when criticizing the available options, having not used the direct download from within PSI for ages. Maybe it was improved a bit because, when I tested a few minutes ago starting the download of an update to an "unpatched" program (actually just an unused installer left over from long ago), I was given the option to download the program in question to a location of my choice.
Was this reply relevant?
+0
-0
puget1 RE: Links open in Firefox even though Chrome is my default browser
Member 8th Jul, 2009 20:27
Score: 0
Posts: 551
User Since: 21st Dec 2007
System Score: N/A
Location: US
Last edited on 8th Jul, 2009 20:28
For Vista OS the simplest way of setting your default browser is to go to your control panel--DEFAULT PROGRAMS--set your default programs and go from there. Three other fields are also available--1. Associate a file type or protocol with a program,2. Change auto play settings,3. Set program access and computer defaults. You do need to be system administrator. Hope this helps?

Windows Vista "Home Basic"
Service Pack 1
MAXML 4.0 SP 2

AMD Athlon 64x2 dual core Processor4000+2.10GHz
2GB Ram 32 bit OS

--
Windows Home Basic-Service Pack 2
Dell AMD Athlon 64x2 Processor 4000+ 2.10Ghz 2Memory 32 Bit

Firefox 27+ - MS Security Essentials+Spybot-Spyware Blaster-Malwarebytes-Emsisoft Malware- Sandboxie

IE 9-seldom












Was this reply relevant?
+0
-0
Anthony Wells RE: Links open in Firefox even though Chrome is my default browser
Expert Contributor 8th Jul, 2009 20:28
Score: 2445
Posts: 3,332
User Since: 19th Dec 2007
System Score: N/A
Location: N/A
Last edited on 8th Jul, 2009 20:29
For Elations :

I can't check that at the moment as I've nothing "dangerous" lurking . I have had the impression in some threads that PSI was proposing solutions in a new fashion , but I had no way of checking and/or forgot to look . Thanks for the news , the guys at Secunia are always quick to improve "problem" areas , whenever possible.

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+0
-0
jhertel RE: Links open in Firefox even though Chrome is my default browser
Member 8th Jul, 2009 23:39
Score: 1
Posts: 15
User Since: 11th Mar 2009
System Score: 99%
Location: DK
Last edited on 8th Jul, 2009 23:41
on 7th Jul, 2009 15:30, E.Jeppesen wrote:
This is the registry key determining which default browser the PSI uses:

HKEY_CLASSES_ROOT\HTTP\shell\open\command

The browser stated in this registry key should be the one used by the PSI.

To examine the issue further we would appreciate if those experiencing the issue would provide us with the following information.

- The browser shown in the above mentioned registry key.
- Operating system and Service Packs.
- Whether you normally run as limited user or administrator (please note that to set a default browser for the PSI you need to do so as administrator).


Thank you for this answer!

Here is the contents of my HKEY_CLASSES_ROOT\http\shell\open\command:

[HKEY_CLASSES_ROOT\http\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"

[HKEY_CLASSES_ROOT\http\shell\open\ddeexec]
@="\"%1\",,-1,0,,,,"
"NoActivateHandler"=""

[HKEY_CLASSES_ROOT\http\shell\open\ddeexec\Applica tion]
@="IExplore"

[HKEY_CLASSES_ROOT\http\shell\open\ddeexec\Topic]
@="WWW_OpenURL"


My default browser is Chrome, and Chrome says it is the default browser (I cannot tell Chrome to make it the default, because it already says it is).

I am using Windows Vista Home Premium SP1.

I normally run as an administrator.


Obviously, the entries in my HKEY_CLASSES_ROOT\http (and HKEY_CLASSES_ROOT\https as well, by the way) are wrong. But how come other programs start Chrome when I click on links? Also, when I press the Start button and type a url, e.g. http://secunia.com, it also starts Chrome. So Windows also identifies Chrome as my default http handler. How come only Secunia PSI doesn't?

This (rather old, but probably still valid) article from Microsoft: http://support.microsoft.com/kb/224816 says you should use the ShellExecute() function from shell32.dll to open a URL from a program. Maybe this is simply what the other programs do, and maybe Secunia PSI should do that too?

See also

http://www.bigresource.com/VB-Launch-Default-brows...
http://www.developerfusion.com/code/112/launch-a-p...
http://msdn.microsoft.com/en-us/library/bb762153(VS.85).aspx


For illustration purposes, in Visual Basic the definition of the ShellExecute() function is this:

Private Declare Function ShellExecute _
Lib "shell32.dll" Alias "ShellExecuteA" _
( _
ByVal hWnd As Long, _
ByVal lpOperation As String, _
ByVal lpFile As String, _
ByVal lpParameters As String, _
ByVal lpDirectory As String, _
ByVal nShowCmd As Long _
) As Long

and the call is this:

ShellExecute 0&, vbNullString, "http://secunia.com", vbNullString, _
vbNullString, SW_SHOWNORMAL


I do agree that there are some mysteries in my registry in the HKEY_CLASSES_ROOT\http key, but somehow ShellExecute seems to open my default browser anyway, without any problems.

So I guess using ShellExecute() probably would solve the problem for all of us, simply leaving it to Windows to start the default browser.

As most other programs probably use ShellExecute() too, Secunia would then behave as most other programs do, and if there is a problem with the default browser, it would not be specific to Secunia PSI.
Was this reply relevant?
+0
-0
elations RE: Links open in Firefox even though Chrome is my default browser
Member 9th Jul, 2009 02:15
Score: 1
Posts: 8
User Since: 7th Jul 2009
System Score: N/A
Location: N/A
on 8th Jul, 2009 20:28, Anthony Wells wrote:
I can't check that at the moment as I've nothing "dangerous" lurking .


Neither do I, having been a good boy and always responded to PSI alerts quickly. But after I posted my earlier message I realized it was quite a while since I had actually used the "Download Solution" button and I should check up to make sure my memory still reflects the situation as it is today. So, just for testing purposes, I temporarily disabled one of my "Ignore" rules. Some ancient installers stored on an external drive had raised alarms previously, even though the programs weren't actually installed. Forcing a rescan after removing the ignore rule for that location tricked PSI into issuing several warnings again, alongwith a selection of "Download Solutions" to chose from ;).
Was this reply relevant?
+0
-0
elations RE: Links open in Firefox even though Chrome is my default browser
Member 9th Jul, 2009 02:40
Score: 1
Posts: 8
User Since: 7th Jul 2009
System Score: N/A
Location: N/A
on 8th Jul, 2009 23:39, jhertel wrote:

So I guess using ShellExecute() probably would solve the problem for all of us, simply leaving it to Windows to start the default browser.
I found that, if a specific browser is already open, other programs tend to just make use of that browser rather than open the default one on top of it, which saves time and resources compared to the way PSI handles it. If ShellExecute meant this type of behaviour, increasing speed and saving resources would be two additional considerations in favour of it.
Was this reply relevant?
+0
-0
E.Jeppesen RE: Links open in Firefox even though Chrome is my default browser
Secunia Official 9th Jul, 2009 11:08
Score: 220
Posts: 618
User Since: 24th Nov 2008
System Score: N/A
Location: Copenhagen, DK
Thank you very much for your responses.

For those experiencing the issue, please try this:

- Right-click on the browser you use as default and run it as administrator.
- Check whether the browser itself claims to be the default browser. If it isn't, use the browsers “Make default” button or any similar feature to make it default.

Let us know whether this has any effect on the issue.
jhertel RE: Links open in Firefox even though Chrome is my default browser
Member 9th Jul, 2009 18:27
Score: 1
Posts: 15
User Since: 11th Mar 2009
System Score: 99%
Location: DK
on 9th Jul, 2009 11:08, E.Jeppesen wrote:
For those experiencing the issue, please try this:

- Right-click on the browser you use as default and run it as administrator.
- Check whether the browser itself claims to be the default browser. If it isn't, use the browsers “Make default” button or any similar feature to make it default.

Let us know whether this has any effect on the issue.


I did as you said, but my Chrome browser still says "Google Chrome er i øjeblikket din standardbrowser" (which means "Google Chrome is currently your default browser"). And the button "Gør Google Chrome til min standardbrowser" ("Make Google Chrome my default browser") is grayed out.

I still believe using ShellExecute() would solve the problem, as Secunia PSI is the only program on my computer that does not use my default browser when launching http URLs (web addresses).
Was this reply relevant?
+0
-0
bhenshaw RE: Links open in Firefox even though Chrome is my default browser
Member 29th Jul, 2009 01:44
Score: 18
Posts: 67
User Since: 29th Apr 2009
System Score: 93%
Location: US
I am having the same problem. IE is my default browser, but Secunia always opens Firefox. Is there a way to get Secunia to use my default browser?

Thanks!

Bill
Was this reply relevant?
+0
-0
jhertel RE: Links open in Firefox even though Chrome is my default browser
Member 29th Jul, 2009 14:54
Score: 1
Posts: 15
User Since: 11th Mar 2009
System Score: 99%
Location: DK
Last edited on 29th Jul, 2009 14:55
on 29th Jul, 2009 01:44, bhenshaw wrote:
I am having the same problem. IE is my default browser, but Secunia always opens Firefox. Is there a way to get Secunia to use my default browser?

Thanks!

Bill

As a work-around, until Secunia solves the problem, you can do the following (at your own risk) to make Secunia PSI use Internet Explorer:

1. It could be a good idea to back up your registry first, at least the key "HKEY_CLASSES_ROOT\http\shell\open\command", but there shouldn't be that much risk with entering the information below into the registry.

2. Put this text into a text file using Notepad (or another plain text editor) and save the file as "internetexplorer.reg" (the extension .reg is important, the first part of the name is not):

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\http\shell\open]

[HKEY_CLASSES_ROOT\http\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"

[HKEY_CLASSES_ROOT\http\shell\open\ddeexec]
@="\"%1\",,-1,0,,,,"
"NoActivateHandler"=""

[HKEY_CLASSES_ROOT\http\shell\open\ddeexec\Applica tion]
@="IExplore"

[HKEY_CLASSES_ROOT\http\shell\open\ddeexec\Topic]
@="WWW_OpenURL"



3. Double click the resulting file and say Yes to the warning.


I have tested it on my own computer.

This doesn't make Secunia use your default browser, but it should make Secunia PSI use Internet Explorer.
Was this reply relevant?
+0
-0
jhertel RE: Links open in Firefox even though Chrome is my default browser
Member 29th Jul, 2009 15:01
Score: 1
Posts: 15
User Since: 11th Mar 2009
System Score: 99%
Location: DK
Last edited on 29th Jul, 2009 15:02
on 29th Jul, 2009 14:54, jhertel wrote:
[HKEY_CLASSES_ROOT\http\shell\open\dd eexec\Application]
@="IExplore"


Strangely, the word Application seems to be broken into "Applica tion" when the text is displayed in my previous post. In my post, and also in the quote above, the text was and is not broken, so I cannot correct the error - it is an error in the Secunia forum software.

So the best I can do is add this instruction:

Please correct "Applica tion" to "Application" in Notepad before saving the file.
Was this reply relevant?
+0
-0
Trino RE: Links open in Firefox even though Chrome is my default browser
Member 7th Aug, 2009 17:25
Score: 0
Posts: 7
User Since: 3rd Aug 2009
System Score: N/A
Location: N/A
I have both a PROGRAM FILES & a PROGRAM FILES (x86) file. The Secunia is in the (x86) file as our most programs. Should I change the

[HKEY_CLASSES_ROOT\http\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"


to: \\Program Files (x86)\\
Was this reply relevant?
+0
-0
jhertel RE: Links open in Firefox even though Chrome is my default browser
Member 7th Aug, 2009 21:46
Score: 1
Posts: 15
User Since: 11th Mar 2009
System Score: 99%
Location: DK
on 7th Aug, 2009 17:25, Trino wrote:
I have both a PROGRAM FILES & a PROGRAM FILES (x86) file. The Secunia is in the (x86) file as our most programs. Should I change the

[HKEY_CLASSES_ROOT\http\shell\open\command]
@="\"C:\\Program Files\\Internet Explorer\\iexplore.exe\" -nohome"

to: \\Program Files (x86)\\


Ah, you have Vista 64 bit. The "Program Files (x86)" folder is for 32 bit programs. I have read others say (http://tinyurl.com/l5ocwv) that it is best to use the 32 bit version of Internet Explorer.

So the answers is yes: Use "\\Program Files (x86)\\" instead of "\\Program Files\\" in 64 bit versions of Vista.

Thanks for being aware of this!
Was this reply relevant?
+0
-0
bhenshaw RE: Links open in Firefox even though Chrome is my default browser
Member 12th Aug, 2009 04:10
Score: 18
Posts: 67
User Since: 29th Apr 2009
System Score: 93%
Location: US
Last edited on 12th Aug, 2009 04:14
jhertel

Thanks for responding. I made these changes and now things open using IE 8 instead of Firefox, but I get the warning other people are mentioning when I try to download an update which says basically that IE is not my default browser, but IE must be used.

Any ideas on how to fix this error?

Thanks!

Bill
Was this reply relevant?
+0
-0
GH-UpNorth RE: Links open in Firefox even though Chrome is my default browser
Member 12th Aug, 2009 17:16
Score: 0
Posts: 3
User Since: 24th Sep 2008
System Score: N/A
Location: N/A
I have noticed a similar situation with my XP laptop... I only have one browser installed - IE8. I checked the registry for data in HKEY_CLASSES_ROOT\HTTP\shell\open\command and it reads ... "C:\Program Files\Internet Explorer\IEXPLORE>EXE" -nohome. When I click on the "Download Solution" button in Secunia PSI to update to the proper adobe flash version I get.... "The link you are trying to open requires Internet Explorer to function correctly and will therefore not use your default browser" It then opens IE8 and continues. Any ideas on how to get Secunia PSI to recognize that IE8 is my default browser?

Was this reply relevant?
+0
-0
puget1 RE: Links open in Firefox even though Chrome is my default browser
Member 12th Aug, 2009 17:51
Score: 0
Posts: 551
User Since: 21st Dec 2007
System Score: N/A
Location: US
Last edited on 12th Aug, 2009 20:17
In regards to last entry: This what I have also encountered as far as having to go through PSI flash link and being told internet explorer needs to function correctly. I found that when using multiple browsers that you have to download to both (i.e. Adobe to IE and Adobe to Firefox(or whatever)). This then triggers "compatibility mode" in windows. I am not sure exactly how it works but maybe if we query the p.c. it might tell us how to designate the primary browser to use PSI in? I use FF and it works for me as I then get prompted to get a ""plug in"" Maybe, this is what is required? Hope this triggers a clue to someone?



--
Windows Home Basic-Service Pack 2
Dell AMD Athlon 64x2 Processor 4000+ 2.10Ghz 2Memory 32 Bit

Firefox 27+ - MS Security Essentials+Spybot-Spyware Blaster-Malwarebytes-Emsisoft Malware- Sandboxie

IE 9-seldom












Was this reply relevant?
+0
-0
puget1 RE: Links open in Firefox even though Chrome is my default browser
Member 12th Aug, 2009 18:23
Score: 0
Posts: 551
User Since: 21st Dec 2007
System Score: N/A
Location: US
Don't know, but maybe something like this might help http://www.howtogeek.com/howto/windows-vista/using...

--
Windows Home Basic-Service Pack 2
Dell AMD Athlon 64x2 Processor 4000+ 2.10Ghz 2Memory 32 Bit

Firefox 27+ - MS Security Essentials+Spybot-Spyware Blaster-Malwarebytes-Emsisoft Malware- Sandboxie

IE 9-seldom












Was this reply relevant?
+0
-0
jhertel RE: Links open in Firefox even though Chrome is my default browser
Member 14th Aug, 2009 02:09
Score: 1
Posts: 15
User Since: 11th Mar 2009
System Score: 99%
Location: DK
on 12th Aug, 2009 04:10, bhenshaw wrote:
jhertel
Thanks for responding. I made these changes and now things open using IE 8 instead of Firefox, but I get the warning other people are mentioning when I try to download an update which says basically that IE is not my default browser, but IE must be used.

Any ideas on how to fix this error?

Thanks!

Bill

I'm sorry, but I don't know how Secunia PSI determines whether IE is the default browser or not, so here I don't have a clue.

Jesper
Was this reply relevant?
+0
-0
jhertel RE: Links open in Firefox even though Chrome is my default browser
Member 14th Aug, 2009 02:47
Score: 1
Posts: 15
User Since: 11th Mar 2009
System Score: 99%
Location: DK
Here is a quick hack to make Secunia PSI use the default browser, no matter what it is:

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\http\shell\open\command]
@="C:\\Windows\\system32\\cmd.exe /c start \"\" \"%1\""


Not pretty with the short-lived popup command window, but it works (tested on my 32 bit Vista Home Premium).

Note that this does not solve the problem with Secunia not recognizing IE as the default browser.
Was this reply relevant?
+0
-0
bhenshaw RE: Links open in Firefox even though Chrome is my default browser
Member 14th Aug, 2009 05:20
Score: 18
Posts: 67
User Since: 29th Apr 2009
System Score: 93%
Location: US
jhertel,

Thanks for your help.

Bill
Was this reply relevant?
+0
-0
Trino RE: Links open in Firefox even though Chrome is my default browser
Member 23rd Aug, 2009 02:45
Score: 0
Posts: 7
User Since: 3rd Aug 2009
System Score: N/A
Location: N/A
I've been away on vaction.

Using REGEDIT I went to: HKEY_CLASSES_ROOT\http\shell\open\command

and found a (value not set)

but I cannot find a way to type in the new command.

Thanks for your help
Was this reply relevant?
+0
-0
Frogger77 RE: Links open in Firefox even though Chrome is my default browser
Member 23rd Aug, 2009 08:00
Score: 0
Posts: 4
User Since: 29th Nov 2008
System Score: N/A
Location: CA
Secunia would open all links in firefox for me as well with conflicting results on the windows downloads. Control panel / internet options / programs / make IE the default browser seems to have done the trick for me with IE7, XP SP2 AMD 4400

--
XP Pro, AMD Athlon X64 X2 4400+, 3Gb Ram
Was this reply relevant?
+0
-0
This user no longer exists RE: Links open in Firefox even though Chrome is my default browser
Member 23rd Aug, 2009 16:45
on 23rd Aug, 2009 08:00, Frogger77 wrote:
Secunia would open all links in firefox for me as well with conflicting results on the windows downloads. Control panel / internet options / programs / make IE the default browser seems to have done the trick for me with IE7, XP SP2 AMD 4400

WinXP SP3 has been available for over a year so you should go to Tools then Windows Update in Internet Explorer and install all updates as it provides performance enhancements and several Critical updates.

Go to Control panel then Automatic updates then enable at least Notify me but do not download updates.

User Profile Hive Cleanup Service
Brief Description
A service to help with slow log off and unreconciled profile problems.
http://www.microsoft.com/downloads/details.aspx?fa...

Install IE8 as it is faster and safer than IE7:
Stay Safer Online
http://www.microsoft.com/windows/internet-explorer...
Accelerators
http://www.microsoft.com/windows/internet-explorer...
Was this reply relevant?
+0
-0
Frogger77 RE: Links open in Firefox even though Chrome is my default browser
Member 26th Aug, 2009 01:04
Score: 0
Posts: 4
User Since: 29th Nov 2008
System Score: N/A
Location: CA
There were a number of issues with AMD machines and SP3. Have they all been solved?

--
XP Pro, AMD Athlon X64 X2 4400+, 3Gb Ram
Was this reply relevant?
+0
-0
This user no longer exists RE: Links open in Firefox even though Chrome is my default browser
Member 26th Aug, 2009 02:13
on 26th Aug, 2009 01:04, Frogger77 wrote:
There were a number of issues with AMD machines and SP3. Have they all been solved?

Ages ago:
http://msinfluentials.com/blogs/jesper/archive/200...
http://discussions.virtualdr.com/showthread.php?t=...

Google is your friend.
Was this reply relevant?
+0
-0
Trino RE: Links open in Firefox even though Chrome is my default browser
Member 26th Aug, 2009 15:05
Score: 0
Posts: 7
User Since: 3rd Aug 2009
System Score: N/A
Location: N/A
referring to Post 6 on 3 august 09:

IE 8 is my default browser and that is confirmed in Internet options. However, that does not appear in my registry as noted in the previous thread.

Not being completely familiar with the rigistry I cannot figure out how to put in the change recommended in this thread. I cannot edit the current "no value" except to begin a new entry on a second line. Is this what needs to be done or is there some other way to edit the "no value" entry?
Was this reply relevant?
+0
-0
Frogger77 RE: Links open in Firefox even though Chrome is my default browser
Member 27th Aug, 2009 07:03
Score: 0
Posts: 4
User Since: 29th Nov 2008
System Score: N/A
Location: CA
Thanks for the links. I'll check it out.

--
XP Pro, AMD Athlon X64 X2 4400+, 3Gb Ram
Was this reply relevant?
+0
-0
MRCS4 RE: Links open in Firefox even though Chrome is my default browser
Member 7th Oct, 2009 11:06
Score: 0
Posts: 8
User Since: 30th Nov 2008
System Score: N/A
Location: N/A
on 7th Jul, 2009 15:30, E.Jeppesen wrote:
This is the registry key determining which default browser the PSI uses:


I had the same problem and found a comparatively easy solution for Opera. I would suspect there should be a similar way for Firefox, Chrome, etc. I had recently done a fresh install of Opera 10.0 and still had 9.64 installed, which PSI insisted on using. Uninstalling PSI and even deleting my profile did not help. Under Opera preferences there is a setting for Protocols Handled by Opera (Tools > Preferences > Advanced > Programs > Details) with checkboxes for HTTP and HTTPS. I unchecked those in 9.64 and then checked them under 10.0, and PSI used the correct default browser after that.
Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability