Forum Thread: Joomla AllVideos Plugin "file" Information Disclosure Vulnerability

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
Vulnerabilities

See the original Secunia advisory:
Joomla AllVideos Plugin "file" Information Disclosure Vulnerability

This thread has been marked as locked.
Secunia Joomla AllVideos Plugin "file" Information Disclosure Vulnerability
Secunia Official 15th Feb, 2010 15:35
Ranking: 0
Posts: 0
User Since: -
System Score: -
Location: Copenhagen, DK
A vulnerability has been discovered in the AllVideos plugin for Joomla, which can be exploited by malicious people to disclose potentially sensitive information.

Input passed to the "file" parameter in plugins/content/jw_allvideos/includes/download.php is not properly sanitised before being used to read files. This can be exploited to read arbitrary files from local resources via directory traversal attacks.

The vulnerability is confirmed in version 3.1. Other versions may also be affected.

joomlaworks

RE: Joomla AllVideos Plugin "file" Information Disclosure Vulnerability
[+]
This reply has been minimised due to a negative Relevancy Score.
Secunia Research RE: Joomla AllVideos Plugin "file" Information Disclosure Vulnerability
Secunia Official 16th Feb, 2010 16:30
Score: 5
Posts: 7
User Since: 16th Feb 2010
System Score: N/A
Location: Copenhagen, DK
As part of normal procedure, the vulnerability report was verified and confirmed to be valid before issuing a Secunia advisory. Note that we have just updated the advisory today with an example to clarify the problem.
joomlaworks RE: Joomla AllVideos Plugin "file" Information Disclosure Vulnerability
Member 17th Feb, 2010 20:44
Score: 6
Posts: 2
User Since: 15th Feb 2010
System Score: N/A
Location: GR
Last edited on 18th Feb, 2010 20:22
AllVideos v3.3 has just been released, permanently dealing with a security flaw discovered in version 3.0 to 3.2. You are strongly advised to upgrade immediately to v3.3 if you're already using v3.0 to v3.2.

The vulnerability discovered in versions 3.0. to 3.2 of the plugin can be exploited by malicious people to disclose potentially sensitive information. For security reasons we will not be providing further details to safeguard users of affected versions.

If you are using AllVideos v1.x or v2.x there is no security concern to upgrade. You are however advised to upgrade to v3.3 if using Joomla! 1.5 to enjoy all the new features introduced in the v3 series.

Official announcement here: http://www.joomlaworks.gr/content/view/77/34/
Was this reply relevant?
+10
-0

This thread has been marked as locked.