navigation bar left navigation bar right

Secunia CSI7
navigation left tab Advisories navigation right tab
navigation left tab Research navigation right tab
navigation left tab Forums navigation right tab
navigation left tab Create Profile navigation right tab
navigation left tab Our Commitment navigation right tab
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: icon not showing in tray in Vista

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
bhenshaw icon not showing in tray in Vista
Member 15th Mar, 2010 02:53
Ranking: 18
Posts: 67
User Since: 29th Apr, 2009
System Score: 93%
Location: US
PSI is not showing up in the tray any longer. I am running Vista SP1.

This just started happening in the last couple weeks. I start up PSI. I click the X in the upper right hand corner and instead of an icon going into the tray that shows the program is still running, the program actually closes. I look in task manager and it isn't running.

Any ideas on what might be wrong?

Thanks!

TiMow RE: icon not showing in tray in Vista
Dedicated Contributor 15th Mar, 2010 08:42
Score: 737
Posts: 728
User Since: 26th Jun 2009
System Score: N/A
Location: CH
Last edited on 15th Mar, 2010 10:18
I`m not familiar with Vista, but a couple of simple things are worth checking.

1) Go to settings tab on PSI (advanced) page and make sure that both "Start Secunia PSI on boot" and "Enable program monitoring" are ticked.

2) Right click Start: > properties: > taskbar tab: > customise. Find the Secunia icon in the list and make sure that "Always Show" is chosen.

PSI never shows in my task manager when the icon is in the tray - but it`s still monitoring any program changes, providing that box is checked.

TiMow

EDIT: If you make any of the above changes, don`t forget a re-boot, so they can take effect.

--
Computing is not yet a perfect science - it still requires humans.
Was this reply relevant?
+0
-0
bhenshaw RE: icon not showing in tray in Vista
Member 15th Mar, 2010 15:26
Score: 18
Posts: 67
User Since: 29th Apr 2009
System Score: 93%
Location: US
Thanks for your quick reply.

I have both items in PSI selected and in Vista I have PSI set to always show. Still, the icon does not show in the tray.

I used to start PSI and then when I clicked on the X in the PSI window, an icon would appear in the tray and I think it said something like PSI is still running. Now when I click on the X, no icon shows in the tray so I can't tell if PSI is still running or not. However, if I try to startup PSI again, it actually brings up a window without checking for connectivity so I think it is not really loading the program from scratch, but is just redisplaying the actively running program window.

With no icon in the tray I can not actually exit the program any longer.

Very weird.
Was this reply relevant?
+0
-0
This user no longer exists RE: icon not showing in tray in Vista
Member 15th Mar, 2010 15:40
Hi,

We have been unable to reproduce this issue.
It is possible for you to expand the tray, and if so, is the PSI icon hidden there?

Do you have any other software running in the tray, and if so, which? Do you have any software that manages or interferes with the tray?
Was this reply relevant?
+1
-0
bhenshaw RE: icon not showing in tray in Vista
Member 15th Mar, 2010 18:16
Score: 18
Posts: 67
User Since: 29th Apr 2009
System Score: 93%
Location: US
Hi Emil,

I have the tray set to always show all icons (don't hide any).

The other programs that show up in the tray are:

Comodo Firewall
Microsoft Outlook
Synatics Pointing Device
Norton Antivirus
Power
Wireless Network
Volume

I don't have anything that manages the tray that I'm aware of.

Just as an FYI... I have another thread open on the forum because I'm having issues when PSI starts up. This just started happening as well. I have PSI set to automatically start up on system startup. After I boot up I see an icon in the tray that says that programs have been blocked. When I click on this I get some options that show that it is User Account Control (UAC) which has blocked the automatic start up of PSI. I can then start it up manually from an option on the menu. This never used to happen. I have not made any changes to UAC that I'm aware of. Not sure if this is related to the problem of the icon not showin in the tray.

I just noticed that even though the icon is not in the tray, if I go into task manager and look at processes, PSI.EXE is shown in the list. It does not show in the list of active applications.

Thanks!
Was this reply relevant?
+0
-0
This user no longer exists RE: icon not showing in tray in Vista
Member 17th Mar, 2010 09:38
Hi,

Please try right-clicking your tray, selecting "Notification area", and make sure "Disable inactive icons" is not checked.

Hope this helps.
Was this reply relevant?
+0
-0
bhenshaw RE: icon not showing in tray in Vista
Member 17th Mar, 2010 17:39
Score: 18
Posts: 67
User Since: 29th Apr 2009
System Score: 93%
Location: US
on 17th Mar, 2010 09:38, wrote:
Hi,

Please try right-clicking your tray, selecting "Notification area", and make sure "Disable inactive icons" is not checked.

Hope this helps.


I don't see this on my system. When I right click on the tray the menu that pops up does not have an option called "notification area".

When I right click the tray their is an option called "Properties". When I click on this a window opens that has four tabs. One of these is "Notification Area". If I click on that there is a section called "Icons". In this there is an option called "Hide inactive icons". This option is not checked.

Any other ideas?

Thanks!
Was this reply relevant?
+0
-0
This user no longer exists RE: icon not showing in tray in Vista
Member 18th Mar, 2010 09:19
Hi,

Please try clicking the icon tray again, and select "Custom notification icons". What are the settings for the PSI?
Was this reply relevant?
+0
-0
bhenshaw RE: icon not showing in tray in Vista
Member 18th Mar, 2010 17:22
Score: 18
Posts: 67
User Since: 29th Apr 2009
System Score: 93%
Location: US
on 18th Mar, 2010 09:19, wrote:
Hi,

Please try clicking the icon tray again, and select "Custom notification icons". What are the settings for the PSI?


When I right click the tray there is an option called "Customize notification icons" but it is grayed out, I can't select it.
Was this reply relevant?
+0
-0
This user no longer exists RE: icon not showing in tray in Vista
Member 19th Mar, 2010 09:13
Hi,

Being unable to reproduce, and seeing as you can't access the settings tab, I'm forced to conclude the problem must be on your end. Could I ask you to try reinstalling the PSI?

Hope this helps.
Was this reply relevant?
+0
-0
bhenshaw RE: icon not showing in tray in Vista
Member 19th Mar, 2010 17:57
Score: 18
Posts: 67
User Since: 29th Apr 2009
System Score: 93%
Location: US
Hi Emil,

I did some research and the option to "customize notification icons" is only active on the menu if you have "hide inactive icons" selected in the tray properties. I have that option not selected.

If I select the "hide inactive icons" option and then right click in the tray I can select "customize notification icons". When I do that I can scroll down through the list of icons. PSI shows up in the list and the behavior is listed as "Show".

Thanks!

Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


Secunia is a member of FIRST Secunia is a member of EDUcause Secunia is a member of The Open Group Secunia is a member of FS-ISAC
 
Secunia © 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability - Disclaimer
follow Secunia on Facebook follow Secunia on Twitter follow Secunia on LinkedIn follow Secunia on YouTube follow Secunia Xing follow Secunias RSS feed follow Secunia on Google+