Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: MS fails to update the vulnerable NET Framework 3.x

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
DHC MS fails to update the vulnerable NET Framework 3.x
Member 9th Jun, 2010 05:35
Ranking: 0
Posts: 2
User Since: 26th Sep, 2009
System Score: N/A
Location: N/A
All of the updates updates installed smoothly but the update to NET Framework 3.x continually failed to install. All this happened - I should say failed to happen - on patch Tuesday June * 2010. Everything else was updated successfully. Windows Update always stated the failure to install of the update. For all the years I have been updating Windows via the web - over 20 years - I've never encountered an update failure like this


Any suggestions? I use Windows XP and, as I've said everything else is up-to-date.

HERE IS THE PATH:
C:\WINDOWS\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\SMSvcHost.exe


David

mogs RE: MS fails to update the vulnerable NET Framework 3.x
Expert Contributor 9th Jun, 2010 06:44
Score: 2265
Posts: 6,266
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
Hello.
Well you've got many more years of experience than me; but in about 20 months I've had a couple of failures.
You should have an error code to help you resolve matters ?
Sometimes I've found that sometime later the update has installed successfully.
I use Vista so will not get too much into it.
In the meantime I'd have run a CHKDSK. Regards


--
Was this reply relevant?
+1
-0
Anthony Wells RE: MS fails to update the vulnerable NET Framework 3.x
Expert Contributor 9th Jun, 2010 13:09
Score: 2437
Posts: 3,323
User Since: 19th Dec 2007
System Score: N/A
Location: N/A
Last edited on 9th Jun, 2010 13:09
@DHC ,

Hello David ,

There is a long running problem of certain KB's not installing/validating correctly in .Net . I have this problem .

Which KB's are being "re-offered" to you ??

The insecurity is rated as fairly low level ; so a temporary measure is to go to "microsoftupdates" , select "custom" and then click on the box at the the left of the problem KB , this will expand the KB and at the bottom is another box you can tick so that the KB is no longer shown .

Some people have success doing a manual install of the KB .

I will look into the problem over the next few days and come back to this thread , if you leave it open .

You may see more information if you "Google/search" your KB's.

I hope this is clear .

Anthony.



--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+1
-0
ddmarshall RE: MS fails to update the vulnerable NET Framework 3.x
Dedicated Contributor 9th Jun, 2010 13:17
Score: 1208
Posts: 959
User Since: 8th Nov 2008
System Score: 98%
Location: UK
If you are in the US you can get free help with security updates from Microsoft on 866-727-2338.
There is also the Windows Update Forum at:
http://social.answers.microsoft.com/Forums/en-US/v...

--
This answer is provided “as-is.” You bear the risk of using it.
Was this reply relevant?
+0
-0
DHC RE: MS fails to update the vulnerable NET Framework 3.x
Member 10th Jun, 2010 09:40
Score: 0
Posts: 2
User Since: 26th Sep 2009
System Score: N/A
Location: N/A
Can I delete all of NET Framework? I don't do any programing. What else would I need it for? Deleting the damned thing -- all of it: well I'd love to do it because it would fix the problem. SO WHY DO I NEED IT AND WHAT WOULD HAPPEN IF I ZAP IT?
Thanks, David
Was this reply relevant?
+0
-0
ddmarshall RE: MS fails to update the vulnerable NET Framework 3.x
Dedicated Contributor 10th Jun, 2010 12:22
Score: 1208
Posts: 959
User Since: 8th Nov 2008
System Score: 98%
Location: UK
You need .NET Framework to run programs written using it. It contains libraries they need to run.
If you can't resolve your problem with your local Microsoft support (problems installing security updates are supposed to be dealt with free of charge), there is a comprehensive troubleshooting guide here:
http://blogs.msdn.com/b/astebner/archive/2008/03/0...

How much of the .NET Framework you could uninstall depends on which Operating System you are using. From Vista onwards some of it is an operating system component. In my limited experience of this, if updates won't install, uninstalling .NET Framework fails also.

--
This answer is provided “as-is.” You bear the risk of using it.
Was this reply relevant?
+1
-0
Anthony Wells RE: MS fails to update the vulnerable NET Framework 3.x
Expert Contributor 10th Jun, 2010 12:46
Score: 2437
Posts: 3,323
User Since: 19th Dec 2007
System Score: N/A
Location: N/A
Last edited on 10th Jun, 2010 12:52
To update , my/the latest .NET download (on XP) is a complete "pig's breakfast" as we say in Lancashire . Belarc agrees with "Add/Remove" but they both disagree with MS/Windoze updates - both history and actualKB's offered/loaded and/or reoffered .

I have 3 KB's hidden at updates so that PSI is satisfied for now .

The problems/solutions are unlikely to become clear for a few days . I will likely take it up further with Windows Secrets at some stage (time permitting) .

Aaron Stebner's weblog (as per ddmarshall's link above) would help if anyone wants a complete root and branch uninstall/reinstall . This is the earlier link to his clean up tool (for background):-

http://blogs.msdn.com/b/astebner/archive/2005/04/0...

I shall wait a few days to see where/if things are any less muddy .

Anthony

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+1
-0
wr RE: MS fails to update the vulnerable NET Framework 3.x
Contributor 10th Jun, 2010 20:02
Score: 308
Posts: 736
User Since: 30th Mar 2008
System Score: 100%
Location: US
Hi all

The following link has a great explanation of the
.NET Frameworks versions by Maurice Joyce & may be
helpful correcting your problem(s). His post & that of ddmarshall are the last 2 posts in this thread.

http://secunia.com/community/forum/thread/show/424...

Hope this helps.

Regards, wr



--
HP Pavilion Slimline s3020n
Windows Vista Home Premium SP2 32 bit
AMD 64 Athlon X2
Firefox 24.4.0 ESR
The weakest link of a computer system is always sitting in front of the monitor.
Was this reply relevant?
+0
-0
Anthony Wells RE: MS fails to update the vulnerable NET Framework 3.x
Expert Contributor 11th Jun, 2010 12:00
Score: 2437
Posts: 3,323
User Since: 19th Dec 2007
System Score: N/A
Location: N/A
Last edited on 11th Jun, 2010 15:55
My .Net version 1.1 update is fine .

As only my .Net version 2.0 SP2 seems to be causing problems , I will do an uninstall/reinstall to see if that helps .

Anthony

EDIT ; all the info available showed my problem as a progressive failure of the KB's and an uninstall via "Add/Remove" of 3.5 , 3.0 and 2.0 was probably enough - leaving the files in the ..\Windows\Microsoft.Net\.. as they were . A reinstall using just the 3.5 installer seemingly replaced everything back as before (looking in Add/Remove) and following the specific order of updates demanded by M$ updates , i was then able to install the three recalcitrant KB's I had needed to hide .

Belarc , "Add/Remove", PSI and M$/Windoze updates are now all happy , me too .

Till the next time .

Take care Anthony

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability