Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: Another Flash CS3 vulnerability (!) upgrade problem

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
Programs

Relating to this vendor:
Adobe Systems
And, this specific program:
Adobe Flash CS3 9.x

This thread has been marked as resolved.
Hollico Another Flash CS3 vulnerability (!) upgrade problem
Member 14th Jun, 2010 20:05
Ranking: 0
Posts: 16
User Since: 22nd Jul, 2009
System Score: N/A
Location: N/A
Secunia reported a vulnerability in Flash CS3 today(2010/06/14) and when I downloaded the solution I received a file (sa_flashplayer_9.exe) a no instructions. I ran the file, it opened but nothing happened. No instructions from the vendor (no big surprise since it's Adobe).

What are we supposed to do with the file?

Post "RE: Another Flash CS3 vulnerability (!) upgrade problem" has been selected as an answer.
ddmarshall RE: Another Flash CS3 vulnerability (!) upgrade problem
Dedicated Contributor 14th Jun, 2010 20:18
Score: 1210
Posts: 961
User Since: 8th Nov 2008
System Score: 98%
Location: UK
If you go to the Adobe Security bulletin:

http://www.adobe.com/support/security/bulletins/ap...

towards the end is a link for CS3 to the Flash Player Support Center. If you follow this link you will eventually find instructions on how to update CS3. I'm afraid it is a manual process.

--
This answer is provided as-is. You bear the risk of using it.
Was this reply relevant?
+1
-0
M.Hansen RE: Another Flash CS3 vulnerability (!) upgrade problem
Secunia Official 15th Jun, 2010 09:15
Score: 188
Posts: 410
User Since: 26th Jan 2009
System Score: N/A
Location: Copenhagen, DK
Hi

This is a rather strange update and not very user friendly

Rename the downloaded file to FlashPlayer.exe

Replace the old FlashPlayer.exe located in the "Players" folder in the Flash CS3 folder.

Rescan with the PSI and you should now be flagged as "patched"
Hollico RE: Another Flash CS3 vulnerability (!) upgrade problem
Member 15th Jun, 2010 13:37
Score: 0
Posts: 16
User Since: 22nd Jul 2009
System Score: N/A
Location: N/A
You are right about it being a strange update.

Thanks for the help.
Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability - Disclaimer