Forum Thread: Unable to locate an appropriate web browser for the requested URL

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI 2.0 Beta

This thread has been marked as locked.
libove Unable to locate an appropriate web browser for the requested URL
Member 21st Sep, 2010 11:59
Ranking: 31
Posts: 71
User Since: 12th Feb, 2008
System Score: N/A
Location: N/A
I get this error, "Unable to locate an appropriate web browser for the requested URL" when I click on any link within Secunia PSI 2.0 Beta, such as the "Visit the Community Forum" link on the general help page within the application, or the "Need Help with this program?" link within the detail page for any program in the Results list.

My system is Windows 7 Ultimate, 64-bit, with Firefox 4.0beta6 and IE8 (production) installed. This happens both with Firefox set as the default web browser and also with IE8 set as the default web browser.

Both 32-bit and 64-bit versions of JRE 6.0u21 are installed.

This user no longer exists RE: Unable to locate an appropriate web browser for the requested URL
Member 21st Sep, 2010 12:36
Hi,

Please try following the steps outlined in this thread: http://secunia.com/community/forum/thread/show/471...

Has this resolved the issue?
Was this reply relevant?
+0
-0
libove RE: Unable to locate an appropriate web browser for the requested URL
Member 21st Sep, 2010 16:28
Score: 31
Posts: 71
User Since: 12th Feb 2008
System Score: N/A
Location: N/A
Hello Emil.
Yes, this resolves the problem.

Since this is frankly a pain no matter how you look at it, I urge that PSI be enhanced to have some smart logic to figure out whether the user's settings "work", and to try some sensible defaults if not, possibly even going so far - for a product which can autocorrect software deficiencies on a system this isn't much of a stretch - as to set the registry properly when either the product detects that the registry settings for URL handling is incorrect, or the user clicks a button in the PSI program to so indicate.

Thank you,
Jay
Was this reply relevant?
+1
-0
This user no longer exists RE: Unable to locate an appropriate web browser for the requested URL
Member 22nd Sep, 2010 10:10
Hi,

Altering the user's registry would probably be much too instrusive. However, we are looking into ways to handle the PSI's use of browsers, and will try to make the process easier and less intrusive. Making this easier is one of our goals with the PSI 2.0 Beta.

Thank you for your feedback.
Was this reply relevant?
+0
-0

This thread has been marked as locked.