Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: Enable program monitoring -> "Error loading filter driver"

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI 2.0 Beta

This thread has been marked as locked.
libove Enable program monitoring -> "Error loading filter driver"
Member 26th Sep, 2010 10:35
Ranking: 31
Posts: 70
User Since: 12th Feb, 2008
System Score: N/A
Location: N/A
From this morning, I can no longer get PSI 2beta to enable the "Enable program monitoring" settings checkbox. When I click on settings, that checkbox is blank. I click on the box, the check immediately appears, then about two or three seconds later I get an error dialog box saying:

Error loading filter driver.
An error occurred while attempting to enable the PSI filter driver.

This persists even after a total uninstallation (including manually cleaning all file system entries for Secunia PSI, though I admit I forgot to walk the registry looking for vestiges there...), reboot, and reinstall.

(And, for those who have been watching my other thread, about how I run PSI under my own user ID but with SuRun elevated privileges, this also happens even when I explicitly RunAs PSI as Administrator, so it's not some funky "I'm elevated but not elevated enough" problem).

Windows 7 Ultimate, 64-bit, PSI 2beta and PSI 1.5.0.x and earlier had all been running great and monitoring programs, up until this morning. (SuRun had been involved before, and things had worked fine then; the only change I made this morning, oddly, was uninstalling VMware Workstation 7.1.1 and updating to 7.1.2, which I had hoped wouldn't break anything else...).

Help? I'd like to get my live monitoring back :-)

Thanks!
Jay

E.Jeppesen RE: Enable program monitoring -> "Error loading filter driver"
Secunia Official 27th Sep, 2010 12:33
Score: 220
Posts: 618
User Since: 24th Nov 2008
System Score: N/A
Location: Copenhagen, DK
Hi
Could I ask you to contact us at support@secunia.com? We will then send you information on how to further examine and troubleshoot this issue.

If anyone else is also experience this exact issue, please let us know.
DenTNT RE: Enable program monitoring -> "Error loading filter driver"
Member 29th Sep, 2010 15:41
Score: 3
Posts: 4
User Since: 29th Sep 2010
System Score: N/A
Location: RU
Error loading filter driver

An error occurred while attempting to enable the PSI filter driver.

Seven x64
Was this reply relevant?
+1
-0
libove RE: Enable program monitoring -> "Error loading filter driver"
Member 1st Oct, 2010 19:04
Score: 31
Posts: 70
User Since: 12th Feb 2008
System Score: N/A
Location: N/A
I note that this problem persists in the new 1.9.0.4001 beta version.
-Jay
Was this reply relevant?
+0
-0
libove RE: Enable program monitoring -> "Error loading filter driver"
Member 5th Oct, 2010 18:38
Score: 31
Posts: 70
User Since: 12th Feb 2008
System Score: N/A
Location: N/A
Any luck on finding/ fixing this "filter driver" bug?
Thanks,
Jay
Was this reply relevant?
+0
-0
This user no longer exists RE: Enable program monitoring -> "Error loading filter driver"
Member 6th Oct, 2010 09:24
Last edited on 6th Oct, 2010 09:25 Hi,

@libdove
So far, we are still working to resolve the issue.

However, those users who wish to speed up the resolution can do so by sending us a debug log at support@secunia.com

To obtain such a log, follow the below instructions. Before starting, please note that debug logs are confidential, and should not be posted on the forum. Doing so can lead to your account being hijacked.

First, close the PSI by right-clicking it's tray icon and selecting "Exit".
Then, enter "cmd" either in the Start > Run box (For XP users), or directly in the Start menu search field (For Vista and Win7). A command window will appears. Enter the below commands exactly, and the PSI will run in debug mode:
cd "%ProgramFiles%\Secunia\PSI"
psi.exe --verbose --debug secunia.txt

Please walk through the steps to reproduce the issue, and close this instance of the PSI.
A new file will have been created at %ProgramFiles%\Secunia\PSI\secunia.txt
If you can email us this file at support@secunia.com, along with a reference to this thread (we receive quite a few debug logs), the debugging process will be made easier.

Please note that the solution should be announced, and will most likely come out with the next release - There is no current solution, whether you send a debug log or not.

Thank you all for your feedback.
Was this reply relevant?
+0
-0
libove RE: Enable program monitoring -> "Error loading filter driver"
Member 14th Oct, 2010 21:09
Score: 31
Posts: 70
User Since: 12th Feb 2008
System Score: N/A
Location: N/A
Any update on this?
I'm still seeing this filter problem on two Windows 7 64-bit systems here.
Thanks,
Jay
Was this reply relevant?
+0
-0
This user no longer exists RE: Enable program monitoring -> "Error loading filter driver"
Member 15th Oct, 2010 09:28
Hi,

The situtation is still the same.

Our developers are working on a solution, which will be deployed once ready.
Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability