Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: PSI is telling me that Skype requires update

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
Programs

Relating to this vendor:
Skype Technologies
And, this specific program:
Skype for Windows 4.x

This thread has been marked as locked.
RhonBB PSI is telling me that Skype requires update
Member 26th Sep, 2010 17:51
Ranking: 0
Posts: 5
User Since: 26th Sep, 2010
System Score: N/A
Location: CA
My PSI is telling me that Skype requires update yet when I try to update it I get a message telling me that a version of Skye is alread installed and should be removed. I don't want to remove it as I have checked and the latest version on Skypes webite is 4.2 and I already have 4.2. I have used it and it is working fine...so why should I have to remove and reinstall it??

By the way, from reading other threads I see that one advice that has been given is to make sure Sype is completely closed down before I try to run the update....well I always keep it closed, only open it when I want to use it.


How can I cancel this skype advisory in PSI??

Maurice Joyce RE: PSI is telling me that Skype requires update
Handling Contributor 26th Sep, 2010 17:59
Score: 11711
Posts: 8,954
User Since: 4th Jan 2009
System Score: N/A
Location: UK
U can ignore it but that would negate what PSI is telling U. Somewhere on your PC is a vulnerable element of Skype.

b]FINDING A FILE PATH

ALL PSI VERSIONS EXCEPT VERSION 2 (BETA)[/b]

To locate the exact file that the Secunia PSI has detected, use or switch to the ADVANCED interface, then :

1 Click on the + sign of the programme to "expand' it.
2 Click on Technical Details in the Toolbox to see the installation path of the detected file. (Copy (CTRL+C) & paste (CTRL+V) the Installation Path of the file back to the Forum if U are unsure what to do next.

PSI VERSION 2 (BETA)

From the DASHBOARD page click on RESULTS.

1. This will show U the file that is vulnerable.
2. Click the + sign next to the file.
3. This will reveal the path.
4. Highlight it then copy (CTRL+C) & then paste (CTRL+V) that path back to the Forum if U do not know what to do next.


Update 5 10:46 26/09/2010


--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+1
-0
RhonBB RE: PSI is telling me that Skype requires update
Member 26th Sep, 2010 22:34
Score: 0
Posts: 5
User Since: 26th Sep 2010
System Score: N/A
Location: CA
Hi Maurice,

This is the path:

Installation Path:
C:\Program Files\Skype\Phone\Skype.exe

And...when I go into advanced it is showing 4 more programs that need updating that were not showing in regular view....hmmm...and most of them I have already done! I will do them again in the advanced mode and see what happens....if they go away.
Was this reply relevant?
+0
-0
Maurice Joyce RE: PSI is telling me that Skype requires update
Handling Contributor 26th Sep, 2010 23:53
Score: 11711
Posts: 8,954
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Last edited on 26th Sep, 2010 23:54
OK - the advanced mode does scan more programmes & gives U better protection.

Post the paths if unsure what to do.

In the case of Skype - from the PSI toolbox open the folder where it has found the skype phone vulnerabilty. Right click on the file - it will tell U the version number.

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+2
-0
RhonBB RE: PSI is telling me that Skype requires update
Member 27th Sep, 2010 19:17
Score: 0
Posts: 5
User Since: 26th Sep 2010
System Score: N/A
Location: CA
Hi Maurice,

I do not see "toolbox" anywhere on Secunia, either in advanced or simple mode. But, in the area where it is telling me that the Skpye needs to be updated it is saying t's detecting version 4.2.32.155....which is the version I already have and the latest version on the Skype website is 4x. Is uninstalling my Skype the only way for me toget this updated?? Cause I really didn't want to do that....

Also those other paths in the advanced mode are a bit confusing...one says that IE 7 is vulnerable and there is no fix...but I already updated to IE 8 a long time ago....huh??? why is it still checking version 7?

It also say "no fix" for Adobe reader 9.x ??

Also, Secunia advised me to update flashplayer...I did the update 5 times and it said it was installed correctly but in avanced it is still telling me to update it.

I am sooo confused...lol
Was this reply relevant?
+0
-0
Maurice Joyce RE: PSI is telling me that Skype requires update
Handling Contributor 27th Sep, 2010 21:36
Score: 11711
Posts: 8,954
User Since: 4th Jan 2009
System Score: N/A
Location: UK
It is the paths I need - it looks to me like some of these issues are not on the C drive.

I need to see the path PSI is giving U. Use the script I have given U.

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+1
-0
ddmarshall RE: PSI is telling me that Skype requires update
Dedicated Contributor 27th Sep, 2010 21:57
Score: 1208
Posts: 959
User Since: 8th Nov 2008
System Score: 98%
Location: UK
Last edited on 27th Sep, 2010 21:59
As far as Skype goes, you really do need to install the update, either from Secunia or the Skype website. The current version is 4.2.0.187 which is later than the version that you have: 4.2.0.155. Version 4.2.0.155 is insecure. The removal of the old version is a necessary part of the update process.

--
This answer is provided “as-is.” You bear the risk of using it.
Was this reply relevant?
+0
-0
RhonBB RE: PSI is telling me that Skype requires update
Member 28th Sep, 2010 02:02
Score: 0
Posts: 5
User Since: 26th Sep 2010
System Score: N/A
Location: CA
ddmarshal...aaargh...really didn'y want to have to do that...but what can you do huh? Thanks.

Maurice, ok, so that will resolve the Skype isse...but why does it keep telling me to update adobe flash when I have done it 10 times already And why is it watching IE7 when I already have IE8? Still don't see anything marked "toolbox".....
Was this reply relevant?
+0
-0
Maurice Joyce RE: PSI is telling me that Skype requires update
Handling Contributor 28th Sep, 2010 10:00
Score: 11711
Posts: 8,954
User Since: 4th Jan 2009
System Score: N/A
Location: UK
AS I said I suspect there are some issues that are not on your C drive. I need the paths of all the outstanding problems PSI has found to give proper advice.

b]FINDING A FILE PATH

ALL PSI VERSIONS EXCEPT VERSION 2 (BETA)[/b]

To locate the exact file that the Secunia PSI has detected, use or switch to the ADVANCED interface, then :

1 Click on the + sign of the programme to "expand' it.
2 Click on Technical Details in the Toolbox to see the installation path of the detected file. (Copy (CTRL+C) & paste (CTRL+V) the Installation Path of the file back to the Forum if U are unsure what to do next.

PSI VERSION 2 (BETA)

From the DASHBOARD page click on RESULTS.

1. This will show U the file that is vulnerable.
2. Click the + sign next to the file.
3. This will reveal the path.
4. Highlight it then copy (CTRL+C) & then paste (CTRL+V) that path back to the Forum if U do not know what to do next.


Update 5 10:46 26/09/2010


--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+2
-0
ddmarshall RE: PSI is telling me that Skype requires update
Dedicated Contributor 28th Sep, 2010 11:49
Score: 1208
Posts: 959
User Since: 8th Nov 2008
System Score: 98%
Location: UK
Use Skype > Help > Check for Updates. It may be quicker and simpler.

--
This answer is provided “as-is.” You bear the risk of using it.
Was this reply relevant?
+0
-0
RhonBB RE: PSI is telling me that Skype requires update
Member 29th Sep, 2010 01:46
Score: 0
Posts: 5
User Since: 26th Sep 2010
System Score: N/A
Location: CA
ddmarshall.....did it already thanks and it's now gone from my Secunia insecure list.

Maurice, it seems it is just the Adobe flash player 10.x that has a problem, I have installed it 10 times...even had Secunia re-scan the program...still showing as insecure... Here is the path info:

Version Detected:
10.1.82.76 (ActiveX)

Installation Path:
C:\WINDOWS\system32\Macromed\Flash\Flash10i.ocx

Last Inspection of Program:
28th Sep. 2010, 2:20 CET


Was this reply relevant?
+0
-0
This user no longer exists RE: PSI is telling me that Skype requires update
Member 29th Sep, 2010 08:47
Hi,

To update Flash without receiving an alert in 1.x version of the PSI (In the 2.0 Beta, this is all handled automatically), first download Adobe's Flash uinstaller, and follow Adobe's instructions to remove Flash leftovers:
http://kb2.adobe.com/cps/141/tn_14157.html

Then, ensure that every application using Flash is closed (Including the PSI in versions prior to 2.x), and run patch.
You should be shown as Secure.

hope this helps.
Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability