Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: 4 insecurities I can't update thru psi

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as resolved.
Nikilet 4 insecurities I can't update thru psi
Member 30th Sep, 2010 19:34
Ranking: 7
Posts: 287
User Since: 15th Jul, 2008
System Score: N/A
Location: N/A
A short time ago I had an item come thru as insecure in PSI for which I could not use the Download Solution button. It would indicate to me that IE was not up to date. Another forum memer tried to help me straightent this out. The item was Microsoft Word 2002. At the same time an item came thru my Windows Update, OfficeXP SP3, and I couldn't run that because I didn't have a disk to insert. I went to Windows forum and in the end I uninstalled this Word 2002 and installed OpenOffice and those woes went away. I also discovered that PSI actually was working when a Flash update came thru after that.

Now I have 4 more insecure items in PSI and every one of them reacts the same way as that Word item did when I click on Download Solution.

"The link you are trying to open requires Internet Explorer to function correctly and will therefore not use your default browser. Press 'OK' to continue."

When I press OK it opens up Windows Update online, which opens the one on my computer, which tells me my Windows is up to date.

These are the items in question:
Microsoft .Net Framework 1.x
C:\Windows\Microsoft.NET\Framework\v1.1.4322\aspne t_wp.exe

Microsoft .Net Framework 2.x
C:\Windows\Microsoft.NET\Framework\v2.0.50727\aspn et_wp.exe

Microsoft .Net Framework 3.x
C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\SMSvcHost.exe

Microsoft .Net Framework 4.x
C:\Windows\Microsoft.NET\Framework\v3.0\Windows Communication Foundation\SMSvcHost.exe

Help please, if you can.

Post "RE: 4 insecurities I can't update thru psi" has been selected as an answer.
mogs RE: 4 insecurities I can't update thru psi
Expert Contributor 30th Sep, 2010 20:01
Score: 2265
Posts: 6,266
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
Hello.
Here's a link to a thread that may help. There is also another link contained therein to further reading/understanding of .NET probs.

http://secunia.com/community/forum/thread/show/564...

Hope it helps.......regards,

--
Was this reply relevant?
+1
-0
Nikilet RE: 4 insecurities I can't update thru psi
Member 30th Sep, 2010 20:27
Score: 7
Posts: 287
User Since: 15th Jul 2008
System Score: N/A
Location: N/A
Last edited on 30th Sep, 2010 20:29
If there was something here that was supposed to help me I must have missed it, and went back twice. Apparently these 4 items need to be updated, but I can't use the Download Solution button in PSI, so how do I update them?

On something like this, I would think that updates would come through Windows Update.
Was this reply relevant?
+0
-0
silvatek RE: 4 insecurities I can't update thru psi
Member 30th Sep, 2010 21:06
Score: 11
Posts: 51
User Since: 31st Aug 2008
System Score: N/A
Location: UK
The new 2.0 beta PSI is telling me that .NET 2.0 and .NET 3.0 are out of date and points me at Microsoft Update, which says there are no outstanding updates for .NET. So I guess I'm going to have to live with an amber bar on the dashboard. :(
Was this reply relevant?
+0
-0
mogs RE: 4 insecurities I can't update thru psi
Expert Contributor 30th Sep, 2010 21:07
Score: 2265
Posts: 6,266
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
Have you tried this ? :-

When updating Microsoft Applications, it is a good idea to keep in mind that some Microsoft Updates do not "kick in" until after a reboot. Therefore, it is recommended to try following this proceduce when installing Microsoft Updates:

1) Check Microsoft Update, install all security-related patches
2) Reboot
3) Repeat step 1, repeat step 2 if anything was installed at this step
4) Run a full rescan with the PSI

Emil R. Petersen
Secunia PSI Support


Hope it helps.......regards,

--
Was this reply relevant?
+1
-0
Nikilet RE: 4 insecurities I can't update thru psi
Member 30th Sep, 2010 21:31
Score: 7
Posts: 287
User Since: 15th Jul 2008
System Score: N/A
Location: N/A
I manually selected to check for updates and it did come up with three on this .Net business, but only for 1 and 3.5. Nothing there for 2 or 4. PSI says 1-4 are all insecure.

The first two, 1.1 SP1 and 3.5 SP1 are both for Windows XP. Why would those come through as important updates for my Vista?

The third update is 3.5 SP1 Vista.

I selected to install all 3 and then will reboot, run Windows Update again and report back.
Was this reply relevant?
+0
-0
silvatek RE: 4 insecurities I can't update thru psi
Member 30th Sep, 2010 21:54
Score: 11
Posts: 51
User Since: 31st Aug 2008
System Score: N/A
Location: UK
Rebooting will not solve anything when no new Microsoft patches have been applied. I booted my PC, upgraded PSI 2.0 beta, it scanned and told me there were outstanding .NET updates, I ran MS Update - no outstanding updates.
Was this reply relevant?
+0
-0
tichbennett RE: 4 insecurities I can't update thru psi
Member 30th Sep, 2010 22:04
Score: 0
Posts: 1
User Since: 22nd Oct 2009
System Score: 100%
Location: UK
Last edited on 30th Sep, 2010 22:06
I have the same problem. Microsoft says that there are no updates for these products.
Was this reply relevant?
+0
-0
mogs RE: 4 insecurities I can't update thru psi
Expert Contributor 30th Sep, 2010 22:14
Score: 2265
Posts: 6,266
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
Have you read thro' Maurice Joyce's post at (?):-
http://secunia.com/community/forum/thread/show/424...

With Vista, I have these .NET versions showing with psi 2.0 Beta :-

2.0.50727.4205
3.0.4506.4037
4.0.30319.1

--
Was this reply relevant?
+1
-0
Nikilet RE: 4 insecurities I can't update thru psi
Member 30th Sep, 2010 22:29
Score: 7
Posts: 287
User Since: 15th Jul 2008
System Score: N/A
Location: N/A
Mogs, I read that post by M. Joyce and most of it as like reading Greek to me as far as understanding what I was reading.

However, I am happy to report that your instructions solved my problem. I'm sure they must have, but did the other posters here manually select to check for updates? When I opened WU it said my Windows was up to date, but when I went ahead and clicked to check, it found those 3 and after installing I now have no more insecure issues with this .Net.

Apparently PSI does not provide some updates through that Download Solutions button and that's why it sends you to Windows Update when you click the OK button on that window. That's sure what it's looking like to me, however, why does it indicate that IE is not working correctly?
Was this reply relevant?
+0
-0
Maurice Joyce RE: 4 insecurities I can't update thru psi
Handling Contributor 30th Sep, 2010 22:30
Score: 11630
Posts: 8,917
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Microsoft issued patches today for .Net. Updating Windows 7 was a breeze without any assistance from PSI.

The patching affects all OS's.

Details are here:
http://www.microsoft.com/technet/security/bulletin...

Open the links on that web page starting with BULLETIN INFORMATION - EXECUTIVE SUMMERIES.

U will find the Update KB numbers for each OS. Are they installed on your PC? If not that is your problem.

They should be available via Windows Update.


--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+2
-0
mogs RE: 4 insecurities I can't update thru psi
Expert Contributor 30th Sep, 2010 23:22
Score: 2265
Posts: 6,266
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
Last edited on 30th Sep, 2010 23:29
Thanks Maurice ! Had checked for updates earlier (1600hrs): checked again following your post. Two updates/rebooted and scanned.
psi now shows 100% score with .NET as follows :-

*2.0.50727.4209
3.0.4506.4037
4.0.30319.1


Nikilet

I've got a fully patched IE8 but it is still shown as " Not secure for browsing " in the Secure Browsing tab. Reasons as given in Secunia Advisories. If you're fully patched there is no more that you can do at the present time.

--
Was this reply relevant?
+0
-0
Maurice Joyce RE: 4 insecurities I can't update thru psi
Handling Contributor 1st Oct, 2010 00:22
Score: 11630
Posts: 8,917
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Summary of the .Net Framework Issue.

MS released patches today (Thursday) for .Net Framework via Windows Update.

If they are installed correctly PSI will show your PC as secure with the following version numbers:

WINDOWS 7
2.0.50727.4955
3.0.4506.4926
4.0.30319.1

VISTA SP2

2.0.50727.4209
3.0.4506.4037
4.0.30319.1

XP SP3

2.0.50727.3618
3.0.4506.2152
4.0.30319.1


--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+2
-0
silvatek RE: 4 insecurities I can't update thru psi
Member 1st Oct, 2010 00:56
Score: 11
Posts: 51
User Since: 31st Aug 2008
System Score: N/A
Location: UK
The .NET updates finally showed up in Microsoft Update (I'm on Vista SP2). All sorted now and back to 100%. Is there some kind of time lag between PSI notifications and MS Updates?
Was this reply relevant?
+0
-0
Maurice Joyce RE: 4 insecurities I can't update thru psi
Handling Contributor 1st Oct, 2010 01:01
Score: 11630
Posts: 8,917
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Last edited on 1st Oct, 2010 01:02
Yes - PSI often notify U before it is posted by Windows update. The good thing is U are all fixed up & secure.

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+0
-0
silvatek RE: 4 insecurities I can't update thru psi
Member 1st Oct, 2010 01:04
Score: 11
Posts: 51
User Since: 31st Aug 2008
System Score: N/A
Location: UK
Go PSI!! This bunny is happy once more. Over and out.
Was this reply relevant?
+1
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability