Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: ,NET Framework 1, 2,3 & 4 needs updating

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
Programs

Relating to this vendor:
Microsoft
And, this specific program:
Microsoft .NET Framework 3.x

This thread has been marked as resolved.
snowy1946 ,NET Framework 1, 2,3 & 4 needs updating
Member 9th Oct, 2010 05:01
Ranking: 2
Posts: 8
User Since: 19th Jun, 2010
System Score: N/A
Location: AU
Hi I am only a novice at this and need assistance. PSI tells me that .NET Framework 1,2,3,4 needs updating and everytime I go to auto update on the Microsoft web it seems to keep re-installing and does not solve my problem.
Can anyone help me. I am operating XP SP3 Home Addition.

Post "RE: ,NET Framework 1, 2,3 & 4 needs updating" has been selected as an answer.
mogs RE: ,NET Framework 1, 2,3 & 4 needs updating
Expert Contributor 9th Oct, 2010 07:42
Score: 2265
Posts: 6,266
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
Hello.
Here is a link to a recent thread on the subject.....there is also another link within it which will give background to .NET problems :-
http://secunia.com/community/forum/thread/show/579...
Please read them carefully before taking any actions.
At the present time there are a number of users with XP, experiencing difficulties, so it might be worth your while reading those also.
Hope this helps.......regards,

--
Was this reply relevant?
+1
-0
Anthony Wells RE: ,NET Framework 1, 2,3 & 4 needs updating
Expert Contributor 9th Oct, 2010 09:25
Score: 2384
Posts: 3,280
User Since: 19th Dec 2007
System Score: N/A
Location: N/A
Last edited on 9th Oct, 2010 09:28
Mogs & snowy,

Mogs , you have linked snowy to this thread :-

http://secunia.com/community/forum/thread/show/579...

The important hyperlink in it to a thread containing Maurice Joyce's critical help is not working . This frequently happens if you copy a post from one thread to another and the hyperlink has been curtailed ; because of this , I test the links in my posts after I have posted to a thread . I picked up your problem here :-

http://secunia.com/community/forum/thread/show/583...

Snowy , this is an active link to the thread with Maurice Joyce's important info :-

http://secunia.com/community/forum/thread/show/424...

Mogs , the other thread is still open to you to edit , if you want to update with a working link .

Take care

Anthony

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+1
-0
snowy1946 RE: ,NET Framework 1, 2,3 & 4 needs updating
Member 13th Oct, 2010 07:11
Score: 2
Posts: 8
User Since: 19th Jun 2010
System Score: N/A
Location: AU
Hi Anthony
I am totally confused and frustrated as nothing I do seems to fix this problem. I have tried everything and I think I have followed instructions correctly but I still keep getting the same downloads. I really don't understand exactly what I am supposed to be doing I am just feeling my way round and I am not sure if I am doing more damage than good. Is there any easy exe file to fix this or whatever. I hope you have more patience than I have at the moment and I would really appreciate any help you can give me.
Thanks
Denise
Was this reply relevant?
+0
-0
Maurice Joyce RE: ,NET Framework 1, 2,3 & 4 needs updating
Handling Contributor 13th Oct, 2010 11:23
Score: 11312
Posts: 8,728
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Denise,
Go to Control Panel>add/remove & uninstall .NET FRAMEWORK 4 (Client Profile) and .NET FRAMEWORK 4 (Extended).

Reboot & then complete a full PSI scan.

What result do U get this time?

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+1
-0
snowy1946 RE: ,NET Framework 1, 2,3 & 4 needs updating
Member 13th Oct, 2010 12:47
Score: 2
Posts: 8
User Since: 19th Jun 2010
System Score: N/A
Location: AU
Hi Maurice
I did exactly what you suggested and now I only have .net framework 1,2,3. Do I uninstall these 3 as well?
I really appreciate your assistance and patience with me.
Denise
Was this reply relevant?
+0
-0
Maurice Joyce RE: ,NET Framework 1, 2,3 & 4 needs updating
Handling Contributor 13th Oct, 2010 13:33
Score: 11312
Posts: 8,728
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Denise,
Now go to Windows Update. Click the CUSTOM button. Does MS find any .NET Framework updates are required other than .NET 4?

Whatever happens do not reinstalled .NET 4 which should show as OPTIONAL.

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+0
-0
Maurice Joyce RE: ,NET Framework 1, 2,3 & 4 needs updating
Handling Contributor 14th Oct, 2010 23:40
Score: 11312
Posts: 8,728
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Denise,
Is everything now fixed?

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+0
-0
snowy1946 RE: ,NET Framework 1, 2,3 & 4 needs updating
Member 18th Oct, 2010 06:05
Score: 2
Posts: 8
User Since: 19th Jun 2010
System Score: N/A
Location: AU

sorry I have been away. Net 4 is OK and not available. Framework 2 & 3.5 (KB2418241, KB983583, KB979909 & KB982168) still keeps updating.
Was this reply relevant?
+0
-0
Maurice Joyce RE: ,NET Framework 1, 2,3 & 4 needs updating
Handling Contributor 18th Oct, 2010 09:22
Score: 11312
Posts: 8,728
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Run this programme to try & find the update U are missing.

http://www.belarc.com/

If there are updates missing it will give U a KB number. If U are not sure where to find the download links Belarc may find post the KB number(s) back here.

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+2
-0
snowy1946 RE: ,NET Framework 1, 2,3 & 4 needs updating
Member 18th Oct, 2010 13:36
Score: 2
Posts: 8
User Since: 19th Jun 2010
System Score: N/A
Location: AU
Last edited on 18th Oct, 2010 13:40
I ran this programme and it tells me that KB979909, KB983583 & KB2418241 fails verification.

I tried reinstalling these once again and still need to be updated.

Belarc does not mention KB982168
Was this reply relevant?
+0
-0
Blue Zee RE: ,NET Framework 1, 2,3 & 4 needs updating
Member 18th Oct, 2010 16:36
Score: 11
Posts: 4
User Since: 18th Oct 2010
System Score: 100%
Location: PT
Windows XP SP3

Went through the same pain and the only way I found to solve this was by uninstalling all versions of .NET Framework, using Aaron Stebner's .NET Framework Cleanup Tool to clean all remnants:
http://blogs.msdn.com/b/astebner/archive/2008/08/2...

Reinstalled .NET Framework (excluding version 4!) and finally got it sorted.

Couldn't find any other way.

--
Sometimes the alphabet starts with Z...
Was this reply relevant?
+4
-0
Maurice Joyce RE: ,NET Framework 1, 2,3 & 4 needs updating
Handling Contributor 18th Oct, 2010 21:14
Score: 11312
Posts: 8,728
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Denise,
See the post immediately above this. I suppose U are unfortunately one of the few that needs to resort to that fix. It is fairly easy but just read all the instructions.

Interested to know how U get on.

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+0
-0
snowy1946 RE: ,NET Framework 1, 2,3 & 4 needs updating
Member 19th Oct, 2010 06:07
Score: 2
Posts: 8
User Since: 19th Jun 2010
System Score: N/A
Location: AU
Last edited on 19th Oct, 2010 06:09
Secunia PSI is now saying 100% OK. Thanks so much.

Do I do anything about the messages below:
Belarc is saying I need to reinstall KB982381 as hotfix failed to verify?
Microsoft Update has 5 Optional installs.
1. .NET framework 4 Client KB982670
2. .NET framework 4 Windows XP KB982671
3. Update for Windows XP KB971513
4. .NET Framework 3.5 Service Pack 1 & .NET Framework 3.5 Family Update KB951847
5. .NET Framework Ver 1.1
Was this reply relevant?
+0
-0
Maurice Joyce RE: ,NET Framework 1, 2,3 & 4 needs updating
Handling Contributor 19th Oct, 2010 09:58
Score: 11312
Posts: 8,728
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Forget Belarc.

DO NOT install the 2 offers of .NET 4. Highly unlikely U will need them as a home user for a very long time. Any programme that "calls on it to function" will notify U to install it.

U should install the others as & when. Do them one at a time & reboot after each install & do a full PSI scan. That will give U a clue if things go wrong & U can return to the Forum for advice knowing what could have caused the issue.

If all your problems are now resolved could U please lock (Accept) the thread. This will prevent us both from receiving update emails from "tag on" posts.



--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+1
-0
Blue Zee RE: ,NET Framework 1, 2,3 & 4 needs updating
Member 19th Oct, 2010 11:06
Score: 11
Posts: 4
User Since: 18th Oct 2010
System Score: 100%
Location: PT
on 19th Oct, 2010 06:07, snowy1946 wrote:
...
4. .NET Framework 3.5 Service Pack 1 & .NET Framework 3.5 Family Update KB951847
5. .NET Framework Ver 1.1

I do believe the above should be installed and updated.

I'm also wondering why PSI reports 100% OK with these missing...?

--
Sometimes the alphabet starts with Z...
Was this reply relevant?
+0
-0
Maurice Joyce RE: ,NET Framework 1, 2,3 & 4 needs updating
Handling Contributor 19th Oct, 2010 12:32
Score: 11312
Posts: 8,728
User Since: 4th Jan 2009
System Score: N/A
Location: UK
@Blue Zee

I agree but they all appear cosmetic/bug fixes - see here:

http://support.microsoft.com/kb/951847

PSI does not report on cosmetic or bug fix (Hotfix) issues. It only covers vulnerabilities therefore they could be secure but not fully up to date.

The .NET problem is most prevalent with XP users.

Many rely solely on the Auto Update feature which does not install Optional updates.

Some users do use the manual CUSTOM update search but elect not to install some updates offered (I suspect without really understanding dependencies). This, in my view, is what is causing some of the problems on this Forum - some of the optional installs are required to fix the critical fixes now being offered.

Others appear to think if U have .NET 4 installed U can dump earlier .NET installs.

Some are asking why .NET 3.5 is not showing in the PSI results - merely proves that dependencies are not fully understood.

All a bit of a muddle but slowly users are clearing down the vulnerabilities correctly highlighted by Secunia. Slowly slowly approach - no one fix covers all users as this Forum has proved - followed by the solution U used as a last resort.

What is clear is home users do not require .NET 4 at this stage.

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+2
-0
Anthony Wells RE: ,NET Framework 1, 2,3 & 4 needs updating
Expert Contributor 19th Oct, 2010 12:36
Score: 2384
Posts: 3,280
User Since: 19th Dec 2007
System Score: N/A
Location: N/A
Last edited on 19th Oct, 2010 12:54
Hello Denise ,

I too have KB982381 ** showing in the Belarc report as a hotfix which fails to validate ; it is not (re-)offered by M$update nor is it detected by the PSI . I have tried reinstalling but to no avail and cannot find a way around it for the moment ; it applies to IE and as I never use it for browsing (Firefox is my default + Chrome) I am ignoring it "for the time being" . In M$ terms for XP SP3 updates it is not a "security" hotfix ; however , a solution to the problem would be useful - I'll post one if I find one .

To answer to @Blue Zee , the updates which M$ are offering are also "options" and not "Proirity Security" fixes so the PSI will ignore them ; as Maurice Joyce has suggested , the .Net 4 fixes should not be installed , the others as a when , but soon .

The M$ rationale for rating hotfixes for XP SP3 is confusing and you need to look carefully at whether the "options" should be installed - again , as per Maurice Joyce , load them one at a time so you will be able to backtrack if a prroblem were to arrive .

Hope that helps you both .

Anthony

Edit ; post crossed with that from Maurice Joyce , but our messages remain similar .

EDIT2: ** here is the M$ report (found dy clicking the "details" link in the Belarc report) which allows you to "judge" the update importance :-

http://support.microsoft.com/kb/982381

I have tried the "fixit" link in the bulletin (a while ago) , which says it worked (for me) but does not change anything for Belarc .

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+1
-0
Blue Zee RE: ,NET Framework 1, 2,3 & 4 needs updating
Member 19th Oct, 2010 12:57
Score: 11
Posts: 4
User Since: 18th Oct 2010
System Score: 100%
Location: PT
Last edited on 19th Oct, 2010 12:59
I am also absolutely sure that the problems discussed here were caused by .Net Framework 4.

I have the sometimes painful curiosity of trying to understand how things work and/or why they don't.

In short: I reinstalled .Net Framework 4, updated and was facing problems again.
Updates reinstalling time after time and PSI reporting they were not installed.
Of course the step by step installation/update easily pointed me the culprit.
Uninstalling version 4 solved it this time.

Another problem in XP SP3 that I did pinpoint to the latest .Net Framework 4 update: Windows would take over 2 minutes to fully boot.
Uninstalled, cleaned up, solved.



--
Sometimes the alphabet starts with Z...
Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Factsheets
Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability