Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: Insecure Framework 1.1.4322 error?

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
Programs

Relating to this vendor:
Microsoft
And, this specific program:
Microsoft .NET Framework 1.x

This thread has been marked as resolved.
MiVetters Insecure Framework 1.1.4322 error?
Member 13th Oct, 2010 18:00
Ranking: 0
Posts: 1
User Since: 26th Nov, 2008
System Score: N/A
Location: N/A
PSI lists MS .NET Framework 1.x as insecure.
The listed path is C:\windows\Microsoft.NET\Framework1.1.4322\aspnet_ wp.exe
PSI sends me to go to Microsoft Update to fix it.
Running Microsoft Update results in no mention of a fix or need for a fix.
I ran a full scan and PSI still says it is insecure.
Who is right? How do I find a solution?

Post "RE: Insecure Framework 1.1.4322 error?" has been selected as an answer.
mogs RE: Insecure Framework 1.1.4322 error?
Expert Contributor 13th Oct, 2010 20:09
Score: 2265
Posts: 6,266
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
Last edited on 13th Oct, 2010 20:12
Hello.
Here is a copy of Maurice Joyce's post which gives valuable background in understanding .NET problems :-

********************************

.NET FRAMEWORK PROBLEMS
=======================

A bit of background information worth knowing before trying to fix .NET issues with Windows XP,Vista & Windows 7

1. .NET Framework 1.0, 1.1 and 2.0 are all side-by-side versions that can be installed and uninstalled without affecting the others. This means that if you are running into an issue in .NET Framework 2.0, for example, you do not necessarily need to remove .NET Framework 1.0 and 1.1 in addition to removing 2.0.

2. .NET Framework 3.0 is an add-on that requires .NET Framework 2.0 to be present as a prerequisite. If you have .NET Framework 3.0 installed, you will not be allowed to uninstall .NET Framework 2.0 until you first uninstall .NET Framework 3.0.

3. .NET Framework 3.5 is an add-on that requires .NET Framework 2.0 SP1 and .NET Framework 3.0 SP1 to be present as prerequisites. If you have .NET Framework 3.5 installed, you will not be allowed to uninstall .NET Framework 3.0 SP1 or 2.0 SP1 until you first uninstall .NET Framework 3.5.

4. .NET Framework 3.5 SP1 is an add-on that requires .NET Framework 2.0 SP2 and .NET Framework 3.0 SP2 to be present as prerequisites. If you have .NET Framework 3.5 SP1 installed, you will not be allowed to uninstall .NET Framework 3.0 SP2 or 2.0 SP2 until you first uninstall .NET Framework 3.5 SP1.

.NET 1 & 1.1 are very old & it is highly unlikely U will have a programme that "calls" on it to work. It can be safely uninstalled in the knowledge that if it is later required they can be re installed as Standalone items.

++++++++++++++++++++++++++++++++++++++++++++++++++ ++++++

If you are having trouble installing .NET Framework 2.0, 3.0 or 3.5, I recommend trying to install .NET Framework 3.5 SP1. It will install .NET Framework 2.0 SP2 and 3.0 SP2 behind the scenes, and these versions contain additional fixes not in the original 2.0, 3.0 or 3.5 releases. Plus, 3.5 SP1 will automatically uninstall any older versions of 2.0, 3.0 or 3.5 that are on your system, so you can save some time by not trying to install a version of .NET Framework that 3.5 SP1 is going to uninstall during its install process.

Link is here:

http://www.microsoft.com/downloads/details.aspx?fa...

++++++++++++++++++++++++++++++++++++++++++++++++++ ++++++
The latest version of .NET framework 3 is different among the various versions of Windows.

Windows XP: V3.0.4506.2152
Windows Vista: V3.0.4506.4037
Windows 7: V3.0.4506.4926
++++++++++++++++++++++++++++++++++++++++++++++++++ ++++++
There is a last resort but read the details before embarking on the action described.

NET FRAMEWORK CLEANUP TOOL FOR XP & VISTA

The link to a .Net Framework Clean Up Tool is here:

http://www.raymond.cc/blog/archives/2008/12/02/uni...

I would STRONGLY advise U do not install .Net 4.

****************************************


Since then there have been further updates; and depending 'pon what OS you're using, here are the current arrangements, when fully patched.


WINDOWS 7
2.0.50727.4955
3.0.4506.4926
4.0.30319.1

VISTA SP2

2.0.50727.4209
3.0.4506.4037
4.0.30319.1

XP SP3

2.0.50727.3618
3.0.4506.2152
4.0.30319.1

When updating Microsoft Applications, it is a good idea to keep in mind that some Microsoft Updates do not "kick in" until after a reboot. Therefore, it is recommended to try following this procedure when installing Microsoft Updates:

1) Check Microsoft Update, install all security-related patches
2) Reboot
3) Repeat step 1, repeat step 2 if anything was installed at this step
4) Run a full rescan with the PSI

Please include details of OS when next you contact the forum.
Hope this helps..........regards,

--
Was this reply relevant?
+2
-1
Anthony Wells RE: Insecure Framework 1.1.4322 error?
Expert Contributor 13th Oct, 2010 21:07
Score: 2437
Posts: 3,323
User Since: 19th Dec 2007
System Score: N/A
Location: N/A
Last edited on 13th Oct, 2010 21:12
For Mogs and @MiVetters .

Mogs you really do need to check that the links that are posted within a/the body of a copy of a post you make from another thread are working correctly .

In the Maurice Joyce post you have copied , the hyperlink to the .NET 3.5 SP1 download is truncated and gives a general search page for all M$ products .

This is the correct link for the download if @MiVitters should need it ; found by using the original link in Maurice Joyce's post and then recopying the correct url here ; it is also truncated but works here , it probably will not work if you copy it from here :-

http://www.microsoft.com/downloads/en/details.aspx...

Take care

Anthony

PS : for MOgs , your link to M.J's post in this thread does not work for the same reasoning :-

http://secunia.com/community/forum/thread/show/586...



--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+2
-0
mogs RE: Insecure Framework 1.1.4322 error?
Expert Contributor 13th Oct, 2010 22:02
Score: 2265
Posts: 6,266
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
Thanks for setting it aright Anthony....noted it the first time....probably more concerned with getting the body of the text sorted at the time and overlooked yet again !! I very much hope it's not a sign of premature ageing or senility !! Shock therapy or a thumbs down might reinforce the amendment....sometimes better to be cruel than kind. I can assure you it's not the sometimes willful ignorance of a rebellious youth !!!!

--
Was this reply relevant?
+1
-0
Maurice Joyce RE: Insecure Framework 1.1.4322 error?
Handling Contributor 13th Oct, 2010 22:09
Score: 11710
Posts: 8,954
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Last edited on 13th Oct, 2010 22:11
@Mogs
Also a little unsure which of my posts U have copied. It is not complete & I cannot see which update++ U copied.

Certainly not update 6 which has my latest details on the subject.

++All my researched posts have an update number & date/time at the bottom which helps me track if outdated information is being copied.

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+0
-0
Anthony Wells RE: Insecure Framework 1.1.4322 error?
Expert Contributor 13th Oct, 2010 22:33
Score: 2437
Posts: 3,323
User Since: 19th Dec 2007
System Score: N/A
Location: N/A

Hello again ,

Going back along the links , I think it is Revision 4 from here :-

http://secunia.com/community/forum/thread/show/424...

Anthony

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+0
-0
mogs RE: Insecure Framework 1.1.4322 error?
Expert Contributor 13th Oct, 2010 22:45
Score: 2265
Posts: 6,266
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
Maurice.
I've referred users to Revision 4 for background in all my posts :-
.NET FRAMEWORK PROBLEMS from 14/5/10.
I think the only phrase I edited out was concerning the possibility of an Optional update to .NET 4 mentioned at the time....for the reason given to you in another thread.

--
Was this reply relevant?
+0
-0
Maurice Joyce RE: Insecure Framework 1.1.4322 error?
Handling Contributor 13th Oct, 2010 23:10
Score: 11710
Posts: 8,954
User Since: 4th Jan 2009
System Score: N/A
Location: UK
@Mogs
Understand that thank you. I appreciate U are trying to help but not really a good idea to copy particularly when the original author cannot see all the detail as written. I note there are two bits of my research cobbled into one post & neither is complete as originally written. Most is not relevant to a standalone .NET 1 issue hence I did not use my latest version to try & help.

Better to point to an actual thread that solved a similar problem & it should have working links.

As I said my latest on .NET is Update 6. This is a result of more research in light of the recent batch of problems but does not cover the single instance of just .NET1

I will unsubscribe & leave the real solution with U.



--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+1
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability