navigation bar left navigation bar right

Secunia CSI7
navigation left tab Advisories navigation right tab
navigation left tab Research navigation right tab
navigation left tab Forums navigation right tab
navigation left tab Create Profile navigation right tab
navigation left tab Our Commitment navigation right tab
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: Issue with XML

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
Programs

Relating to this vendor:
Microsoft
And, this specific program:
Microsoft XML Core Services (MSXML) 6.x

This thread has been marked as locked.
aalested Issue with XML
Member 29th Oct, 2010 10:48
Ranking: 0
Posts: 4
User Since: 29th Oct, 2010
System Score: N/A
Location: DK
Hi.

Secunia made a report to me about an XML issue.

It is shown here, what I see:

http://picpaste.com/insecure-Jb2VwPGU.jpg
and
http://picpaste.com/inscure2-6uVzUIcU.jpg

How can I tackle the mentioned ?

--
Windows 7 Ultimate 64bit
ASUS P5Q-DeLuxe
4G RAM
Secunia PSI Version 1.5.0.2

mogs RE: Issue with XML
Expert Contributor 29th Oct, 2010 11:22
Score: 2265
Posts: 6,268
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
Last edited on 29th Oct, 2010 11:25
Hello.
If you start at the following link, you'll find the most recent threads on the forum concerning :-
http://secunia.com/community/forum/?forum=2&vendor...
Hope it helps....regards,

PS.
Please provide details of your Operating System and version of psi in use, when next you contact the forum.....thankyou.

--
Was this reply relevant?
+1
-0
TiMow RE: Issue with XML
Dedicated Contributor 29th Oct, 2010 14:34
Score: 737
Posts: 728
User Since: 26th Jun 2009
System Score: N/A
Location: CH
Sorry, to state the obvious, but have you checked Microsoft Update?

Belarc Advisor is also useful as a double check to missing M$ Hotfixes:

http://belarc.com/free_download.html

Does the following link help throw a bit more light on things?

http://support.microsoft.com/kb/269238

TiMow

--
Computing is not yet a perfect science - it still requires humans.
Was this reply relevant?
+1
-0
ddmarshall RE: Issue with XML
Dedicated Contributor 29th Oct, 2010 15:12
Score: 1219
Posts: 971
User Since: 8th Nov 2008
System Score: 98%
Location: UK
Last edited on 29th Oct, 2010 15:19
I think the file that is being reported is part of the Windows Driver Kit. It won't be affected by the usual windows updates.

It seems to be the latest version, if not you can update it from here
http://www.microsoft.com/downloads/en/details.aspx...

Edit

After a bit more reearch, I'm not sure you have the latest version. So try downloading the one dated 2/26/2010 if this is later than you installed it.

--
This answer is provided “as-is.” You bear the risk of using it.
Was this reply relevant?
+1
-0
aalested RE: Issue with XML
Member 29th Oct, 2010 16:24
Score: 0
Posts: 4
User Since: 29th Oct 2010
System Score: N/A
Location: DK
The WDK is:

WDK 7600.16385.1

--
Windows 7 Ultimate 64bit
ASUS P5Q-DeLuxe
4G RAM
Secunia PSI Version 1.5.0.2
Was this reply relevant?
+0
-0
aalested RE: Issue with XML
Member 29th Oct, 2010 16:31
Score: 0
Posts: 4
User Since: 29th Oct 2010
System Score: N/A
Location: DK
A bit more.
I can also see, that the WDK is version 7.1.0.7600, and this means, that it is the most recent version with ref. to the link you gave here.

--
Windows 7 Ultimate 64bit
ASUS P5Q-DeLuxe
4G RAM
Secunia PSI Version 1.5.0.2
Was this reply relevant?
+0
-0
ddmarshall RE: Issue with XML
Dedicated Contributor 29th Oct, 2010 17:08
Score: 1219
Posts: 971
User Since: 8th Nov 2008
System Score: 98%
Location: UK
There does not seem to be much else you can do if you installed the WDK after 26th February.

If you want to experiment you could
1. Try renaming the msxml6.dll and msxml6r.dll files and seeing if the operating system copies are used.
or
2. Replace the files in the WDK directory with the latest version from the Windows directory. From the filenames (x86), it looks like you would need 32bit versions.

Otherwise, probably safe to set up an ignore rule.

--
This answer is provided “as-is.” You bear the risk of using it.
Was this reply relevant?
+0
-0
aalested RE: Issue with XML
Member 29th Oct, 2010 17:45
Score: 0
Posts: 4
User Since: 29th Oct 2010
System Score: N/A
Location: DK
Last edited on 29th Oct, 2010 17:45
Thanks for the reply.

Yes, I installed it after the date you mention.
I will look for the suggestions you tell.
I run the Windows Ultimate 64bit system

--
Windows 7 Ultimate 64bit
ASUS P5Q-DeLuxe
4G RAM
Secunia PSI Version 1.5.0.2
Was this reply relevant?
+0
-0
ddmarshall RE: Issue with XML
Dedicated Contributor 29th Oct, 2010 21:33
Score: 1219
Posts: 971
User Since: 8th Nov 2008
System Score: 98%
Location: UK
I'm not sure how WDK uses these files. If they are redistributed with the driver, do not use the renaming option.

--
This answer is provided “as-is.” You bear the risk of using it.
Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


Secunia is a member of FIRST Secunia is a member of EDUcause Secunia is a member of The Open Group Secunia is a member of FS-ISAC
 
Secunia © 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability - Disclaimer
follow Secunia on Facebook follow Secunia on Twitter follow Secunia on LinkedIn follow Secunia on YouTube follow Secunia Xing follow Secunias RSS feed follow Secunia on Google+