Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: Various programs that cannot be updated

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
peterksejersen@hotmail.com Various programs that cannot be updated
Member 9th Nov, 2010 12:58
Ranking: 0
Posts: 1
User Since: 5th Dec, 2008
System Score: N/A
Location: N/A
I have been fighting with the tree Window updated listed below for weeks. Now some other ones have arrived and I do not what to do.

I have tryed the Windows update both manually, through Secunia and when closing/installing the computer.

Anybody that can help me with these six items:


Denne side, viser programmer som Secunia PSI har detekteret på din computer, hvor der er kendte sikkerhedsopdateringer tilgængelige. Vi anbefaler, at du opdaterer eller afinstallerer alle programmer vist på denne side. Klik på et program for at se yderligere detaljer.

Usikre Programmer [?] Version Detekteret [?] Trusselsvurdering [?] Direkte [?]

Adobe Flash Player 10.x 10.1.85.3 (ActiveX)

Google Chrome 7.x 7.0.517.41

Microsoft .NET Framework 1.x 1.1.4322.2470

Microsoft .NET Framework 2.x 2.0.50727.3614

Microsoft .NET Framework 3.x 3.0.4506.2152

Sun Java JRE 1.6.x / 6.x 6.0.210.7

Thanks/Peter

TiMow RE: Various programs that cannot be updated
Dedicated Contributor 9th Nov, 2010 13:33
Score: 737
Posts: 728
User Since: 26th Jun 2009
System Score: N/A
Location: CH
Last edited on 9th Nov, 2010 13:34
Hi Peter

It would be helpful, if in your next reply, if you could give details of your Windows OS, and which version of PSI you use.

Leaving .Net Framework for the moment - as this could be a bit more complicated.

Without the requested details, I can only offer advice in general terms.

What has probably happened is, that you have correctly updated the following programs, but have elements of previous versions remaining, which PSI continues to find as insecure.

1)Adobe flash ActiveX - this always causes problems when all programs that use it, aren't fully exited, when updating - these include all browsers, messenger and PSI (v.1.5.0.2 and earlier) - which has to be exited by right clicking the tray icon.

2)Chrome always creates a new file with each update and doesn't remove previous files - these have to be manually deleted every time.

3)Java only removes the previous version of itself with each new update - but you are showing the previous version as remaining, so this will need a bit more investigation as to the correct installation of the latest update.

I will post this for now and await your reply with the requested details.

TiMow

--
Computing is not yet a perfect science - it still requires humans.
Was this reply relevant?
+1
-0
TiMow RE: Various programs that cannot be updated
Dedicated Contributor 9th Nov, 2010 13:58
Score: 737
Posts: 728
User Since: 26th Jun 2009
System Score: N/A
Location: CH
Last edited on 9th Nov, 2010 17:11
Please see my EDIT at the bottom of this reply, before continuing.

Pre-empting your next reply, I will offer a few guidelines as to how you may clear the 3 aforementioned issues.

1) Flash - use PSI "Open Folder" (right of insecure listing; or click [+] on it's left); or navigate to file location using Windows Explorer. Once there, you will see named icons on the right. Look for yellow/green gear wheels, with Flash 10l.ocx written to the side of it. If it is present, then you have the latest Flash ActiveX installed. If you see others with earlier letters - e.g Flash 10k.ocx (or Flash 10i.ocx, etc.) - then these can be deleted by right clicking it and deleting. If you have problems deleting, then close all the programs I mentioned in my above reply, and retry.

2) Chrome - use the same method as with Flash to navigate to file location (PSI Open Folder). You should see Chrome numbered files for latest - 7.0.517.44, and previous 7.0.517.41 - right click the old numbered file and delete.

3) Java - look in Add/Remove Programs (from PSI, right of listing for Java, or Control Panel). You should only have one listing as follows: Java (TM) 6 update 22 - which is the latest update - any other references for Java can be deleted - click to highlight, then Remove. If you don't see "Java (TM) 6 update 22" then you need to re-apply the update.

Re-boot and full PSI re-scan may be necessary for changes to be fully recognised.

Solution(s) to .Net, will have to come later, probably from someone else.

TiMow

EDIT: I forget to check the obvious, concerning the 3 programs I have advised on ( NOT .Net ) - have you actually updated them all to the latest versions? - by clicking Download Solution on PSI - or for Chrome, from the open program, click Spanner>About Google Chrome - this will automatically check for updates - if you have, then finish reading this reply from the top.

--
Computing is not yet a perfect science - it still requires humans.
Was this reply relevant?
+1
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability