Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
hmufti My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633
Member 2nd Feb, 2011 23:30
Ranking: 0
Posts: 3
User Since: 10th Dec, 2009
System Score: 100%
Location: DE
I am using Win XP SP3 in a dual boot config:

1. Boot Partition is Drive "D:"
2. Boot Partition is Drive "G:" (on a _different_ Disk).

I detected at http://www.filehippo.com/download_realplayer/tech/
that RealNetworks releases a new version 14.0.2.633 of their Product
"Realplayer" (to solve a security problem that the previous RealPlayer version 14.0.1.609 had).

I downloaded the new version from FileHippo
but i did _not_ use the DL to install the new version.

Instead i successfully used on both partitions the option "check for updates" _inside_ the running previous version 14.0.1.609 of RealPlayer:

This way all my elaborated settings in RP's Preferences were conserved!

For example my preferred settings of the 10-band-equalizer that came
with the PLUS-Version of RP (extra-fee of 19.99 USD) remained untouched.

My Problem now:
PSI 1.5.0.2 does not detect RealPlayer 14.0.2.633 -
NOT on Drive "D:" (D:\Program Files\Real\RealPlayer\realplay.exe) and
NOT on Drive "G:" (G:\Program Files\Real\RealPlayer\realplay.exe) !!

BTW:
1. In RP/Help/About i read "Version 14.0.2.633" and "Distribution: R61EUR"
while most .exe or .dll files now show version "12.0.1.633"...

2. I use PSI 1.5.0.2 on _purpose_ since i don't like PSI 2.0.0.x because
the newer PSI installs a new service "Secunia Update Agent" (sua.exe)
which i definitely do not want to be always running...

Please _correct_ your Detection-Sytem of PSI 1.5.0.2
in order to find my 2 installations of the latest RealPlayer 14.0.2.633 !

hmufti



ddmarshall RE: My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633
Dedicated Contributor 3rd Feb, 2011 00:37
Score: 1212
Posts: 967
User Since: 8th Nov 2008
System Score: 98%
Location: UK
It's in the Secunia database, so it should detect it http://secunia.com/advisories/product/33017/?task=...
Have you done a full scan? If that doesn't work a reboot and full scan?

If you turn off Automatic Updates in the 2.0 configuration settings the Update Agent service does not run. The PSI Agent uses for scanning does still run however.

--
This answer is provided “as-is.” You bear the risk of using it.
Was this reply relevant?
+1
-0
hmufti RE: My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633
Member 3rd Feb, 2011 01:23
Score: 0
Posts: 3
User Since: 10th Dec 2009
System Score: 100%
Location: DE
Yes, i rebootet and run a full scan.
the scan found again 246 items on both partitions, all patched,
rather than the expected 248 items -
because the 2 items for my patched RP 14.0.2.633 on Part. "D:" resp. "G:"
are still missing.

I will later give your PSI 2.0.0.x another try -
But only after this problem here with PSI 1.5.0.2 is solved.

BTW:
There is also a glitch in PSI 1.5.0.2 which shows my Country
_inside_ "Germany" with this FALSE spelling: "Baden-wÜrttemberg"
rather than the CORRECT spelling: "Baden-Württemberg" !!

thanx for your fast answer

hmufti
Was this reply relevant?
+0
-0
hmufti_G RE: My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633
Member 3rd Feb, 2011 02:50
Score: 0
Posts: 5
User Since: 6th Sep 2010
System Score: 100%
Location: DE
Last edited on 3rd Feb, 2011 02:52
On the advise to reboot before doing a full scan
i rebooted to my 1. Partition "D:" with the same Result
as stated in my first posting.

Now i just fully shutted down the PC and booted up
into my 2. Partition "G:", then running again a full scan -

The result is un-changed:
PSI 1.5.0.2 can _not_ detect the latest RealPlayer 14.0.2.633 !

Another annyoing thing:
Each time a want to exit PSI 1.5.0.2
i have to right-click the trayicon of PSI and to select "Exit".
After this action the following MsgBox is presented:

---------------------------
Secunia PSI
---------------------------
If you exit the application, the Secunia PSI will no longer alert you
to Insecure/End-of-Life software installed on your computer,
increasing the chances your system could be compromised
due to out of date software.

Are you sure you want to exit the Secunia PSI?
---------------------------
Yes No
---------------------------

I suggest to add the checkbox "[v] Don't show me this again"
in order to suppress this un-needed dialog in the future.

I think right-clicking the trayicon and selecting "Exit" is enough
to prevent an _unintended_ termination of PSI!

hmufti
Was this reply relevant?
+0
-0
This user no longer exists RE: My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633
Member 3rd Feb, 2011 09:49
Hi,

Do you have any ignore rules specified? If so, disable them and try again.

Otherwise, please submit a software suggestion for the program not being detected, and explain the problem in the comments.

Was this reply relevant?
+0
-0
hmufti_G RE: My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633
Member 3rd Feb, 2011 17:32
Score: 0
Posts: 5
User Since: 6th Sep 2010
System Score: 100%
Location: DE
Thank you Mr. E.Petersen for your answer to my problem with PSI 1.5.0.2
which does _not_ detect the latest RealPlayer 14.0.2.633.
You are the first "Secunia Official" that cares about my problem.

I have _not_ specified any ignore rules, so there is nothing to disable!

Today i booted up into my 2. Boot Partition on Drive "G:" and performed
as usual a full scan with PSI 1.5.0.2 with these results:

NO "Insecure" entries, NO "End-of-Life" entries, 246 "Patched" entries.

I expected to see 248 "Patched" entries including those 2 for the latest
RealPlayer 14.0.2.633 on Boot Partitions "D:" and "G:" ,
but again as in my last full scans:

This new Version of RealPlayer is NOT detected, but all _previous_ versions
of RealPlayer were detected!

How and where in the Forum do i submit a software suggestion
for the RealPlayer you recommended for my problem?

Thanks in advance

hmufti
Was this reply relevant?
+0
-0
Maurice Joyce RE: My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633
Handling Contributor 3rd Feb, 2011 18:06
Score: 11799
Posts: 9,040
User Since: 4th Jan 2009
System Score: N/A
Location: UK
1. Open the PATCHED or SECURE BROWSING tab.
2. Scroll to the bottom where U will see a link in blue ink "Program Missing? Suggest It Here!"
3. Click the link & then fill out the details in the boxes that appear(the important bit is the FILE SELECTION).
4.Click Suggest Program.

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+1
-0
hmufti RE: My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633
Member 4th Feb, 2011 03:39
Score: 0
Posts: 3
User Since: 10th Dec 2009
System Score: 100%
Location: DE
Last edited on 4th Feb, 2011 03:41
@ Maurice Joyce, Expert Contributor
---------------------------------------------

Many thanks for your very helpful 4 steps
to place a missing program suggestion into my PSI 1.5.02 !!

I followed your 4 steps -
But on step "4." i got this MsgBox:

---------------------------
Secunia PSI
---------------------------
Unable to get data from the selected file.

This is most likely because you need to add
"https://psi.secunia.com/" to your Trusted Sites in Internet Explorer.

Open Internet Explorer. Go to "Tools" then "Internet Options" then "Security"
then select "Trusted Sites" then click "Sites"
then Add "https://psi.secunia.com/" then Close Internet Explorer

Afterward, please try to suggest this program again,
by clicking "OK" to close this dialog and then click "Suggest Program" once more.
---------------------------
OK
---------------------------

After that i added "https://psi.secunia.com/" to my Trusted Sites in IE8...
Thereafter i could _succesfully_ suggest inside PSI 1.5.0.2 these 2 Programs:

1. D:\Program Files\Real\RealPlayer\realplay.exe (with new Version 12.0.1.633)
2. G:\Program Files\Real\RealPlayer\realplay.exe (with new Version 12.0.1.633)

I did this after booting up _each_ of my 2 Boot-Partitions "D:" and "G:" -

BTW, each of my 2 Boot-Partitions contains the _same_ programs,
so each Boot-Partition serves as my emergency-bootup
in case the other Boot-Partition is damaged...

Nevertheless, after these program suggestions
the latest RealPlayer 14.0.2.633 so far is still _not_ detected
whenever i run a full scan in my PSI 1.5.02...

Sincerly yours
hmufti
Was this reply relevant?
+0
-0
hmufti_G RE: My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633
Member 4th Feb, 2011 08:53
Score: 0
Posts: 5
User Since: 6th Sep 2010
System Score: 100%
Location: DE
@ Mr. E.Petersen, Secunia Official
------------------------------------------

Hi Mr. Petersen,

according to your last posting in reply to my first posting
under Topic "My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633"
i began to follow your recommendations to solve the problem.

Your Expert Contributor Maurice Joyce gave me helpful hints,
how to submit a software suggestion for the program not being detected,
i.e. the latest RealPlayer 14.0.2.633 -
for details see my thankful reply to his 4 steps how i succesfully did this.

But what do you mean in your last reommendation to
"explain the problem in the comments" ?

Yes, i can explain my problem, but in which "comments" ??

Please give me a another/clearer description of your final advice to me!

BTW, my daily full scans in both starttup-partitions with PSI 1.5.9.2
still can _not_ detect the latest RealPlayer 14.0.2.633.

Kind regards,
hmufti
Was this reply relevant?
+0
-0
This user no longer exists RE: My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633
Member 4th Feb, 2011 09:22
Hi,

I meant the comments on the software suggestion.

I believe I have found and corrected the source of the problem. If you run a full rescan now, does the PSI pick up RealPlayer?
Was this reply relevant?
+0
-0
hmufti_G RE: My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633
Member 4th Feb, 2011 19:58
Score: 0
Posts: 5
User Since: 6th Sep 2010
System Score: 100%
Location: DE
Last edited on 4th Feb, 2011 20:01
@ Mr. E.Petersen, Secunia Official
------------------------------------------

Hi Mr. Petersen,

I have read your latest posting on my problem already this morning
_after_ booting up to my boot-partition on drive "D:" and
_after_ running a full scan in PSI 1.5.9.2 which took as usual
about 3 minutes and 30 to 40 seconds. The result again was negative:
My PSI 1.5.0.2 did not detect the latest RealPlayer 14.0.2.633.

But since your posting stated
"I believe I have found and corrected the source of the problem."
i re-run the full scan - again with negative result...

But i observed also that this re-run lasted only 30 to 40 seconds,
so a terminated PSI completely and started it again,
then starting a full scan which took _again_ only 30 to 40 seconds -
again with negative result...

Where does PSI 1.5.0.2 cache it's findings, so that it can finish
a full scan within only 30-40 seconds?

Therefore a waited until this afternoon where i rebooted
into my 2. Boot-Partition on Drive "G:".

Since i run on each shutdown or reboot my own logoff .cmd script
which removes many files that otherwise would steadily grow and grow
(e.g. the index.dat of the "Temporary Internet Files"
or the "WindowsUpdate.log and many other files)
i now was good prepared to run PSI 1.5.0.2 from fresh again...

The full scan then took again as usual about 3 minutes and 30 to 40 seconds. The result again was negative:
My PSI 1.5.0.2 did _not_ detect the latest RealPlayer 14.0.2.633.

My Conclusion:
You have _not_ found and corrected the source of the problem!!

You also told me
"I meant the comments on the software suggestion." -

NO, inside the dialog to suggest a missing program
are only 3 Fields to fill in:

1. The full path (including the executable itself) to the missing program.
This must be selected from several screens and can _not_ manually altered.
I selected
"D:\Program Files\Real\RealPlayer\realplay.exe" and also
"G:\Program Files\Real\RealPlayer\realplay.exe".

2. The Name of the missing program which must be manually typed in.
I typed in "RealPlayer 12.0.1.633" since that is shown
in the Properties of "realplay.exe".

3. Some "Link" must be manually typed in.
I typed in "http://www.filehippo.com/download_realplayer/tech/"
since many users use this Link to download the latest
"RealPlayer 14.0.2.633" to some of their local disks
to later install it in one or more boot-partitions.

But there is/are _no_ additional field(s) to leave
"comments on the software suggestion" as you told me!!

Kind regards,
hmufti
Was this reply relevant?
+0
-0
hmufti_G RE: My PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633
Member 12th Feb, 2011 10:00
Score: 0
Posts: 5
User Since: 6th Sep 2010
System Score: 100%
Location: DE
Last edited on 12th Feb, 2011 10:24
@ Mr. E.Petersen, Secunia Official
------------------------------------------

Hi Mr. Petersen,

this is my 2. reply on your last recommendations to solve my problem.

I wrote my 1. reply on the same day
you gave me your last recommendations.

Today, 12. Feb 2011, i.e. 8 days later,
i still have no answer on my 1. reply
and i still have the original problem, i.e.
my PSI 1.5.0.2 does not detect the latest RealPlayer 14.0.2.633.

In the meantime i updated a few of my programs (not RealPlayer),
so my last full scan with PSI 1.5.0.2 reports more programs:

No "Insecure", no "End-of-Life" and 255 "Patched" programs -
but my RealPlayer 14.0.2.633 is still _not_ found...

I also investigated Secunia's huge Database of Vendors together
with the different programs or program-versions published.

I found in this Database that Vendor "RealNetworks"
offers different programs and one of them is "RealPlayer"
with 12 _different_ versions for "RealPlayer".

Attention:

What i report as "RealPlayer 14.0.2.633" in this thread's Topic and it's replies
appears in Secunia's Database as "RealPlayer 14.x" !!

Maybe, these _different_ versions for the _same_ product
are the reason for my missing "RealPlayer 14.0.2.633" !!

Some more hints on the "RealPlayer" -

1. It can be installed _only_ on a real windows partition,
i.e. for my _english_ version of Win XP SP3 (32-bit)
a partition with 3 main folders
"Documents and Settings", "Program Files" and "WINDOWS".

2. It can be installed in Folder "Program Files\Real"
OR in Folder "Program Files\Real\RealPlayer",
i have chosen the _latter_ at install time.

3. In Folder "Program Files\Real\RealPlayer" i find 10 .exe files,
especially "Program Files\Real\RealPlayer\realplay.exe",
all 10 with the _same_ version "12.0.1.633".

So i suggest, to _extend_ Secunia's Detection System for "RealPlayer"
to include a search for versions "14.0.2.633 OR 14.x OR 12.0.1.633" !!

Hopefully this may help!

Kind regards
hmufti
Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability - Disclaimer