Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: Firefox 4.0 not detected under PSI 2.0.0.3001

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as resolved.
Compumind Firefox 4.0 not detected under PSI 2.0.0.3001
Member 22nd Mar, 2011 20:28
Ranking: 8
Posts: 54
User Since: 2nd Feb, 2010
System Score: N/A
Location: US
Hi -

Just installed Firefox 4.0 which was never on this XP SP3 system and to my amazement, the latest edition of the PSI did not detect it.

What's up?


Post "RE: Firefox 4.0 not detected under PSI 2.0.0.3001" has been selected as an answer.
smallbiz RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 22nd Mar, 2011 20:56
Score: 16
Posts: 19
User Since: 26th Sep 2009
System Score: N/A
Location: N/A
I think that what you installed was the RC version ('Release Candidate') that will be kicked around for a while, to pick up the kinds of it-doesn't-work bug yells that are harvested when the audience is extended beyond the early-adopter computer nerd users who have been testing it for months.

As a matter of good policy, PSI never recognizes a product until it is the final RTW ('release to web') version. These guys are smart! smallbiz
Was this reply relevant?
+0
-1
Compumind RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 22nd Mar, 2011 21:16
Score: 8
Posts: 54
User Since: 2nd Feb 2010
System Score: N/A
Location: US
@smallbiz -

No, today was the full release (RTM).

Check for yourself...

:0)
Was this reply relevant?
+1
-0
Maurice Joyce RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Handling Contributor 22nd Mar, 2011 21:20
Score: 11744
Posts: 9,002
User Since: 4th Jan 2009
System Score: N/A
Location: UK
It does take Secunia a little while to update the database.

Have U completed a full PSI rescan?

If U have & it is still not showing U can suggest the new programme to them:

SUGGESTING A NEW PROGRAMME TO SECUNIA

VERSION 2

1. From the DASHBOARD page click on RESULTS.
2. On the RESULTS page look above the tab INSTALL SOLUTION & U will see a green icon & ARE YOU MISSING A PROGRAM?
3. Click it. Fill out the details requested.
4. Click SUGGEST SOFTWARE.

ALL OLDER PSI VERSIONS

1. Open the PATCHED or SECURE BROWSING tab.
2. Scroll to the bottom where U will see a link in blue ink "Program Missing? Suggest It Here!"
3. Click the link & then fill out the details in the boxes that appear(the important bit is the FILE SELECTION).
4.Click Suggest Program.

Normally,Secunia do not respond to any request for programme inclusion nor do they accept programmes in Beta.

After a reasonable time lapse a full rescan of PSI should reveal the new programme.

Update 6 20:48 09/03/2011


--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+2
-0
mogs RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Expert Contributor 22nd Mar, 2011 21:31
Score: 2265
Posts: 6,266
User Since: 22nd Apr 2009
System Score: 100%
Location: UK
@smallbiz

Here's an extract from an article :-
Firefox 4.0’s Love for XP Is a Drawback for the Web
March 22nd, 2011, 18:44 GMT| By Marius Oiaga
Users worldwide have been able to download Firefox 4.0 Final since March 21st, 2011 as Softpedia readers know very well, but Mozilla only officially launched the browser today (1.9 million downloads already at the time of this article).

http://news.softpedia.com/news/Firefox-4-0-s-Love-...

--
Was this reply relevant?
+2
-0
Compumind RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 22nd Mar, 2011 21:52
Score: 8
Posts: 54
User Since: 2nd Feb 2010
System Score: N/A
Location: US
Hi all -

Tried "suggesting" Firefox 4.0...

PSI would not accept the Firefox.exe path as being valid (!)

C:\fakepath\firefox.exe (this was the result.)

Strange...

It is under the Mozilla Firefox folder under Program Files.
Was this reply relevant?
+0
-0
Websafe RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 22nd Mar, 2011 23:28
Score: 79
Posts: 105
User Since: 24th May 2009
System Score: 100%
Location: NL
Hello Compumind and all,

C:\fakepath is explained in the PSI FAQ under question 17, link: http://secunia.com/products/consumer/PSI/faq/#q17

Just installed Firefox 4.0 and also missed the browser from PSI 2.0.0.3001. Used the “Suggest a Program” to report Firefox 4.0 to Secunia.

Enjoy your new Firefox,
Websafe.
Was this reply relevant?
+5
-0
Compumind RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 22nd Mar, 2011 23:57
Score: 8
Posts: 54
User Since: 2nd Feb 2010
System Score: N/A
Location: US
Hi Websafe:

Thanks for that info!

However, what if I uninstalled IE 8 and just had Firefox 4?

How would it be configured then?

Curious...

Compumind :0)
Was this reply relevant?
+0
-1
Websafe RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 23rd Mar, 2011 00:47
Score: 79
Posts: 105
User Since: 24th May 2009
System Score: 100%
Location: NL
Hello Compumind,

You might be able to downgrade to IE7. But it seems to me not possible to fully uninstal Internet Explorer since it is highly integrated with the Operating System.
Anyway PSI uses Internet Explorer and likely won't work with Firefox only.

Have a nice day,
Websafe.
Was this reply relevant?
+3
-0
Websafe RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 23rd Mar, 2011 15:24
Score: 79
Posts: 105
User Since: 24th May 2009
System Score: 100%
Location: NL
Hello all,

Firefox 4.0 is recognised by the PSI after my latest scan at 14:00 UTC. However I'm missing the “auto update” feature in combination with Firefox 4.0.
Unfortunately Firefox 4.0 does not show up at the “Secure Browsing” page. Perhaps just a matter of time.

Windows XP-home SP3 – 32 bit PSI 2.0.0.3001 and
Windows Vista-home Premium – 32 bit PSI 2.0.0.2001.

Websafe.
Was this reply relevant?
+1
-0
Maurice Joyce RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Handling Contributor 23rd Mar, 2011 16:09
Score: 11744
Posts: 9,002
User Since: 4th Jan 2009
System Score: N/A
Location: UK
I think U are correct. IE9 is still not showing yet in Secure Browsing.

--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+0
-1

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability - Disclaimer