Forum Thread: Firefox 4.0 not detected under PSI 2.0.0.3001

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as resolved.
Compumind Firefox 4.0 not detected under PSI 2.0.0.3001
Member 22nd Mar, 2011 20:28
Ranking: 8
Posts: 54
User Since: 2nd Feb, 2010
System Score: N/A
Location: US
Hi -

Just installed Firefox 4.0 which was never on this XP SP3 system and to my amazement, the latest edition of the PSI did not detect it.

What's up?


Post "RE: Firefox 4.0 not detected under PSI 2.0.0.3001" has been selected as an answer.
smallbiz RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 22nd Mar, 2011 20:56
Score: 16
Posts: 19
User Since: 26th Sep 2009
System Score: N/A
Location: N/A
I think that what you installed was the RC version ('Release Candidate') that will be kicked around for a while, to pick up the kinds of it-doesn't-work bug yells that are harvested when the audience is extended beyond the early-adopter computer nerd users who have been testing it for months.

As a matter of good policy, PSI never recognizes a product until it is the final RTW ('release to web') version. These guys are smart! smallbiz
Was this reply relevant?
+0
-1
Compumind RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 22nd Mar, 2011 21:16
Score: 8
Posts: 54
User Since: 2nd Feb 2010
System Score: N/A
Location: US
@smallbiz -

No, today was the full release (RTM).

Check for yourself...

:0)
Was this reply relevant?
+1
-0
Maurice Joyce RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Handling Contributor 22nd Mar, 2011 21:20
Score: 12090
Posts: 9,383
User Since: 4th Jan 2009
System Score: N/A
Location: UK
It does take Secunia a little while to update the database.

Have U completed a full PSI rescan?

If U have & it is still not showing U can suggest the new programme to them:

SUGGESTING A NEW PROGRAMME TO SECUNIA

VERSION 2

1. From the DASHBOARD page click on RESULTS.
2. On the RESULTS page look above the tab INSTALL SOLUTION & U will see a green icon & ARE YOU MISSING A PROGRAM?
3. Click it. Fill out the details requested.
4. Click SUGGEST SOFTWARE.

ALL OLDER PSI VERSIONS

1. Open the PATCHED or SECURE BROWSING tab.
2. Scroll to the bottom where U will see a link in blue ink "Program Missing? Suggest It Here!"
3. Click the link & then fill out the details in the boxes that appear(the important bit is the FILE SELECTION).
4.Click Suggest Program.

Normally,Secunia do not respond to any request for programme inclusion nor do they accept programmes in Beta.

After a reasonable time lapse a full rescan of PSI should reveal the new programme.

Update 6 20:48 09/03/2011


--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1607 Build 14393.222
16 GB RAM
IE & Edge Only
Was this reply relevant?
+2
-0
mogs RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 22nd Mar, 2011 21:31
Score:
Posts: 6,279
User Since: 22nd Apr 2009
System Score: N/A
Location: UK


--
Was this reply relevant?
+2
-0
Compumind RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 22nd Mar, 2011 21:52
Score: 8
Posts: 54
User Since: 2nd Feb 2010
System Score: N/A
Location: US
Hi all -

Tried "suggesting" Firefox 4.0...

PSI would not accept the Firefox.exe path as being valid (!)

C:\fakepath\firefox.exe (this was the result.)

Strange...

It is under the Mozilla Firefox folder under Program Files.
Was this reply relevant?
+0
-0
Websafe RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 22nd Mar, 2011 23:28
Score: 79
Posts: 105
User Since: 24th May 2009
System Score: 100%
Location: NL
Was this reply relevant?
+5
-0
Compumind RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 22nd Mar, 2011 23:57
Score: 8
Posts: 54
User Since: 2nd Feb 2010
System Score: N/A
Location: US
Hi Websafe:

Thanks for that info!

However, what if I uninstalled IE 8 and just had Firefox 4?

How would it be configured then?

Curious...

Compumind :0)
Was this reply relevant?
+0
-1
Websafe RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 23rd Mar, 2011 00:47
Score: 79
Posts: 105
User Since: 24th May 2009
System Score: 100%
Location: NL
Hello Compumind,

You might be able to downgrade to IE7. But it seems to me not possible to fully uninstal Internet Explorer since it is highly integrated with the Operating System.
Anyway PSI uses Internet Explorer and likely won't work with Firefox only.

Have a nice day,
Websafe.
Was this reply relevant?
+3
-0
Websafe RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Member 23rd Mar, 2011 15:24
Score: 79
Posts: 105
User Since: 24th May 2009
System Score: 100%
Location: NL
Was this reply relevant?
+1
-0
Maurice Joyce RE: Firefox 4.0 not detected under PSI 2.0.0.3001
Handling Contributor 23rd Mar, 2011 16:09
Score: 12090
Posts: 9,383
User Since: 4th Jan 2009
System Score: N/A
Location: UK
I think U are correct. IE9 is still not showing yet in Secure Browsing.

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1607 Build 14393.222
16 GB RAM
IE & Edge Only
Was this reply relevant?
+0
-1

This thread has been marked as locked.