Secunia CSI7
Advisories
Research
Forums
Create Profile
Our Commitment
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: platform detection error, VMware Workstation 7.1.4 (I think)

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
Programs

Relating to this vendor:
VMware
And, this specific program:
VMware Workstation 7.x

This thread has been marked as resolved.
libove platform detection error, VMware Workstation 7.1.4 (I think)
Member 31st Mar, 2011 21:17
Ranking: 31
Posts: 71
User Since: 12th Feb, 2008
System Score: N/A
Location: N/A
I suspect that PSI 2.0 (2.0.0.1003) has a minor database error regarding the current version of VMware Workstation 7.1.4 on Windows. PSI on my Windows 7 (Ultimate, 64-bit) system is reporting that the just updated VMware Workstation 7.1.4 build 385536 on the system is out of date as version 7.1.4 build 16648.
The vulnerability announcement link to VMware's web site (https://www.vmware.com/security/advisories/VMSA-20...), in the Secunia page for this program (http://secunia.com/advisories/43885/), is about a Linux-only vulnerability. In fact, the Secunia web page even correctly notes that this is a Linux-only vulnerability.

So why is it reporting that my installed VMware Workstation version is out of date or insecure?


Program Name:
VMware Workstation 7.x

Security State:
Insecure

Download Link:
http://downloads.vmware.com/d/info/desktop_downloa...

Instances Found:
C:\Program Files (x86)\VMware\VMware Workstation\vmware.exe, version: 7.1.4.16648

Last System Scan (localtime):
31. Mar 2011, 16:01

Operating System:
Microsoft Windows 7,


Post "RE: platform detection error, VMware Workstation 7.1.4 (I think)" has been selected as an answer.
gbohn RE: platform detection error, VMware Workstation 7.1.4 (I think)
Member 1st Apr, 2011 00:04
Score: 0
Posts: 1
User Since: 31st Mar 2011
System Score: N/A
Location: US
I see the same issue with Secunia PSI 1.5.0.2 on Windows 7 SP1.

It tags my (Windows) VMWare workstation '7.1.4 build-385536' install as insecure (despite this supposedly being a Linux only issue). The string I just quoted is what is being reported by the VmWare workstation 'Help/About' page.

Since PSI called out the file 'vmware.exe', I went to the folder for it and clicked on details. It says:

Product Version: 7.1.4 build-385536
File Version: 7.1.4.16648

-Greg
Was this reply relevant?
+0
-0
stephensussman RE: platform detection error, VMware Workstation 7.1.4 (I think)
Member 1st Apr, 2011 02:15
Score: 1
Posts: 8
User Since: 9th Dec 2010
System Score: N/A
Location: N/A
I see the same. PSI 2.0, Win7x64SP1
Was this reply relevant?
+0
-0
Maurice Joyce RE: platform detection error, VMware Workstation 7.1.4 (I think)
Handling Contributor 1st Apr, 2011 02:28
Score: 11744
Posts: 9,000
User Since: 4th Jan 2009
System Score: N/A
Location: UK
As U are perhaps aware the Secunia Officials are extremely busy elsewhere.

I have sent an email to them requesting their assistance/explanation on this issue for U all.



--
Maurice

Windows 7 SP1 64 Bit OS
HP Intel Pentium i7
IE 11 for Windows 7 SP1
16GB RAM
Was this reply relevant?
+1
-0
BLindow RE: platform detection error, VMware Workstation 7.1.4 (I think)
Secunia Official 1st Apr, 2011 08:52
Score: 35
Posts: 35
User Since: 6th Nov 2009
System Score: N/A
Location: Copenhagen, DK
Hi,
Thank you for reporting this issue.

We have corrected our rules and it should be shown correctly after a re-scan with Secunia PSI.

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 VARS
MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


 
© 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability - Disclaimer