navigation bar left navigation bar right

Secunia CSI7
navigation left tab Advisories navigation right tab
navigation left tab Research navigation right tab
navigation left tab Forums navigation right tab
navigation left tab Create Profile navigation right tab
navigation left tab Our Commitment navigation right tab
PSI
PSI API
CSI
OSI
xSI
Vulnerabilities
Programs
Open Discussions
My Threads
Create Thread
Statistics
About

Forum Thread: 0% System Score -- Exception SDRD01

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
thokea 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 11:12
Ranking: 0
Posts: 2
User Since: 6th Apr, 2011
System Score: N/A
Location: US
Have been running PSI 2.0 for a while when tonight I encounter a case where the scan appears to come up empty, the score is 0% and the log notes several instances of:

Exception SDRD01 : -2146823281 , 'length' is null or not an object

When I click on "dashboard" in the PSI window, I get:

Error: TypeError
Function: util.switchPage
File: undefined
Line: undefined
Description: 'length' is null or not an object

Will try re-installing and see if that helps ...




thokea RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 11:19
Score: 0
Posts: 2
User Since: 6th Apr 2011
System Score: N/A
Location: US
after reinstall the same problem exists
Was this reply relevant?
+1
-1
Lion106 RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 11:19
Score: 0
Posts: 1
User Since: 6th Apr 2010
System Score: N/A
Location: N/A
I have the same problem. Secunia-people help me!
Was this reply relevant?
+1
-1
tommy cockles RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 11:20
Score: 0
Posts: 5
User Since: 25th Nov 2009
System Score: N/A
Location: N/A
Last edited on 6th Apr, 2011 11:20
i have the same problem and have tried reinstalling and no joy.. i tried an older version and the same thing ocurred........except aborting scan automatically
Was this reply relevant?
+1
-1
Leendert Kip System Score -- Exception SDRD01
Member 6th Apr, 2011 11:31
Score: 70
Posts: 526
User Since: 22nd Jan 2009
System Score: 100%
Location: NL
on 6th Apr, 2011 11:19, thokea wrote:
after reinstall the same problem exists

I see the same after startup of my pc at 11.00hrs Amsterdam time. It's the typical behaviour in case there are server problems at Secunia. Uninstalling-
installing will not help. Wait a few hours and start a scan manually. And keep
an eye on the forum.


--
PC: JJ Computer Services
Intel Core I3 2100 3.1Ghz
DDR3 Kingston ValueRam 4GB 1333
Windows 7 Home Premium 64bits SP1
Secunia PSI 3.0.0.9016
Internet Explorer 9
Mozilla Firefox 31NL

Laptop: MSI GT780DX
Intel Core I5-2450
DDR3 RAM 6GB
Windows 7 Home Premium 64bits SP1
Secunia PSI 3.0.0.9016
Internet Explorer 11
Mozilla Firefox 31NL
Was this reply relevant?
+3
-0
Michael37 RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 11:34
Score: 0
Posts: 2
User Since: 30th Oct 2008
System Score: 100%
Location: Bridlington, UK
I am the same so system isn't working so I will wait a few hours then retry a manual scan.
Was this reply relevant?
+1
-1
froglady26 RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 12:05
Score: 0
Posts: 1
User Since: 18th Nov 2010
System Score: N/A
Location: N/A
I have a similar problem that Secunia all of a sudden lost all past scan information and isn't finding any programs, patched or otherwise. I haven't tried uninstalling and reinstalling but it sounds like this doesn't help.

This is my work computer. I haven't checked my home computers yet today to see if they have the same.

Advice, please.
Was this reply relevant?
+1
-1
Anthony Wells RE: 0% System Score -- Exception SDRD01
Expert Contributor 6th Apr, 2011 12:06
Score: 2463
Posts: 3,348
User Since: 19th Dec 2007
System Score: N/A
Location: N/A

Hi ,

I can confirm that my version of the PSI here in the South of France is having the same problem and the icon is switching from red 0% to green 100% from time to time .

As per LK , this is typical of a server connection problem at the Secunia end of the system and there is nothing you can do but wait for them to put the server back to work ; you will need to be patient and check it every hour so if you are the anxious type !!

Take care

Anthony

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+3
-1
rex_shep RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 12:09
Score: 0
Posts: 2
User Since: 16th Jul 2008
System Score: N/A
Location: N/A
exactly the same on my pc (XP Home Pro) - has been doing it for 4 or 5 days.

but, oddly, no probs on my pc that has Vista.

Weird!
Was this reply relevant?
+0
-0
Anthony Wells RE: 0% System Score -- Exception SDRD01
Expert Contributor 6th Apr, 2011 12:15
Score: 2463
Posts: 3,348
User Since: 19th Dec 2007
System Score: N/A
Location: N/A

@rex_shep ,

It is probable that you have a different problem specific to your system using XP , so I suggest you start your own thread if you want help on solving the problem .You could wait until the servers are back up by monitoring the Forum and this thread .

Anthony



--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+1
-0
Anthony Wells RE: 0% System Score -- Exception SDRD01
Expert Contributor 6th Apr, 2011 12:20
Score: 2463
Posts: 3,348
User Since: 19th Dec 2007
System Score: N/A
Location: N/A

@froglady26 ,

The PSI GUI is only an interface between you and the Secunia servers . Your data is almost entirely stored on the servers and is not lost merely unavailable to you ; you will get things back including your last scan data when there is a renewed internet connection .

No worries :))

Anthony

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+1
-0
tasfield RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 12:24
Score: 0
Posts: 1
User Since: 6th Apr 2011
System Score: N/A
Location: NZ
Have exactly same thing on my machine
I have reloaded and updated Secunia 2.0 I am running on XP SP#
Was this reply relevant?
+0
-0
jopjop RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 12:27
Score: 0
Posts: 2
User Since: 10th Jan 2008
System Score: N/A
Location: N/A
Aparently the program updatd it self.

Came out and said tha it had deleted 99 peograms.

Shen scanning no result is coming up!!

Help?????
Was this reply relevant?
+0
-0
cudBwrong RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 12:39
Score: 3
Posts: 3
User Since: 1st Mar 2011
System Score: N/A
Location: US
Exact same symptoms, even after reinstall. It was working properly for weeks. Someone broke something on the server side. Kindly investigate.
Was this reply relevant?
+1
-1
dcmehl RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 12:54
Score: 0
Posts: 3
User Since: 6th Sep 2010
System Score: 99%
Location: US
I am also getting a 0% system score.
I have been running PSI 2.0 for months on 64-bit Vista.
When I open PSI and rescan, I get a 0% score and no programs are found.

I am not finding the SDRD01 exception.
Was this reply relevant?
+1
-1
dcmehl RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 13:28
Score: 0
Posts: 3
User Since: 6th Sep 2010
System Score: 99%
Location: US
I've rebooted my system and I still get no programs found and a 0% score in PSI. I do not see the Excetion SDRD01 (yet) but I do see an error when I try to open the dashboard which says:

Error
Error: TypeError
Function: uil.switchPage
File: undefined
Line: undefined
Description: Unable to get value of the property 'length': object is null or undefined

When I open PSI, I am getting the "Welcome to the Secunia PSI" banner as if the program is being opened for the first time.

After I scan my results are:

The Secunia PSI has successfully scanned your PC
The scan of your PC completed successfully, a quick summary of the scan is available below. For indepth results, please click the "View Scan Results" button.

Secunia System Score: 0%

Programs found:
0 Inscure programs
0 End-of-Life programs
0 Patched programs
===========
0 Total

When I try to open the dashboard after the "scan" I get the same "object is null of undefined" error as above (before the scan).

My scan results show no programs.
Was this reply relevant?
+1
-1

dcmehl

RE: 0% System Score -- Exception SDRD01
[+]
This reply has been deleted
Freebyrdwil RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 13:40
Score: 3
Posts: 8
User Since: 11th Nov 2009
System Score: N/A
Location: N/A
Same issue in South Florida, Secunia Need Your Help!
Thank You
Was this reply relevant?
+0
-0
azorro666 RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 13:46
Score: 0
Posts: 1
User Since: 6th Apr 2011
System Score: N/A
Location: DE
The same problem with two of us here in Berlin, Germany.

Hope you get it straightened out.
Was this reply relevant?
+0
-0
tdc2316 RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 14:04
Score: 0
Posts: 1
User Since: 6th Apr 2011
System Score: N/A
Location: N/A
exactly the same problems in Northern Germany
tdc2316
Was this reply relevant?
+0
-0
Anthony Wells RE: 0% System Score -- Exception SDRD01
Expert Contributor 6th Apr, 2011 16:20
Score: 2463
Posts: 3,348
User Since: 19th Dec 2007
System Score: N/A
Location: N/A

Hi ,

My system is now fixed as at 16.00hrs CET in the South of France ; in my case the PSI automatically reset to "normal" when I opened the PSI from a red tray icon : you may need to run a manual scan .

This does not guarantee that your server location is fixed , merely that Secunia are working on the problem :))

Take care

Anthony

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+0
-0
Anthony Wells RE: 0% System Score -- Exception SDRD01
Expert Contributor 6th Apr, 2011 16:52
Score: 2463
Posts: 3,348
User Since: 19th Dec 2007
System Score: N/A
Location: N/A


Hello again ,

You should read this thread and scroll down to see the post from Morten Hansen , Secunia official) about tomorrow's repeat of the problem :-

http://secunia.com/community/forum/thread/show/802...

Anthony

--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+0
-0
rex_shep RE: 0% System Score -- Exception SDRD01
Member 6th Apr, 2011 21:30
Score: 0
Posts: 2
User Since: 16th Jul 2008
System Score: N/A
Location: N/A
5.30am local time in Australia and PSI has resumed working on my pc that has XP Pro. The problem never occurred on my other pc that has Vista. To those responsible for the fix, "Thanks! Well done!"
Was this reply relevant?
+0
-0
cudBwrong RE: 0% System Score -- Exception SDRD01
Member 7th Apr, 2011 17:19
Score: 3
Posts: 3
User Since: 1st Mar 2011
System Score: N/A
Location: US
Everything is working OK now, thanks to everyone who helped.

(Northeast USA)
Was this reply relevant?
+0
-0

This thread has been marked as locked.


 Products Solutions Customers Partner Resources Company
 
 Corporate
Vulnerability Intelligence Manager (VIM)
Corporate Software Inspector (CSI)
Consumer
Personal Software Inspector (PSI)
Online Software Inspector (OSI)
 Industry
Compliance
Technology
Integration
 Customers
Testimonials
 MSSP
Technology Partners
References
 Reports
Webinars
Events
 About us
Careers
Memberships
Newsroom


Secunia is a member of FIRST Secunia is a member of EDUcause Secunia is a member of The Open Group Secunia is a member of FS-ISAC
 
Secunia © 2002-2014 Secunia ApS - Rued Langgaards Vej 8, 4th floor, DK-2300 Copenhagen, Denmark - +45 7020 5144
Terms & Conditions and Copyright - Privacy - Report Vulnerability - Disclaimer
follow Secunia on Facebook follow Secunia on Twitter follow Secunia on LinkedIn follow Secunia on YouTube follow Secunia Xing follow Secunias RSS feed follow Secunia on Google+